Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
The_Strict_Nein

Cannot get Windows Update to work

Solved it, turns out that Intel's RST predecessor completely bricks Windows Update 

Recommended Posts

Posted · Original PosterOP

I'm having the issue where-by Windows Update says it's not working due to the service not running. I'm running Windows 7 Professional 64-Bit SP1.

 

If you google 'Windows 7 Professional Windows Update not working' I've tried literally everything on that first page. None of the automated utilities have done anything to help. Any advice?

 

EDIT:

 

I have literally just installed the OS, so no previous updates are installed and windows update has never worked before on this PC, hence.


CPU: AMD Ryzen 7 3700X - CPU Cooler: Deepcool Castle 240EX - Motherboard: MSI B450 GAMING PRO CARBON AC - RAM: 2 x 8GB Corsair Vengeance Pro RBG 3200MHz - GPU: EVGA RTX 2080 XC ULTRA - Case: Fractal Design Arc Midi R2

 

Storage: 512GB Samsung 950 Pro - PSU: EVGA SuperNOVA G2 750W - Mouse: Logitech G502 Proteus Core - Keyboard: Logitech G810 - Headphone: Audio Technica ATH-M50X / Sennheiser HD600 - Monitor: Dell U2414H

 

Link to post
Share on other sites

I'm having the issue where-by Windows Update says it's not working due to the service not running. I'm running Windows 7 Professional 64-Bit SP1.

 

If you google 'Windows 7 Professional Windows Update not working' I've tried literally everything on that first page. None of the automated utilities have done anything to help. Any advice?

 

EDIT:

 

I have literally just installed the OS, so no previous updates are installed and windows update has never worked before on this PC, hence.

 

Is the copy legit? If not that may be the problem.


"Do not pray for and easy life, pray for the strength to endure a difficult one."

 

"A place where everything and nothing exists, this is my playground."

Link to post
Share on other sites
Posted · Original PosterOP

Legitimate OEM copy, first time used, and activated with Microsoft's online activation.

Specs are on my profile page


CPU: AMD Ryzen 7 3700X - CPU Cooler: Deepcool Castle 240EX - Motherboard: MSI B450 GAMING PRO CARBON AC - RAM: 2 x 8GB Corsair Vengeance Pro RBG 3200MHz - GPU: EVGA RTX 2080 XC ULTRA - Case: Fractal Design Arc Midi R2

 

Storage: 512GB Samsung 950 Pro - PSU: EVGA SuperNOVA G2 750W - Mouse: Logitech G502 Proteus Core - Keyboard: Logitech G810 - Headphone: Audio Technica ATH-M50X / Sennheiser HD600 - Monitor: Dell U2414H

 

Link to post
Share on other sites
Posted · Original PosterOP

If that's Microsoft's automated tool it doesn't work. It just instantly says there has been problem and goes no further


CPU: AMD Ryzen 7 3700X - CPU Cooler: Deepcool Castle 240EX - Motherboard: MSI B450 GAMING PRO CARBON AC - RAM: 2 x 8GB Corsair Vengeance Pro RBG 3200MHz - GPU: EVGA RTX 2080 XC ULTRA - Case: Fractal Design Arc Midi R2

 

Storage: 512GB Samsung 950 Pro - PSU: EVGA SuperNOVA G2 750W - Mouse: Logitech G502 Proteus Core - Keyboard: Logitech G810 - Headphone: Audio Technica ATH-M50X / Sennheiser HD600 - Monitor: Dell U2414H

 

Link to post
Share on other sites

go to services by typing it in the search bar then scroll all the way down to windows update the right click the service named 'windows update' then click start. try running it after that has been started 


i7 875k @ 4.2 GHz, MSI BIG BANG TRINERGY BOARD, 16GB RAM, OCZ AGILITY 120GB SSD, MSI GTX 580, FULL CUSTOM WATERCOOLED

Link to post
Share on other sites
Posted · Original PosterOP

go to services by typing it in the search bar then scroll all the way down to windows update the right click the service named 'windows update' then click start. try running it after that has been started

I have done that. As I said, I googled this and tried everything on the first and second page. None of it worked


CPU: AMD Ryzen 7 3700X - CPU Cooler: Deepcool Castle 240EX - Motherboard: MSI B450 GAMING PRO CARBON AC - RAM: 2 x 8GB Corsair Vengeance Pro RBG 3200MHz - GPU: EVGA RTX 2080 XC ULTRA - Case: Fractal Design Arc Midi R2

 

Storage: 512GB Samsung 950 Pro - PSU: EVGA SuperNOVA G2 750W - Mouse: Logitech G502 Proteus Core - Keyboard: Logitech G810 - Headphone: Audio Technica ATH-M50X / Sennheiser HD600 - Monitor: Dell U2414H

 

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

Solved it, turns out that Intel's RST predecessor completely bricks Windows Update 


CPU: AMD Ryzen 7 3700X - CPU Cooler: Deepcool Castle 240EX - Motherboard: MSI B450 GAMING PRO CARBON AC - RAM: 2 x 8GB Corsair Vengeance Pro RBG 3200MHz - GPU: EVGA RTX 2080 XC ULTRA - Case: Fractal Design Arc Midi R2

 

Storage: 512GB Samsung 950 Pro - PSU: EVGA SuperNOVA G2 750W - Mouse: Logitech G502 Proteus Core - Keyboard: Logitech G810 - Headphone: Audio Technica ATH-M50X / Sennheiser HD600 - Monitor: Dell U2414H

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×