Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Britanian

The Britannix: My first Build.

Recommended Posts

Posted · Original PosterOP

Parts list:

AMD FX8350 

Asus m5a99fx pro r2.0

2x4gb Corsair Vengeance pro 1333mhz

R9270x Gigabyte oc windforce

Cooler master hyper 212 evo

Cs 750m

WD Caviar Blue 1tb

Samsun 840 evo 120gb

Fractal Design Define r4

Windows 7

ALBA LCD19880hdf

 

The build went to plan, my only concern was that i had to apply quite a lot of pressure to the hyper 212 evo to fit the screws when placing the heat sink over the cpu. I first only plugged the SSD in because i didn't want to install my os on the HDD. once the os was installed i plugged it back in; it was recognized but didn't come up as a drive letter. i later found that i have to assign it to drive letter.

 

The drivers were slightly difficult to install as the screen cut off about 1/16 of the bottom of the page. i had to use a lot tab and enter, trial and error. once i had the graphics drivers installed it worked fine but the search bar and tabs on chrome are tiny and so is the whole ui on steam. it is near impossible to read. any solutions to this would be greatly appreciated.

 

I did not buy a h100i as i don't have the money right now but for people asking, there is enough room for a h100i and 1 set of fans internally although you many have to run the 8/6 pin fro another cable management socket.

 

Thnx,

Brit,


<p> AMD FX-8350 CPU, Asus M5A99FX PRO R2.0 Mobo, Corsair Vengeance Pro 8GB (2 x 4GB) DDR3-1866 Memory,Samsung 840evo 120gb ssd, Samsung 840evo 256gb ssd, Western Digital Caviar Blue 1TB HDD, Gigabyte Radeon R9 270X 2GB Graphics card, Fractal Design Define R4 w/Window (Black Pearl) Case, Corsair CS 750W 80+ Gold PSU, Windows 7 Home Premium

Link to post
Share on other sites

some pics please :D,  we dont see enough AMD builds


CPU: i5 4670K @ 4.2Ghz Mainboard: Asus Maximus VI Hero Z87 GPU: Gigabyte WindForce 3 GTX 770 RAM: 16GB Corsair Vengeance Pro @1600MHz 

PSU: Corsair AX760 SSD: Corsair Force GS 128GB HDD: 3TB WD Caviar Green, 2TB WD Caviar Black Headset: Steelseries 7H

Case: Corsair Vengeance C70 Gunmetal Black Keyboard: Corsair K70 Mouse: Corsair M65 Monitor: Samsung S27A950D CPU-Cooler: Corsair H100i

Link to post
Share on other sites

Parts list:

AMD FX8350 

Asus m5a99fx pro r2.0

2x4gb Corsair Vengeance pro 1333mhz

R9270x Gigabyte oc windforce

Cooler master hyper 212 evo

Cs 750m

WD Caviar Blue 1tb

Samsun 840 evo 120gb

Fractal Design Define r4

Windows 7

ALBA LCD19880hdf

 

The build went to plan, my only concern was that i had to apply quite a lot of pressure to the hyper 212 evo to fit the screws when placing the heat sink over the cpu. I first only plugged the SSD in because i didn't want to install my os on the HDD. once the os was installed i plugged it back in; it was recognized but didn't come up as a drive letter. i later found that i have to assign it to drive letter.

 

The drivers were slightly difficult to install as the screen cut off about 1/16 of the bottom of the page. i had to use a lot tab and enter, trial and error. once i had the graphics drivers installed it worked fine but the search bar and tabs on chrome are tiny and so is the whole ui on steam. it is near impossible to read. any solutions to this would be greatly appreciated.

 

I did not buy a h100i as i don't have the money right now but for people asking, there is enough room for a h100i and 1 set of fans internally although you many have to run the 8/6 pin fro another cable management socket.

 

Thnx,

Brit,

Your build is almost like mine. I really enjoy having that motherboard and CPU cooler. Granted my temps don't go over 50 after some BF4 but I may have a bottleneck with my GPU. On topic like the parts and show us some Pics!


CPU-- AMD FX-8320 (Stock), Motherboard-- ASUS M5A99FX PRO R 2.0, RAM-- Team 8gb 1600Mhz, GPU-- Sapphire 7870 GHz with OC Edition, Case-- NZXT Tempest 210, PSU-- Corsair CX600m, HDD, 1tb Seagate & 2tb WD External, Monitor-- Dell S2240M IPS Display, Keyboard/Mouse-- Some Logitech keyboard and some Dell mouse, Speakers-- Logitech Z533

Link to post
Share on other sites
Posted · Original PosterOP

Your build is almost like mine. I really enjoy having that motherboard and CPU cooler. Granted my temps don't go over 50 after some BF4 but I may have a bottleneck with my GPU. On topic like the parts and show us some Pics!

Hey,

You said you have the same motherboard as me, when you built your system did the BIOS work striaght off because i cant't access mine, they are buggy. i will be posting some pictures of what happens in the software section to see if anyone ahs any ideas. Btw i have installed wndows and eveything works fine i just can't acces the bios which is annoying because i would like to overclock in the furutre.

Thnx,

Brit,


<p> AMD FX-8350 CPU, Asus M5A99FX PRO R2.0 Mobo, Corsair Vengeance Pro 8GB (2 x 4GB) DDR3-1866 Memory,Samsung 840evo 120gb ssd, Samsung 840evo 256gb ssd, Western Digital Caviar Blue 1TB HDD, Gigabyte Radeon R9 270X 2GB Graphics card, Fractal Design Define R4 w/Window (Black Pearl) Case, Corsair CS 750W 80+ Gold PSU, Windows 7 Home Premium

Link to post
Share on other sites

Hey,

You said you have the same motherboard as me, when you built your system did the BIOS work striaght off because i cant't access mine, they are buggy. i will be posting some pictures of what happens in the software section to see if anyone ahs any ideas. Btw i have installed wndows and eveything works fine i just can't acces the bios which is annoying because i would like to overclock in the furutre.

Thnx,

Brit,

I worked right as I turned it on. I don't remember exactly but can this motherboard do the bios flash easily because you may have to do that. I used the 8320 and I don't think using the 8350 will cause a huge problem. Not saying you should but you can change the CPU settings in the ai suite software.


CPU-- AMD FX-8320 (Stock), Motherboard-- ASUS M5A99FX PRO R 2.0, RAM-- Team 8gb 1600Mhz, GPU-- Sapphire 7870 GHz with OC Edition, Case-- NZXT Tempest 210, PSU-- Corsair CX600m, HDD, 1tb Seagate & 2tb WD External, Monitor-- Dell S2240M IPS Display, Keyboard/Mouse-- Some Logitech keyboard and some Dell mouse, Speakers-- Logitech Z533

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×