Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Lupul

Second router on LAN has no internet

Recommended Posts

Posted · Original PosterOP

Hello everybody,

 

I have a bit of an issue with my home network. It is set up as follows:

 

Fiber into an ISP provided ONT/Router from ZTE.

 

Directly to it have run three Gigabit ethernet cables to the following: PC, NAS, second router (TPLink TL-WDR3600 N600)

 

The second router cable is not plugged into WAN, but into one of the LAN ports, just as my Smart TV is connected.

 

I have disabled DHCP on the second router, set a different IP from the one on the main router and i can access its web interface and ping is reliable to it. The TV that's connected to it, via ethernet, has Internet working fine, it can do 4K streaming no problem. However, the WLan on the second router has no internet when you connect to it (my phone says it's connected "no internet")

 

From what I can tell, it is acting as if the "switch" part is working fine and dandy, but the "wifi" part doesn't get internet. The router can ping any device on the network fine, but if I try to ping an external IP it gets timed out.

 

My question would be: Am I missing some setting on either routers or is this second router aging disgracefully and acting up?

 

PS: Apologies if I missed out on a similar discussion, my search throughout the forum earlier didn't seem to fit my case or was too old a topic to revive..

Link to post
Share on other sites
59 minutes ago, Lupul said:

My question would be: Am I missing some setting on either routers or is this second router aging disgracefully and acting up?

It's operation mode must be set up as 'Access Point'.

Link to post
Share on other sites
Posted · Original PosterOP

It doesn't seem to have an "operation mode" menu/setting. When looking up how to set it up in AP mode, even TPLink's website recommends doing the settings manually. This is why I'm thinking I am missing something.

Link to post
Share on other sites
32 minutes ago, Lupul said:

It doesn't seem to have an "operation mode" menu/setting. When looking up how to set it up in AP mode, even TPLink's website recommends doing the settings manually. This is why I'm thinking I am missing something.

See if these instructions help.

Link to post
Share on other sites
Posted · Original PosterOP

Followed those:

 

At the moment here's the situation: 

 

1st Router IP 192.168.1.1

DHCP 192.168.1.10-254

 

2nd router IP 192.168.1.2

DHCP OFF

 

Cable is Lan-Lan.

 

Currently when I connect to WiFi i do seem to get internet but something is off. For instance, Pokemon Go doesn't want to sign in from WiFi on second router, yet does it no problem on main router WiFi.

 

TV does work with Netflix/Youtube/app market but sometimes fails to connect to my plex server (it's an extension on my NAS - which is on the same network as stated in opening post). TV is connected via cable to second router.

 

Could the problem be more of a conflict rather than a configuration issue?

Link to post
Share on other sites
14 minutes ago, Lupul said:

2nd router IP 192.168.1.2

DHCP OFF

Specify the DNS server and gateway as 192.168.1.1 for the second wireless router.

 

14 minutes ago, Lupul said:

Currently when I connect to WiFi i do seem to get internet but something is off. For instance, Pokemon Go doesn't want to sign in from WiFi on second router, yet does it no problem on main router WiFi.

Which wireless settings are you using on each network device?

Link to post
Share on other sites
Posted · Original PosterOP

Gateway was already set, added DNS on router 2.

 

Situation seems to be the same with Pokemon Go login from router 2 wifi (also the connection is once again showing connected - no internet).

 

As for the Wireless settings, they are basically named "Room 1" - 2,4 Ghz only (router 1) and "Room 2" - 2,4 Ghz and 5 Ghz (router 2) with custom passwords but everything else set to auto.

Link to post
Share on other sites
59 minutes ago, Lupul said:

Gateway was already set, added DNS on router 2.

What DHCP range is the primary router using?

 

Can you reserve static IPs based on MAC addresses at the primary router?

 

Please run a wireless survey using WiFi Analyzer (post screenshots of the Networks and Analyze pages).

 

Ensure that your WiFi encryption/security is set to WPA/WPA2-PSK and AES (not TKIP) at both wireless routers.

Link to post
Share on other sites
Posted · Original PosterOP

Primary router is set to use 192.168.1.10 to 192.168.1.254.

 

It can assign "static" ips via MAC however, it only seems to do it for ones that are set in its dhcp range. 

 

Since TPLink recommended i use something outside that range, it's a no go. I did try it against TPLinks recommendation, didn't seem to make any difference.

 

The wireless in my area is pretty cluttered as the apartment design is pretty terrible and most of the times, a single wifi emitter isn't enough. Both networks are secured with WPA2 AES. 

 

In the screenshots "my networks" are Sufragerie (router 1) and Dormitor (router 2). 

1602942227328.jpg

1602942227331.jpg

Link to post
Share on other sites
7 hours ago, Lupul said:

The wireless in my area is pretty cluttered as the apartment design is pretty terrible and most of the times, a single wifi emitter isn't enough. Both networks are secured with WPA2 AES. 

That's a horrible-looking 2.4GHz analysis, but not unexpected if you're in an apartment complex.

 

Where is the 5GHz analysis? Your TP-Link wireless router supports 802.11n on 5GHz. You can probably use that if there are available channels instead of 2.4GHz.

 

Also, are wired connections through the 2nd router stable? Have you rebooted both routers recently?

 

Several other things to address:

  1. When you're in a crowded 2.4GHz space like yours, stick to 20MHz channel width. Anything above is going to interfere with other networks and slow down your own. That being said, you'll have to live with the performance of 2.4GHz if you're not willing to use 5GHz (N/AC/AX). Put low priority devices on the 2.4GHz SSID.
  2. The reason your devices are not switching over to the new signal when you move is likely due to the previous signal still being strong enough to establish a link. The solution to this sounds counterintuitive, but it's to reduce the power output to each wireless access point so that the signal just "dies off" close to where the new signal can be detected by your client devices and the switch can be made. This will take some experimentation as your already faced with a crowded wireless environment, but you should have better experience on 5GHz.
  3. If you're going to have multiple wireless access points with hopes of them competing with the neighbors and winning, you're in for a losing battle. Imagine a stadium full of people talking; you might think that if you speak louder then you'll be better heard, but there comes a point where a "louder" signal is just noise. Nothing can be understood. Same with WiFi. Again, the solution is to turn the radio output power down, but then everyone in the apartment needs to do this for everyone's WiFi to perform better.
Link to post
Share on other sites
Posted · Original PosterOP

5 Ghz is beautifully empty. I do use it when in that room.

 

My problem is not the signal itself since in current conditions I get full coverage throughout the apartment. The problem is that second router not willing to "share" the internet i know it is getting. After all, the TV, connected by wire to it, plays Netflix and Youtube 4K all day long.

 

I believe the cable between the two routers is good. I mean, I routed and crimped it myself so it's not a machined one, but it seems fine. I tested it and all wires seem to have signal, pings between the two routers are constant both ways. I will likely get another router. 

 

I will try it in two steps, the first being replacing the main router and then if nothing changes moving it to the second router's spot. The ISP provided one might be part of the problem with this as much as the TPLink one, but with this hard to reproduce constantly issue, they will likely be uninterested in swapping it out.

 

Will post back if I figure anything out, however it might be a while before I get a chance to do so.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Newegg

×