Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Dingleduck

Motherboard with on-board wifi not working

Recommended Posts

Posted · Original PosterOP

I recently helped my friend build a PC but the motherboard's(TUF GAMING X570-PLUS WI-FI) wifi doesn't seem to be working. In device manager, there are numerous unknown devices listed, and the only way to get the drivers would be to have internet, but the wifi doesn't work. The ethernet in our room also doesn't work so any help on how to fix this issue would be greatly appreciated. 

Link to post
Share on other sites
5 minutes ago, Dingleduck said:

I recently helped my friend build a PC but the motherboard's(TUF GAMING X570-PLUS WI-FI) wifi doesn't seem to be working. In device manager, there are numerous unknown devices listed, and the only way to get the drivers would be to have internet, but the wifi doesn't work. The ethernet in our room also doesn't work so any help on how to fix this issue would be greatly appreciated. 

You need drivers. Full stop.

 

Go to someone else's house/room/apt with a USB and download the drivers onto that, then install them on your friend's PC


So rise up, all ye lost ones, as one, we'll claw the clouds

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×