Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
YellowJersey

[SOLVED] Pls help. Mint update broke my laptop?

Recommended Posts

Posted · Original PosterOP

So I'm running Mint 19.1 MATE on my Lenovo T430 and I have a big problem. I installed the latest updates (see pic below) and then my computer crashed. I rebooted, and now it takes a long time to get to the login screen, but nothing happens when I put in my password. Shortly after that, the screen goes blank, I get a cursor blinking on the top left part of the screen, then the screen turns off, and eventually I get back to the login screen. Rinse and repeat. I get stuck in this loop with no way to log in. Any ideas?

Screenshot at 2020-09-28 18-33-24.png

Link to post
Share on other sites

Can you login with a TTY? Ctrl + alt + f2.


Quote me to see my reply!

SPECS:

CPU: Xeon X5650 OC'd to 4.2GHz @ 1.35V (courtesy of @XR6)Motherboard: Asus Sabertooth X58 RAM: 4x4GB G.Skill DDR3 1866MHz GPU: Asus RX 570 Strix Storage: WD Blue 1TB and a 128GB Kingston UV400 PSU: EVGA 600B Case: Fractal Design Define C Cooling: H100i V2, be quiet! Pure Wings 2 (two intake, two exhausting through radiator) Monitor: 3x Dell P2210 on a Steelcase Eyesite triple monitor stand Mouse: Logitech G403 Prodigy Wireless Keyboard: It changes, but usually Focus FK-9000 Mousepad: Steelseries QcK XL Headphones:  Sennheiser HD598SE

 

 

 

 

i use arch btw

Link to post
Share on other sites
Posted · Original PosterOP
43 minutes ago, kelvinhall05 said:

Can you login with a TTY? Ctrl + alt + f2.

Nope. Would it help if I took a video of what's happening?

**edit: Took a video with my phone, but it ended up being 5 minutes long and 300MB, too big to upload here.

Link to post
Share on other sites
Posted · Original PosterOP

UPDATE: I popped the SSD out and stuck it in an external enclosure. However, when I go to open home, it says:

 

"THIS DIRECTORY HAS BEEN UNMOUNTED TO PROTECT YOUR DATA.

From the graphical desktop, click on:
 "Access Your Private Data"

or

From the command line, run:
 ecryptfs-mount-private"

 

If I click on "Access your Private Data" and I get an error. So I try the ecryptfs-mount-private command. The problem is that I don't know the passphrase. When I installed Mint, I clicked the "encrypt home folder," but there was nothing regarding setting up a passphrase, just a login password.

Any ideas? I did some reading and apparently if you know the login password, you can still get in, but I don't know how. I'm really not good with the command line.

 

 

 

Screencap1.png

Screencap2.png

Screencap3.png

Link to post
Share on other sites
Posted · Original PosterOP

I FREAKIN DID IT! After ten hours of researching online and trying a bazillion different things (and then making things worse and spending more time trying to just undo those mistakes), I finally managed to get my files off that encrypted drive in an unencrypted state. Basically:

1) Pop the SSD back into the original machine

2) Enter into recovery mode

3) Go into root

4) Insert external harddrive to USB port

5) Using the command line  (this was the hard part)

   -log in as super user

   -create mount for external harddrive

   -mount external harddrive

   -transfer the home directory to external harddrive

   -pray to the tech gods that its working

6) Offload files from external harddrive onto another laptop


 Now that I have all my files back, I can simply re-install Mint on that SSD, transfer the files back over to it, and just spend a few minutes configuring Mint the way I like it; shouldn't take more than an hour!

I'm a total command line noob, but I did it! I probably shouldn't tag @GabenJr but what the hey, in my sleep-deprived-have-to-be-at-work-in-less-than-two-hours state it's time to celebrate! The whole time I was thinking, "Man, I wish I knew Anthony. He'd know what to do!"

 

nailedit2.jpg

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×