Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
frankgore77

2080 super gaming question

Recommended Posts

Posted · Original PosterOP

I built this monster pc so i could game at good settings and not have lag. Yet in apex legends i cannot seem to get good fps i am on a 1440p monitor at 144hz i play at 1900 by 1200 16:10 in game because stretch helps. 

My rtx 2080 super cant get like over 80 fps in the drop ship and less then 144 in game while fighting? all settings are on low or disabled. 

Specs to the pc are 

Ryzen 9 3900x

Rtx2080 super

asus rog motherboard not sure which one but paid like 300$ for it

2tb nvme m.2

32gb ram at 3200mhz dual channel

850 watt psu not entirely sure what its called havent looked. Yet my pc seems to not run apex at a decent framerate i have all drivers installed. Is there something in nvidia control panel i need to set or something im doing wrong im so confused

my gpu is in the second slot in the mobo but its a x16 slot

Link to post
Share on other sites
1 minute ago, frankgore77 said:

my gpu is in the second slot in the mobo but its a x16 slot

have you tested performance in the primary slot? have you made sure your ram is running at the proper speed?


I WILL find your ITX build thread, and I WILL recommend the SIlverstone Sugo SG13B

 

Primary PC:

i7 8086k (won) - EVGA Z370 Classified K - G.Kill Trident Z RGB - Force MP500 - Jedi Order Titan Xp - Hyper 212 Black (with RGB Riing flair) - EVGA G2 650W - Black and green theme, Razer branwashed me.

Draws 400 watts under max load, for reference.

 

Linux Proliant ML150 G6:

Dual Xeon X5560 - 24GB ECC DDR3 - GTX 750 TI - old Seagate 1.5TB HDD - Dark moded Ubuntu (and Win7, cuz why not)

 

How many watts do I need? Seasonic Focus threadUserbenchmark (Et al.) is trash explained, PSU misconceptions, protections explainedgroup reg is bad

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Fasauceome said:

have you tested performance in the primary slot? have you made sure your ram is running at the proper speed?

well it shows on task manager the ram is running right and also in gpuz that it is. I have not tested the second slot but it is a x16 slot

Link to post
Share on other sites
Just now, frankgore77 said:

I have not tested the second slot but it is a x16 slot

Only the top slot is connected to the CPU's PCIe lanes. The other slot is connected to the chipset.

 

Connect you GPU to the correct slot.


BabyBlu (Primary Rig): 

  • CPU: Intel Core i9 9900K @ Per Core 5.2Ghz, 5.2Ghz, 5.2Ghz, 5.2Ghz, 5.1Ghz, 5.1Ghz, 5.0Ghz, 5.0Ghz; Cache @ 4.8Ghz; 0 AVX offset
  • Motherboard: Asus Maximus XI Hero
  • RAM: G.Skill Trident Z RGB 4x8GB DDR4-3200 CL14 @ 4000Mhz 16-18-18-36
  • GPU: MSI RTX 2080 Sea Hawk EK X
  • Case: Phanteks Evolv X
  • Storage: 3x ADATA Ultimate SU800 1TB (RAID 0), Samsung 970 EVO Plus 500GB NVME
  • PSU: Corsair HX1000i
  • Monitor: Dell S2417DG 23.8" 2560x1440 165 Hz Gsync
  • Cooling: Custom water loop (CPU & GPU), Radiators: 1x140mm(Back), 1x280mm(Top), 1x420mm(Front)
  • Keyboard: Corsair Strafe RGB (Cherry MX Brown)
  • Mouse: Corsair Scimitar Elite/MasterMouse MM710
  • Headset: Corsair Void Pro RGB
  • OS: Windows 10 Pro

Roxanne (Wife Build):

  • CPU: Intel Core i7 4790K @ Per Core 5.0Ghz - 5.0Ghz - 4.9Ghz - 4.8Ghz, Cache @ 4.6Ghz, De-lidded
  • Motherboard: Asus Z97A
  • RAM: G.Skill Ripjaws X 4x4GB DDR3-2133 CL9 @ 2200Mhz 9-11-10-22
  • GPU: EVGA GTX 1080 FTW2 Gaming ICX
  • Case: Corsair Vengeance C70, With Custom Side-Panel Window
  • Storage: Samsung 850 EVO 250GB, Samsung 860 EVO 1TB
  • PSU: Corsair AX760
  • Monitor: Samsung C27JG56 27" 2560x1440 144Hz Curved Freesync
  • Cooling: Corsair H115i RGB
  • Keyboard: Rosewill RK 9000V2(Cherry MX Blue)
  • Mouse: Glorious Model O-
  • Headset: SteelSeries Arctis 7
  • OS: Windows 10 Pro

BlackBox (HTPC):

  • Intel Core i7 6700 slightly under-volted
  • Asus H110T/CSM Thin Mini-ITX
  • G.Skill 1x8GB DDR4-2400 SO-DIMM CL16
  • iGPU
  • Akasa Euler Fanless Solid Aluminum THIN Mini ITX Case (passively cooled)
  • Samsung 850 EVO 250GB
  • External 120W Power Adaptor
  • 4K TV
  • Passively cooled by the Akasa case. No moving parts!
  • Handheld QWERTY keyboard and trackpad.
  • Windows 10 Pro, Kodi autostarts on boot

NAS:

  • Synology DS216J
  • 2x8TB WD Red NAS HDDs in RAID 1. 8TB usable space
Link to post
Share on other sites
3 minutes ago, frankgore77 said:

well it shows on task manager the ram is running right and also in gpuz that it is. I have not tested the second slot but it is a x16 slot

secondary slot is chipset lanes, with slightly increased latency. sometimes there's no difference, sometimes a noticeable difference.


I WILL find your ITX build thread, and I WILL recommend the SIlverstone Sugo SG13B

 

Primary PC:

i7 8086k (won) - EVGA Z370 Classified K - G.Kill Trident Z RGB - Force MP500 - Jedi Order Titan Xp - Hyper 212 Black (with RGB Riing flair) - EVGA G2 650W - Black and green theme, Razer branwashed me.

Draws 400 watts under max load, for reference.

 

Linux Proliant ML150 G6:

Dual Xeon X5560 - 24GB ECC DDR3 - GTX 750 TI - old Seagate 1.5TB HDD - Dark moded Ubuntu (and Win7, cuz why not)

 

How many watts do I need? Seasonic Focus threadUserbenchmark (Et al.) is trash explained, PSU misconceptions, protections explainedgroup reg is bad

Link to post
Share on other sites
7 minutes ago, frankgore77 said:

my gpu is in the second slot in the mobo but its a x16 slot

use GPU-Z to see what lane it is running at


Things I need help with: *new* What can Facebook do to me? Privacy Inquiries

Spoiler

 

 

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

 

Spoiler

 

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

 

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

 

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

 

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

 

Personal Blacklisted Companies:

Spoiler

Acer monitors, Gigabyte, Seagate HDD, Kingston SSD, Razer (except their mouse), XiaoMi Phones

 

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

 

 

Link to post
Share on other sites
6 minutes ago, frankgore77 said:

I built this monster pc so i could game at good settings

Also, if you wanted the highest FPS possible, you should have built with a 10900K/10700K. 3900X is more of a mixed work station/gaming CPU.


BabyBlu (Primary Rig): 

  • CPU: Intel Core i9 9900K @ Per Core 5.2Ghz, 5.2Ghz, 5.2Ghz, 5.2Ghz, 5.1Ghz, 5.1Ghz, 5.0Ghz, 5.0Ghz; Cache @ 4.8Ghz; 0 AVX offset
  • Motherboard: Asus Maximus XI Hero
  • RAM: G.Skill Trident Z RGB 4x8GB DDR4-3200 CL14 @ 4000Mhz 16-18-18-36
  • GPU: MSI RTX 2080 Sea Hawk EK X
  • Case: Phanteks Evolv X
  • Storage: 3x ADATA Ultimate SU800 1TB (RAID 0), Samsung 970 EVO Plus 500GB NVME
  • PSU: Corsair HX1000i
  • Monitor: Dell S2417DG 23.8" 2560x1440 165 Hz Gsync
  • Cooling: Custom water loop (CPU & GPU), Radiators: 1x140mm(Back), 1x280mm(Top), 1x420mm(Front)
  • Keyboard: Corsair Strafe RGB (Cherry MX Brown)
  • Mouse: Corsair Scimitar Elite/MasterMouse MM710
  • Headset: Corsair Void Pro RGB
  • OS: Windows 10 Pro

Roxanne (Wife Build):

  • CPU: Intel Core i7 4790K @ Per Core 5.0Ghz - 5.0Ghz - 4.9Ghz - 4.8Ghz, Cache @ 4.6Ghz, De-lidded
  • Motherboard: Asus Z97A
  • RAM: G.Skill Ripjaws X 4x4GB DDR3-2133 CL9 @ 2200Mhz 9-11-10-22
  • GPU: EVGA GTX 1080 FTW2 Gaming ICX
  • Case: Corsair Vengeance C70, With Custom Side-Panel Window
  • Storage: Samsung 850 EVO 250GB, Samsung 860 EVO 1TB
  • PSU: Corsair AX760
  • Monitor: Samsung C27JG56 27" 2560x1440 144Hz Curved Freesync
  • Cooling: Corsair H115i RGB
  • Keyboard: Rosewill RK 9000V2(Cherry MX Blue)
  • Mouse: Glorious Model O-
  • Headset: SteelSeries Arctis 7
  • OS: Windows 10 Pro

BlackBox (HTPC):

  • Intel Core i7 6700 slightly under-volted
  • Asus H110T/CSM Thin Mini-ITX
  • G.Skill 1x8GB DDR4-2400 SO-DIMM CL16
  • iGPU
  • Akasa Euler Fanless Solid Aluminum THIN Mini ITX Case (passively cooled)
  • Samsung 850 EVO 250GB
  • External 120W Power Adaptor
  • 4K TV
  • Passively cooled by the Akasa case. No moving parts!
  • Handheld QWERTY keyboard and trackpad.
  • Windows 10 Pro, Kodi autostarts on boot

NAS:

  • Synology DS216J
  • 2x8TB WD Red NAS HDDs in RAID 1. 8TB usable space
Link to post
Share on other sites
Posted · Original PosterOP
10 minutes ago, HairlessMonkeyBoy said:

Only the top slot is connected to the CPU's PCIe lanes. The other slot is connected to the chipset.

 

Connect you GPU to the correct slot.

https://www.amazon.com/gp/product/B088W4933P/ref=ppx_yo_dt_b_asin_title_o09_s00?ie=UTF8&psc=1 

That is the mobo i doubt the second slot is the issue. And yes i know i do cpu mining on the 3900x thats why i got it but still i should have that little of fps with that card and this pc i mean idk tbh but i still feel like i shouldnt have lag like that lol

Link to post
Share on other sites
Posted · Original PosterOP
19 minutes ago, frankgore77 said:

https://www.amazon.com/gp/product/B088W4933P/ref=ppx_yo_dt_b_asin_title_o09_s00?ie=UTF8&psc=1 

That is the mobo i doubt the second slot is the issue. And yes i know i do cpu mining on the 3900x thats why i got it but still i should have that little of fps with that card and this pc i mean idk tbh but i still feel like i shouldnt have lag like that lol

i did change the gpu slot to number 1 and it doesnt come on. Like no post at all which is weird as fuck lol

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×