Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Ethen

ssd's disappears when I put my m.2 in the MB

2 minutes ago, Ethen said:

 I have an MSI Tomahawk 450 The M.2 is a 970 evo and I have 2 SATA drives 

sata ports 5 and 6 are disabled on that board when running an m.2, so try ports 1-4 for your sata drives.

Recommended Posts

Posted · Original PosterOP

So I just got a new m.2 and when I plug it in the computer will not boot into windows from the other SSD I have on the back of the pc. I go into the bios and they don't show up only the new m.2. I later removed the m.2 and the 2 other SSD show up and I boots into windows fine. I just need the all the be recognized and I don't know why they are not if anybody know why I would like some help.

Link to post
Share on other sites
Just now, Ethen said:

So I just got a new m.2 and when I plug it in the computer will not boot into windows from the other SSD I have on the back of the pc. I go into the bios and they don't show up only the new m.2. I later removed the m.2 and the 2 other SSD show up and I boots into windows fine. I just need the all the be recognized and I don't know why they are not if anybody know why I would like some help.

Certain SATA ports get disabled when you use an M.2 SSD, typically.

What motherboard do you have, what type of M.2 SSD('s) do you have and how many SATA drives do you have?


"We're all in this together, might as well be friends" Tom, Toonami.

Sorry if my post seemed rude, that is never my intention.

"Why do we suffer a lifetime for a moment of happiness?" - Anonymous

 

Link to post
Share on other sites
1 minute ago, Ethen said:

So I just got a new m.2 and when I plug it in the computer will not boot into windows from the other SSD I have on the back of the pc. I go into the bios and they don't show up only the new m.2. I later removed the m.2 and the 2 other SSD show up and I boots into windows fine. I just need the all the be recognized and I don't know why they are not if anybody know why I would like some help.

Plug your SSDs into another SATA port, it's possible your M.2 slot is running off the same lane as one of those ports. This is typical for M.2 SATA. 


AMD Phenom™ II X6 1100T @ 4.0GHz | MSI 890FXA-GD65 | MSI GTX 550Ti | 16GB Kingston DDR3 | Samsung 850 EVO 250GB | WD 750GB | Antec 300 | ASUS Xonar DG | Corsair A50 | OCZ 600W | Windows 10 Pro

Sony MDR-V250 | Logitech G610 Orion Brown | Logitech G402 | Samsung C27JG5 

Intel Core™ i5-8520U | WD Blue M.2 250GB | 1TB Seagate FireCuda | 8GB DDR4 | Windows 10 Home | ASUS Vivobook 15 

Intel Core™ i7-3520M | GT 630M | 16 GB Corsair Vengeance DDR3 | Samsung 850 EVO 250GB | macOS Catalina  Lenovo IdeaPad P580

AMD Phenom™ II X2 550 @ 3.10GHz | Gigabyte GA-MA785GM-US2H | XFX Radeon HD 4870 | 4GB Corsair XMS2 | WD 250GB | Thermaltake TR2 500W | Windows 10 Pro

iPhone 6s (iOS 13.6.1) | iPad Mini (iOS 9.3.5) | Samsung Galaxy S5e

Link to post
Share on other sites

what are your full specs? chances are you have a mobo that blocks certain sata ports when the m.2 is in a certain slot as it uses them.

Link to post
Share on other sites
Posted · Original PosterOP
Just now, minibois said:

Certain SATA ports get disabled when you use an M.2 SSD, typically.

What motherboard do you have, what type of M.2 SSD('s) do you have and how many SATA drives do you have?

 I have an MSI Tomahawk 450 The M.2 is a 970 evo and I have 2 SATA drives 

Link to post
Share on other sites
Posted · Best Answer
2 minutes ago, Ethen said:

 I have an MSI Tomahawk 450 The M.2 is a 970 evo and I have 2 SATA drives 

sata ports 5 and 6 are disabled on that board when running an m.2, so try ports 1-4 for your sata drives.

Link to post
Share on other sites
3 minutes ago, Ethen said:

 I have an MSI Tomahawk 450 The M.2 is a 970 evo and I have 2 SATA drives 

SATA ports 5 and 6 get turned off when using an M.2 drive.

image.png.24ea98a4f0f3e0fd05d88047c0c72a83.png

Those are the top two SATA ports. Make sure your current SATA drives are not installed there and use two of the other four connectors.


"We're all in this together, might as well be friends" Tom, Toonami.

Sorry if my post seemed rude, that is never my intention.

"Why do we suffer a lifetime for a moment of happiness?" - Anonymous

 

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, bmx6454 said:

sata ports 5 and 6 are disabled on that board when running an m.2, so try ports 1-4 for your sata drives.

okay yeah that's what they are on 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×