Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
RogerRoger

Blue Snowball Fix or is it broken?

Recommended Posts

Posted · Original PosterOP

*LISTENER BEWARE EXTREME HIGH PITCH AUDIO*

 

so im looking for a mic and remembered my dad bought a Blue Snowball that he never used (he uses something different now), so i open them up, plug them in and try them out.

this is what i got.

 

...(the audio your hearing is me talking into the microphone)...

 

 

are they broken? is the driver messed up? what could be the issue here and is it worth trying to fix or is it better to bin it and look for other options.

Record (online-voice-recorder.com).mp3

Link to post
Share on other sites

Make sure the USB connection is electrically isolated, i.e. on its own panel, not near any sources of interference.  Redditors seem to think this is normal for the Snowball, basically calling it extra-sensitive: https://www.reddit.com/r/letsplay/comments/534e5z/crackling_noise_with_a_blue_snowballblue_snowball/

 

Also check the cable for damage.

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, PineyCreek said:

Make sure the USB connection is electrically isolated, i.e. on its own panel, not near any sources of interference.  Redditors seem to think this is normal for the Snowball, basically calling it extra-sensitive: https://www.reddit.com/r/letsplay/comments/534e5z/crackling_noise_with_a_blue_snowballblue_snowball/

 

Also check the cable for damage.

i hope that means their fine but i guess ill have to check

 

can you try resending the link or telling me what you searched for, the link doesn't seem to load for me for some reason

Link to post
Share on other sites
3 minutes ago, RogerRoger said:

i hope that means their fine but i guess ill have to check

 

can you try resending the link or telling me what you searched for, the link doesn't seem to load for me for some reason

Mmm...link loads fine for me, even using the posted link in my earlier post.  Just search blue snowball broken audio in google and it's one of the top results.

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, PineyCreek said:

Mmm...link loads fine for me, even using the posted link in my earlier post.  Just search blue snowball broken audio in google and it's one of the top results.

did so, seems it might be the cable, if that doesn't work i still have my warranty apparently so that could always work

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×