Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
pannic

InWin A1 power supply noise

Recommended Posts

Posted · Original PosterOP

I recently bought an Inwin A1 case and powersupply, the 650W gold certified version.
The system will turn on but I am noticing a crackling sound coming from the powersupply. Also the sound seems fore frequent if the computer is under load. I turned off all the lights in my room to make sure I couldn't see an sparks inside the PSU and didn't see anything. I did look into it a bit and other seem to have fan noise problemes. Not me. It's really just a crackling sound almost like static but not very constant.

 

I'm just scared for my components since it didn't do that in my previous build.
Could it be a PSU defect ?

 

The next step I might try is disasemble the whole computer and make sure my connections are okay, 

And then if nothing, I might try the PSU from my old build.

Link to post
Share on other sites
1 hour ago, pannic said:

Could it be a PSU defect ?

Could be, could be not, we don't know, give us some audio of it at least.


Tag or quote me so i see your reply

Link to post
Share on other sites
Posted · Original PosterOP
3 hours ago, Juular said:

Could be, could be not, we don't know, give us some audio of it at least.

Hope you can pick it up in the video.

Link to post
Share on other sites

Well, this doesn't sound like a coil whine or failed fan bearing to me, perhaps just interference between different vibrating components (fans, HDD) ? Try to pull the PSU out of the case and see if it still products this sound.


Tag or quote me so i see your reply

Link to post
Share on other sites
Posted · Original PosterOP
7 hours ago, Juular said:

Well, this doesn't sound like a coil whine or failed fan bearing to me, perhaps just interference between different vibrating components (fans, HDD) ? Try to pull the PSU out of the case and see if it still products this sound.

I dont't know if your familiar with the Inwin A1 case, but the psu is built into the case. 

It's extremely difficult to remove it.

And I thought the crackling was too inconsistent (didnt seem to have a pattern) to be from a vibrating component. 

Link to post
Share on other sites

It's definitely too inconsistent to be coil whine, fan bearing failure or fan hitting smth, so it has to be vibration.

Is this sound still present when computer is off but PSU is online ?


Tag or quote me so i see your reply

Link to post
Share on other sites
Posted · Original PosterOP
On 9/24/2020 at 10:36 AM, Juular said:

It's definitely too inconsistent to be coil whine, fan bearing failure or fan hitting smth, so it has to be vibration.

Is this sound still present when computer is off but PSU is online ?

If computer is off and PSU still plugged in there is no sound.

Link to post
Share on other sites
Posted · Original PosterOP

Update: Ended up opening my case, wiggling around and making sure the connections to the motherboard were good and now the sound has probably gone down a good 80%.

Still hear some minor sound and I'm thinking that can be attributed to the computer actually working. Now I'm much more confident in my components not frying :P 

Link to post
Share on other sites
Posted · Original PosterOP

Other update, it started to do the noise again today. Dont know why all of a sudden.

Link to post
Share on other sites

It could be the fan, I have a cx 550m and they are known for using hong hua fans that sound similar to that when they spin up but I don't know. See if others have this issue too.

Link to post
Share on other sites
9 hours ago, pannic said:

Other update, it started to do the noise again today. Dont know why all of a sudden.

sounds like fan. return it. that's not normal and will only get worse probably.

 

also I wouldn't buy a case with built-in psu or fans, they're usually trash.


RYZEN 5 3600 | MSI GTX 1060 6GB GAMING X | 16GB CORSAIR VENGEANCE LPX 3200 DDR4 | MSI B350M MORTAR | 250GB SAMSUNG EVO 860 | 4TB TOSHIBA X 300 | 1TB TOSHIBA SSHD | 120GB KINGSTON SSD | WINDOWS 10 PRO | INWIN 301| BEQUIET PURE POWER 10 500W 80+ SILVER | ASUS 279H | LOGITECH Z906 | DELL KB216T | LOGITECH M185 | SONY DUALSHOCK 4

 

LENOVO IDEAPAD 510 | i5 7200U | 8GB DDR4 | NVIDIA GEFORCE 940MX | 1TB WD | WINDOWS 10 GO HOME 

Link to post
Share on other sites
Posted · Original PosterOP
On 10/1/2020 at 10:26 PM, Mark Kaine said:

sounds like fan. return it. that's not normal and will only get worse probably.

 

also I wouldn't buy a case with built-in psu or fans, they're usually trash.

Yea, never doing that again.

I guess I thought it would be better since it's a 80 plus gold certified but I guess you can't trust that nowadays.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×