Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
stevenkoalae

Internet is acting strange...x_X

Recommended Posts

Posted · Original PosterOP

I noticed my 1000up and down fiber internet is unstable about 2 weeks ago, synonyms as follows:

1) Twitch video crash (This video is either unavailable or not supported in this browser. (Error #4000)) every 10-30 mins or so;

2) Unable to download files through browser, mega won't work, download link won't work, it will download at high speed for about 10 second then stop. After a while, chrome will say download failed - network error (I tried microsoft.com, quite a few cloud storage sites, and http://speedtest.tele2.net/)

3) Reddit videos will load half of the video then won't buffer for a long while. 

4) Youtube works, might stutter a bit at 1080p60fps

5) Steam game download works, bittorrent works, general browsing works, speedtest shows 900up and down with 2ms ping. 

 

I tried connecting my pc directly to the ISP modem, bypassing my wifi router, still the same result. I called my ISP and they tell me that they can't find any problem at their end. So I am out of ideas, any suggestions?

Link to post
Share on other sites

download the newest driver for your motherboard from the motherboard web site. uninstall driver. restart install new driver.

Link to post
Share on other sites
Posted · Original PosterOP

Thanks for the suggestion, turns out it is my Kaspersky Internet Security. Turning it off definitely turn my network back to normal and it did have an important update few days ago. Now I just have to figure out which setting is fucking up my internet =_=

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×