Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
T0MMEN

Asus PCE AC68 cant find 5ghz on windows, but on mac

Recommended Posts

Posted · Original PosterOP

So this is strange, i bought a used ac68 wifi card for cheap. And, it seems to find my 2.4ghz network on windows. But when i switch to my mac os it finds my 5ghz network full coverage, but not in windows.

 

Does anyone know what the trick is to get 5ghz working on windows?


i7-9700k 4.9ghz, 16gb Dominator Platinum 3000mhz, Asus z370-f Mobo, GTX 1080 JETSTREAM, 970 evo m.2, s340 elite. Corsair h115i CPU cooler.

 

Link to post
Share on other sites
32 minutes ago, T0MMEN said:

So this is strange, i bought a used ac68 wifi card for cheap. And, it seems to find my 2.4ghz network on windows. But when i switch to my mac os it finds my 5ghz network full coverage, but not in windows.

 

Does anyone know what the trick is to get 5ghz working on windows?

You installed the latest driver from ASUS's website right?


AMD Phenom™ II X6 1100T @ 4.0GHz | MSI 890FXA-GD65 | MSI GTX 550Ti | 16GB Kingston DDR3 | Samsung 850 EVO 250GB | WD 750GB | Antec 300 | ASUS Xonar DG | Corsair A50 | OCZ 600W | Windows 10 Pro

Sony MDR-V250 | Logitech G610 Orion Brown | Logitech G402 | Samsung C27JG5 

Intel Core™ i5-8520U | WD Blue M.2 250GB | 1TB Seagate FireCuda | 8GB DDR4 | Windows 10 Home | ASUS Vivobook 15 

Intel Core™ i7-3520M | GT 630M | 16 GB Corsair Vengeance DDR3 | Samsung 850 EVO 250GB | macOS Catalina  Lenovo IdeaPad P580

AMD Phenom™ II X2 550 @ 3.10GHz | Gigabyte GA-MA785GM-US2H | XFX Radeon HD 4870 | 4GB Corsair XMS2 | WD 250GB | Thermaltake TR2 500W | Windows 10 Pro

iPhone 6s (iOS 13.6.1) | iPad Mini (iOS 9.3.5) | Samsung Galaxy S5e

Link to post
Share on other sites
Posted · Original PosterOP
34 minutes ago, BlueChinchillaEatingDorito said:

You installed the latest driver from ASUS's website right?

Sure did


i7-9700k 4.9ghz, 16gb Dominator Platinum 3000mhz, Asus z370-f Mobo, GTX 1080 JETSTREAM, 970 evo m.2, s340 elite. Corsair h115i CPU cooler.

 

Link to post
Share on other sites
4 hours ago, T0MMEN said:

So this is strange, i bought a used ac68 wifi card for cheap. And, it seems to find my 2.4ghz network on windows. But when i switch to my mac os it finds my 5ghz network full coverage, but not in windows.

 

Does anyone know what the trick is to get 5ghz working on windows?

Are the fittings for the antennae secured properly?

 

What wireless settings do you have set on the wireless router/AP?

Link to post
Share on other sites
Posted · Original PosterOP
On 9/22/2020 at 12:06 AM, Falcon1986 said:

Are the fittings for the antennae secured properly?

 

What wireless settings do you have set on the wireless router/AP?

Yes they are, here is 2.4

image.png.f23e5a0d03225fad198393643be1229c.png

 

And here is 5Ghz

image.png.a0a5aab4b5b6a39bc99f075b3a534124.png


i7-9700k 4.9ghz, 16gb Dominator Platinum 3000mhz, Asus z370-f Mobo, GTX 1080 JETSTREAM, 970 evo m.2, s340 elite. Corsair h115i CPU cooler.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×