Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Satori_Tranzient

No LAN support under UEFI Mode in BIOS

Recommended Posts

Posted · Original PosterOP
Quote

MSI B450 Tomahawk Max

AMD Ryzen 5 3600

Corsair Vengeance RGB Pro 2 x 16 GB

Sapphire Pulse Radeon RX 5600 XT

Samsung V-Nand SSD 970 EVO ( 1TB with Windows 10 Install)

Samsung 860 EVO SATA SSD (1TB with MacOS Catalina 10.15.6 OpenCore Install)

Seagate Barracuda (2TB Extra Storage unused so far)

tp-link TL-WN881ND PCI Express Wi-Fi Adapter

Corsair RM (2019) 750 W 80+ Gold Certified Fully Modular ATX Power Supply

 

MSI BIOS Ver: E7C02AMS.370

 

Hey everyone,

 

Just finished my Hackintosh build using the OpenCore Install Guide for Ryzen 17h processors. I'm running Windows 10 on my Samsung 970 Evo 1 TB drive, with MacOS Catalina running on my Samsung 860 Evo 1 TB drive.

 

Per OpenCore's AMD BIOS instructions, I changed the BIOS mode to UEFI. This makes MacOS load up with seemingly no issues, but when I boot to Windows all of my networking is disabled: My Wi-Fi Adapter and Realtek PCIe GbE Family Controller both have this message in Device Manager properties: 

Quote

This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful.

 

When reverting back to CSM mode, all network adapters work without any issues, but I can't boot into MacOS without a kernel panic around login. 

 

Update 09/21/20: I narrowed down the issue and it seems to be a problem with enabling 4G decoding in the BIOS. The Realtek Ethernet adapter and wi-fi card will not work while this is enabled, but MacOS boots fine. With the option disabled, I have networking in UEFI mode but MacOS will kernel panic upon booting up.

 

I've tried uninstalling and re-installing drivers (directly from Realtek and TP-Link) with no luck. Let me know if I can provide any other information. Any help would be much appreciated!

 

Update 9/21/20 4:00 PM: I've solved my issue. The fix is essentially done by booting into MacOS with UEFI mode enabled, 4G Decode off, mounting the EFI partition and modifying the config.plist file to include npci=0x2000 in boot-args. My Windows boot has networking capability, and I can boot into MacOS with no issues. Hope this helps someone! 

Link to post
Share on other sites
5 minutes ago, Satori_Tranzient said:

Any help would be much appreciated!

You quite possibly will have to reinstall Windows in UEFI-mode.


Hand, n. A singular instrument worn at the end of the human arm and commonly thrust into somebody’s pocket.

Link to post
Share on other sites
Posted · Original PosterOP
8 minutes ago, TrigrH said:

not a mac user but a quick google of "TL-WN881ND uefi" has resulted in this:

https://www.tonymacx86.com/threads/how-can-i-install-tp-link-tl-wn881nd-on-sierra.220593/

https://www.google.com/search?q=TL-WN881ND+uefi&oq=TL-WN881ND+uefi&aqs=chrome..69i57j33.2345j0j1&sourceid=chrome&ie=UTF-8

 

If windows wasn't installed under UEFI, thats your issue.

 

7 minutes ago, WereCatf said:

You quite possibly will have to reinstall Windows in UEFI-mode.

 

Thank you. Would someone mind explaining why this is necessary? 

Link to post
Share on other sites
5 minutes ago, Satori_Tranzient said:

Thank you. Would someone mind explaining why this is necessary? 

Because Windows initializes several of its components in a different way, depending on the mode it's installed and booted in.


Hand, n. A singular instrument worn at the end of the human arm and commonly thrust into somebody’s pocket.

Link to post
Share on other sites
Posted · Original PosterOP

So after uninstalling Windows multiple times on UEFI mode with no results, I narrowed down the issue. It actually has to do with enabling 4G decoding in the BIOS. Enabling this setting allows MacOS to work without a kernel panic, but disables the networking capabilities of the Realtek PCIe GBE Controller and my Wi-FI card. No idea where to go from here. It seems like I need to find a way to enable 4G decoding from MacOS' config.plist file in the EFI. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×