Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
VlaDexa

MSI site is down

Recommended Posts

Posted · Original PosterOP

It's been a whole month of users reporting that they can't download drivers fom the oficial MSI just because it doesn't show anything.

Trying to help my friend checked it myself, doesn't work for me either. Making matters worse, some pages doesn't even load just showing white screen

MsiSiteProblems1.png

Link to post
Share on other sites

It's SUPER SLOW, but it should show up sooner or later. It took about 5 seconds before the black lower third started to show the drivers/bios.

image.thumb.png.e51ee4053311c92e00d0619762d25a9a.png

 

image.thumb.png.2917e7a94c52338d5e45e4584face5e2.png


CPU: AMD Ryzen 3600 / GPU: Radeon HD7970 GHz 3GB(upgrade pending) / RAM: Corsair Vengeance LPX 2x8GB DDR4-3200
MOBO: MSI B450m Gaming Plus / NVME: Corsair MP510 240GB / Case: TT Core v21 / PSU: Seasonic 750W / OS: Win 10 Pro

Link to post
Share on other sites

Laughs is motherboard that hasn’t had a new bios update in years.


I am still TechWizardThatNeedsHelp, just less of a mouthfull.

 

My beautiful, but not that powerful, main PC:

My new PC I'm saving for:

  • NZXT H1 Matte Black
    • Comes with a 650W NZXT PSU
    • NZXT AIO
  • Ryzen 5 3600
  • MSI B450i GAMING PLUS AC
  • XPG ADATA 2800Mhz
  • RX480 untill I have more for a 2060 or 2070
  • 2tb Sabrent Rocket Q PCIE gen 3 NVME SSD
  • Samsung 470 128GB SATA SSD
Link to post
Share on other sites

MSI don't really release anything new. If you find a bug in BIOS or drivers, they will probably inform you that there is no bug or, if you're lucky, they will say that you should live with that because it's made that way.

 

I tried once use support for report missing useful option in bios. After month of questions about my configuration, serial numbers (including additional cards), revisions and probably even shoe size, they answered me that... their BIOS have no option I wanted. No matter that was reason I wrote in the first place or no matter that all questions about my configuration was pointless and not related to answer.

 

MSI support is a joke.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×