Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
FireBoyAwesome

Fitting Graphics Card on Mobo

Recommended Posts

Posted · Original PosterOP

Hey guys so right now I am trying to install a graphics card for my pc. The problem is next to my pcie slot there is a hub thing there.

 

I was wondering if I were to remove it, would my mobo break?

20200920_090324.jpg

Link to post
Share on other sites

That is the heatsink for your motherboard's chipset.

 

Why would you need to remove it to install your graphics card?


Desktop: Intel Core i9-9900K | be quiet! Dark Rock Pro 4 | ASUS Strix Z390-F | G.Skill Trident Z Neo 2x16GB, 3200MHz 14-14-14-34 | EVGA GeForce RTX 2070 SUPER XC Ultra | Corsair RM650x | Fractal Design Define R6

Laptop: 2018 Apple MacBook Pro 13" (i5-8259U | 8GB LPDDR3 | 512GB NVMe)

Peripherals: Ducky Shine 7 (Cherry MX Brown) | Logitech MX Master 3 & Razer Basilisk X HyperSpeed | Beyerdynamic Custom One Pro Plus | Audio-Technica AT2020USB+

Displays: Alienware AW2521HF & BenQ BL2420PT

Link to post
Share on other sites
1 hour ago, FireBoyAwesome said:

would my mobo break?

that's the heatsink for the chipset of the board, why do you want to remove it? it's there to cool it. 

The heatsink should not interfere wih the gpu's cooler. 


Wārudobītā

CPU: Ryzen 3 3100. Board: B550m TUF plus. Memory: 16 (2x8) 3200 cl16 Hyper x Fury RGB. GPU: Gigabyte Windforce 1650 super.  Boot Drive: MX500. Case: Antec NX500 (Quite crappy. :p) PSU: CX450. 

 

Hehe, Meshify c is a kewl case. 

 

 

Link to post
Share on other sites

Like @Mateyyy said it's your PCH heatsink. You don't want to remove it. It's there for a reason. Quick question. Why is your ssd mounted in the lower m.2 slot and not even secured in place?🤔


Main PC:

CPU: AMD Ryzen 7 2700X | RAM:G Skill TridentZ RGB 2666 mhz (16Gb) 

Mobo:X470 AORUS ULTRA GAMING | GPU: MSI RTX 2070 Gaming Z

Case: Sharkoon Nightshark RGB| Storage: 128 GB Adata SP 900 1 TB WD blue 500 GB Samsung HDD

Powersupply: Be Quiet straight Power 10 500 watt

 

 

Main Laptop

CPU: AMD Ryzen 7 4800H | RAM: Team group 16 GB 2666 mhz

GPU: RTX 2060 (MXM swappable)

Storage: 2x 1 TB Samsung 970 EVO NVMe (no raid)

 

 

Second Laptop (Work laptop)

CPU: AMD Ryzen 3 3250U,  RAM: Samsung 8 GB 2400 mhz

GPU: Vega 3

Storage: 512 GB Sk Hynix BC511 NVMe

 

Phone:

Xiaomi MI 9

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, Mateyyy said:

That is the heatsink for your motherboard's chipset.

 

Why would you need to remove it to install your graphics card?

 

3 minutes ago, TofuHaroto said:

that's the heatsink for the chipset of the board, why do you want to remove it? it's there to cool it. 

The heatsink should not interfere wih the gpu's cooler. 

The reason i am asking if i could remove it is because it is in the way of my graphics card

Link to post
Share on other sites
Just now, FireBoyAwesome said:

The reason i am asking if i could remove it is because it is in the way of my graphics card

So you have tried installing the graphics card into the PCIe slot, and it doesn't go in because of the chipset heatsink?


Desktop: Intel Core i9-9900K | be quiet! Dark Rock Pro 4 | ASUS Strix Z390-F | G.Skill Trident Z Neo 2x16GB, 3200MHz 14-14-14-34 | EVGA GeForce RTX 2070 SUPER XC Ultra | Corsair RM650x | Fractal Design Define R6

Laptop: 2018 Apple MacBook Pro 13" (i5-8259U | 8GB LPDDR3 | 512GB NVMe)

Peripherals: Ducky Shine 7 (Cherry MX Brown) | Logitech MX Master 3 & Razer Basilisk X HyperSpeed | Beyerdynamic Custom One Pro Plus | Audio-Technica AT2020USB+

Displays: Alienware AW2521HF & BenQ BL2420PT

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Mateyyy said:

So you have tried installing the graphics card into the PCIe slot, and it doesn't go in because of the chipset heatsink?

yeah, i wont go in fully

Link to post
Share on other sites
1 hour ago, FireBoyAwesome said:

because it is in the way of my graphics card

Picture? so the heatsink isn't allowing the card to properly slot in the pcie slot? the heatsink shouldn't interfere with the card's cooler. 


Wārudobītā

CPU: Ryzen 3 3100. Board: B550m TUF plus. Memory: 16 (2x8) 3200 cl16 Hyper x Fury RGB. GPU: Gigabyte Windforce 1650 super.  Boot Drive: MX500. Case: Antec NX500 (Quite crappy. :p) PSU: CX450. 

 

Hehe, Meshify c is a kewl case. 

 

 

Link to post
Share on other sites
Posted · Original PosterOP
Just now, TofuHaroto said:

Picture? so the heatsink isn't allowing the card to properly slot in the pcie slot? the heatsink shouldn't interfere with the card's cooler. 

the picture was in the og post lol

Link to post
Share on other sites
1 hour ago, FireBoyAwesome said:

the picture was in the og post lol

picture of the heatsink interfering with the card. 


Wārudobītā

CPU: Ryzen 3 3100. Board: B550m TUF plus. Memory: 16 (2x8) 3200 cl16 Hyper x Fury RGB. GPU: Gigabyte Windforce 1650 super.  Boot Drive: MX500. Case: Antec NX500 (Quite crappy. :p) PSU: CX450. 

 

Hehe, Meshify c is a kewl case. 

 

 

Link to post
Share on other sites
Just now, FireBoyAwesome said:

yeah, i wont go in fully

Have you first unlocked the PCIe lock? (the tab on the right-hand side)


Desktop: Intel Core i9-9900K | be quiet! Dark Rock Pro 4 | ASUS Strix Z390-F | G.Skill Trident Z Neo 2x16GB, 3200MHz 14-14-14-34 | EVGA GeForce RTX 2070 SUPER XC Ultra | Corsair RM650x | Fractal Design Define R6

Laptop: 2018 Apple MacBook Pro 13" (i5-8259U | 8GB LPDDR3 | 512GB NVMe)

Peripherals: Ducky Shine 7 (Cherry MX Brown) | Logitech MX Master 3 & Razer Basilisk X HyperSpeed | Beyerdynamic Custom One Pro Plus | Audio-Technica AT2020USB+

Displays: Alienware AW2521HF & BenQ BL2420PT

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Mateyyy said:

Have you first unlocked the PCIe lock? (the tab on the right-hand side)

i had unlocked it, the thing is it wont clicj in bcs of the heatsink in the way

Link to post
Share on other sites
7 minutes ago, FireBoyAwesome said:

i had unlocked it, the thing is it wont clicj in bcs of the heatsink in the way

You must be doing something wrong, it really shouldn't be in the way.

Just now, FireBoyAwesome said:

hey guys it would be cool for someone to respond...

Take a pic that would better illustrate that it's in the way.

Edited by nox_
Link to post
Share on other sites

What is that motherboard?


Skynet: MacBook Pro Late 2016 Space Gray | i7-6820HQ 2.7 GHz | 16 GB LPDDR3 | Radeon Pro 455 2048 MB | 512 GB NVMe SSD | 15" 2880x1800

HAL9000: Intel i5-9600k | Cryorig M9 | 32 GB Corsair Vengeance LPX DDR4 3200 MHz | Gigabyte Z390I AORUS PRO WIFI | MSI GTX 1080 Ti SeaHawk X | 1 TB Samsung 970 Evo Plus + 1 TB Crucial MX500 + 512 GB Samsung 970 Evo Plus | Corsair TX650M | NZXT H210i | LG 34UM95 34" 3440x1440

Hydrogen server: AMD Ryzen 9 3900x | AMD Wraith Prism | 64 GB Crucial Ballistix 3200MHz DDR4 | Asus Prime X570 Pro | Corsair HX1000 | 256 GB Samsung 850 Evo + 1 TB Crucial MX500 + 4x 3 TB + 2 TB WD Red/Seagate/Toshiba  | Fractal Design Define R5 | unRAID 6.8.3

Carbon server: Fujitsu PRIMERGY RX100 S7p | Xeon E3-1230 v2 | 16 GB DDR3 ECC | 60 GB Corsair SSD & 250 GB Samsung 850 Pro | Intel i340-T4 | ESXi 6.5.1

Big Mac cluster: 2x Raspberry Pi 2 Model B | 1x Raspberry Pi 3 Model B | 2x Raspberry Pi 3 Model B+

Link to post
Share on other sites
Just now, FireBoyAwesome said:

well i mean it is lol

Well it really shouldn't... My mb has one of these in this place too,many others too. So it has to be something else. Take a proper pic so we can help you.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×