Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
EmoChipmonk

Unable to acess pi-hole web interface

Recommended Posts

Posted · Original PosterOP

I have tried every thing i can think of. I have tried cent os 7 and fedora 32. I know the service that should be running it is working but  it doesn't wanna FUDGING WORK. It was on a switch that i have had problems with in the past so i took it off and hooked it up to the isp router/modem combo along with the device thats going to be acessing it and that didnt fix it. Im not sure if theres a setting in the router that would be stopping this or what but i am completly floored and have no idea what i can try any more.

I am running this on an old laptop. NOT A RASP PI.

Link to post
Share on other sites

Mods. Please remove my post.

 


"Introduce a little anarchy. Upset the established order and everything becomes chaos. I'm an agent of chaos. Oh, and you know the thing about chaos? It's fair."

 

/ Polak / Husband / Employee / Hetero / Carnivorous / Fugly / Geek / @$$hole / with ADD / Roman Catholic /

 

You can always buy me a cup of coffee if you feel like it...

Link to post
Share on other sites

Did you enable the web interface when you configured it? 

You can reconfigure it with the -r option (i.e pihole -r)

 

If you have to it enabled, can you check that the port is listening

netstat -ano | grep ":80"

Check if you can telnet the port locally

telnet localhost 80

If that's all good, try telnet it remotely

telnet <pi-hole_server_ip> 80

If that's timing out then you probably have a firewall on your Pi-hole server....if it's Ubuntu/Debian based I think it uses UFW (Uncomplicated Firewall)....so to allow the web port it's just 

sudo ufw allow http

 


Spoiler

Desktop: Ryzen 7 2700x | Aorus X470 Gaming Ultra | EVGA RTX2080 Super | 32GB (4x8GB) Corsair Vengeance RGB Pro 3200Mhz | Corsair H105 AIO, NZXT Sentry 3 | Corsair SP120's | 1TB Crucial P1 NVMe, 4TB WD Black | Phanteks Enthoo Pro | Corsair RM650v2 PSU | LG 32" 32GK850G Monitor | Ducky Shine 3 Keyboard, Logitech G502, MicroLab Solo 7C Speakers, Razer Goliathus Extended, X360 Controller | Windows 10 Pro | SteelSeries Siberia 350 Headphones

 

Spoiler

Server 1: Fractal Design Define R6 | Ryzen 3950x | ASRock X570 Taichi | EVGA GTX1070 FTW | 64GB (4x16GB) Corsair Vengeance LPX 3000Mhz | Corsair RM650v2 PSU | Fractal S36 Triple AIO | 10 x 8TB HGST Ultrastar He10 (WD Whitelabel) | 500GB Aorus Gen4 NVMe | 2 x 1TB Crucial P1 NVMe | LSI 9211-8i HBA

 

Server 2: Corsair 400R | IcyDock MB998SP & MB455SPF | Seasonic Focus Plus 650w PSU | 2 x Xeon X5650's | 48GB DDR3-ECC | Asus Z8NA-D6C Motherboard | AOC-SAS2LP-MV8 | LSI MegaRAID 9271-8i | RES2SV240 SAS Expander | Samsung 840Evo 120GB | 5 x 8TB Seagate Archives | 10 x 3TB WD Red

 

Link to post
Share on other sites
Posted · Original PosterOP

it said it was enabled. ill have to try things out in the morning ill update on what happens. A part of me thinks it just hates that laptop

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×