Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ElGoblino777

Windows 10 Firewall Impossible to disable

Recommended Posts

Posted · Original PosterOP

Hello everyone, ever since I've built my PC almost a year ago, i get haunted by firewall notifications from all kinds of apps that i launch, it's the "Windows Firewall has blocked some features of this app" type notification. When i try to turn Firewall off completely it'll just turn on by itself later, same with notifications, basically any app that needs internet connection will trigger firewall to open app that damn notification about "blocked features", although i allowed those apps through firewall. Even after almost a year of just clicking close or "allowing access" it's still annoying and i want to get rid of it. I have third party antivirus installed and if there's a way to turn off firewall COMPLETELY i'd be glad to do it!

Link to post
Share on other sites
6 minutes ago, ElGoblino777 said:

Hello everyone, ever since I've built my PC almost a year ago, i get haunted by firewall notifications from all kinds of apps that i launch, it's the "Windows Firewall has blocked some features of this app" type notification. When i try to turn Firewall off completely it'll just turn on by itself later, same with notifications, basically any app that needs internet connection will trigger firewall to open app that damn notification about "blocked features", although i allowed those apps through firewall. Even after almost a year of just clicking close or "allowing access" it's still annoying and i want to get rid of it. I have third party antivirus installed and if there's a way to turn off firewall COMPLETELY i'd be glad to do it!

Sounds like you need to reset the firewall settings to default. Go to the Control Panel version of it to do this. You can also disable it there.

Link to post
Share on other sites

Are you sure it the windows firewall? Sounds like weird behavior to me. It should ask once per application.

Have you modded anything in your windows? It all works together so maybe changing something screwed the firewall up?

But first definitely do what @TehDwonz said. Reset to default!

After that just to be sure run anti-virus and anti-malware scans. ;)

 


When i ask for more specs, don't expect me to know the answer!
I'm just helping YOU to help YOURSELF!
(The more info you give the easier it is for others to help you out!)

Link to post
Share on other sites
2 minutes ago, HanZie82 said:

Are you sure it the windows firewall? Sounds like weird behavior to me. It should ask once per application.

Have you modded anything in your windows? It all works together so maybe changing something screwed the firewall up?

If he somehow blocked a system process, it could behave that way. 

Link to post
Share on other sites

Go to services and change dns service to automatic, restart computer and disable firewall.

 

If for some reason you cannot change dns service to automatic, change it in registry (link).

 

I can explain later why it will work if someone wants, now I only want to give a solution.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×