Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
MajorFoley

Mac USB wifi adapter dropping out

Recommended Posts

Posted · Original PosterOP

So pretext my sisters macbook pro wifi died last year, isntaed of paying 300 AUD to replace the damn thing we got a TP link USB wifi adapter (WN823N) , and for the most part it worked good enough until a few days ago. It started dropping out after about 15 minutes of connectivity. On advice from TP link i tried chaning channels to 1 and 6 with a width of 40 didnt not solve the issue, tried reinstalling the drivers and it did not do anything unfortunately and then today refused to do anything at all no lights indicating it was working at all (and its a pain to uninstall from that command line thing.

 

Today we got a replacement the Archer T2U (non plus ) model and its having the same issues, about 15-20 minutes of connectivity before it drops, in the network settings page it just appears empty. Before that it has the usual details ip address etc. Does anyone have any ideas? Shes on version Catalina 10.15.6

Link to post
Share on other sites
Posted · Original PosterOP
2 hours ago, Donut417 said:

This is a dual band adapter. Have you tried using 5Ghz as well? 

Same issue and i am really pressed to fix this issue...

Link to post
Share on other sites
Posted · Original PosterOP

Ok so i brought it to my house to test, yeah it connected for a few seconds... Then killed the internet for all wifi devices in my house. Wired was still working. I have absolutely zero clue as to what is going on here...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×