Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
itswillum

Far Cry 3 free on Uplay

Recommended Posts

damn one of my favorite games ever tbh


-it’s scuff Gang btw, I hated the name and needed a change
Quote me for a reply, React if I was helpful, informative, or funny

 

AMD blackout rig

 

cpu: ryzen 5 3600 @4.4ghz @1.35v

gpu: rx580 @1.45ghz mem=2100mhz

ram: vengeance lpx c15 @3800mhz

mobo: Asus b450f

psu: cooler master mwe 650w

case: masterbox mbx520

fans:Noctua industrial 3000rpm x6

 

 

Link to post
Share on other sites

Wow thanks - worked like a charm

 


Workstation Laptop: Dell Precision 7540, Xeon E-2276M, 32gb DDR4, Quadro T2000 GPU, 4k display

Ryzen Rig 2: ASrock B450 Pro4 ATX, Ryzen 7 1700 @ 4.2ghz all core 1.4vCore, AMD R9 Fury X w/ Swiftech KOMODO waterblock, Custom Loop 2x240mm + 1x120mm radiators in push/pull 16gb (2x8) 3600mhz V-Color Skywalker (or 4x8gb DDR4 2666mhz for large tasks), Corsair HX850 PSU, 128gb Patriot Scorch NVMe Win 10 boot drive, 500gb Samsung 840 EVO SSD, 512GB TeamGroup MS30 M.2 SATA III, CoolerMaster HAF XM Case.  Zalman K600S keyboard, Zalman ZM-GM1 mouse, Viotek GN24C 24" 1080p 144hz curved and Hannspree HF207 as 2nd monitor

https://www.3dmark.com/3dm/37004594?

Ryzen Rig 1: ASUS B350-PRIME ATX, Ryzen 7 1700, Sapphire R9 Fury Tri-X Nitro 4gb HBM, 16gb (2x8) 3200mhz V-Color Skywalker, ANTEC Earthwatts 750w PSU, MasterLiquid Lite 120 AIO cooler in Push/Pull config as rear exhaust, 250gb Samsung 850 Evo SSD, Patriot Burst 240gb SSD, Cougar MX330-X Case.  Zalman K600S keyboard, Zalman ZM-GM1 mouse, Acer XF270HU 2560x1440 144hz IPS monitor

https://www.3dmark.com/3dm/37628874?

Dwight: The Mixed Metals Loop Media Center.  Ask me about it.  Currently decommissioned to move to an mATX setup on a new MOBO once I pick one out (getting its facelift as of June 2020 have new air cooler, drives etc.  About 60% finished.  Will no longer be a closed loop system.  Slight update, upgraded to larger SSD, and air cooling installed Arctic Alpine cooler.

Schrute: ASUS M5A99FX Pro R2.0, FX 8350, Sapphire R9 Fury Tri-X Nitro 4gb HBM, 16gb (4x4) Corsair Vengeance DDR3 1600mhz, Sparkle/FSP 650w PSU, Corsair H100i GTX 240mm AIO w/ 12mm thick fans to fit in top exhaust, 256gb TIMETEC SSD, 1tb WDBlack HDD, Rosewill Nautilus 1.0 case.  DSI 90-Key Mechanical Keyboard w/ Cherry Red switches, Zalman gaming mouse

Micro Form Factor Dell OptiPlex 3040: Dell 0MGK50 A02, i3-6100T, 2x4gb DDR3 1600, Team Group 120gb SSD, 500gb Seagate 7mm HDD attached storage, Windows 10 Pro, Logitech K400+, USB Wifi adapter all vesa mounted to the back of a 37" 1080p TV 

Linux Box: Toshiba Laptop, i7 620M, NVS graphics, 4gb ram tinker toy at the moment.  Running Manjaro XFCE at the moment.

Home Security: ZOSI 8 channel CCTV (4 used at this time, 1080p) DVR H.265+, 3tb HGST Enterprise HDD, ASUS monitor for display

Link to post
Share on other sites

Sweet.  I remember you used to be able to do this with some of the Japanese XBOX Live Gold titles, but they seemed to have changed it, and also deleted anything one got from there haha.

Link to post
Share on other sites
Posted · Original PosterOP
23 minutes ago, Kraken_05 said:

It is asking me for a CD Key. What should I do?

Where is it asking you for one? At the purchase or in the uPlay launcher?

 

Link to post
Share on other sites
3 minutes ago, itswillum said:

Where is it asking you for one? At the purchase or in the uPlay launcher?

 

It is re-directing me to the launcher and asking the key there. On the website it is showing that the game has been successfully added to your account. 

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Kraken_05 said:

It is re-directing me to the launcher and asking the key there. On the website it is showing that the game has been successfully added to your account. 

Weird. I didn't get redirected, but I haven't tried to install the game yet. Am I correct in saying that it's in your inventory but you can't install it?

Link to post
Share on other sites
4 minutes ago, itswillum said:

Weird. I didn't get redirected, but I haven't tried to install the game yet. Am I correct in saying that it's in your inventory but you can't install it?

It is not showing up in "My Games" but in the website it is showing that "the game has been added to your library". When I press the purchase button, it is giving two options, download UPlay or go to UPlay.

Link to post
Share on other sites
Posted · Original PosterOP
9 minutes ago, Kraken_05 said:

It is not showing up in "My Games" but in the website it is showing that "the game has been added to your library". When I press the purchase button, it is giving two options, download UPlay or go to UPlay.

I don't know why that's happening to you, as it seems like a similar thing to what steam does where they prompt you to install the game after purchase. I got the deal from the PCMR discord originally, so you could ask around there.

Link to post
Share on other sites
7 hours ago, Kraken_05 said:

It is not showing up in "My Games" but in the website it is showing that "the game has been added to your library". When I press the purchase button, it is giving two options, download UPlay or go to UPlay.

Are you enabling mobile mode in your desktop browser?  Apparently people trying to redeem it through desktop mode get the game key message.  On chrome desktop in windows, press F12.  On the side pane that pops up, look for the toggle device toolbar button (or press ctrl+shift+m, make sure the focus is on the dev panel on the side).  Make sure you're already logged in using the us site.  OP included the helpful tutorial, but I thought typing it out might be helpful, to at least get the mobile part out of the way.  After that I think you just press the big blue button next to where it shows the 0 price and it should add to your account.

Link to post
Share on other sites
6 hours ago, metaleggman said:

Are you enabling mobile mode in your desktop browser?  Apparently people trying to redeem it through desktop mode get the game key message.  On chrome desktop in windows, press F12.  On the side pane that pops up, look for the toggle device toolbar button (or press ctrl+shift+m, make sure the focus is on the dev panel on the side).  Make sure you're already logged in using the us site.  OP included the helpful tutorial, but I thought typing it out might be helpful, to at least get the mobile part out of the way.  After that I think you just press the big blue button next to where it shows the 0 price and it should add to your account.

Thanks man. 

I never bothered to even see the tutorial...such a dumb mistake

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×