Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
BBaron5jd

Mouse non responsive

Recommended Posts

Posted · Original PosterOP

I don't know how to accurately explain the problem, but here it is. 

My mouse works perfectly when I'm doing normal work. But when I'm playing fps games, it stops working a lot. Like, when I move my mouse, the camera moves, but it is very laggy (Don't know if this is the correct word). Sometimes the problem is just noticeable. Sometimes it's extremely annoying. Other times it works fine. 

It's like, I'm moving my mouse, but the camera is moving and the stops moving, and then moves again, it stops for like fraction of a second, every few seconds. Sometimes the camera jumps from one place to another even when I'm moving my mouse very slowly. I can't shoot like this. 

I tried changing DPI settings, I thought it was driver issue, so I reinstalled windows, then I even got a new mouse (Logitech G102 Prodigy). The new mouse was working fine for a few days. But I just started having this problem again. It happens in almost all first-person games. AC, Valorant, COD etc. I even tried updating mouse driver. But I have the latest drivers. I've been having this problem for a long time now. 

 

Link to post
Share on other sites
3 minutes ago, BBaron5jd said:

Logitech G102 Prodigy

another logitech mouse with stuttery issue hmm...

 

third case i've seen this week, 4 if you include me (though mine might be shotty wireless connection)

 

i remember seeing a thread that suggest tweaking system interrupt something something to solve this issue, though i cant remember the thread name.


Things I need help with: *new* What can Facebook do to me? Privacy Inquiries

Spoiler

 

 

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

 

Spoiler

 

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

 

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

 

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

 

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

 

Personal Blacklisted Companies:

Spoiler

Acer: shit tier quality products, shit tier customer service thus far, they "tried" to solve my issue but they arent really doing anything but delaying and delaying. (on-going case since July)

Gigabyte: horrible customer service (gigabyte had literally 0 customer service, asked me to go to retailer with NO WAY to email them about a question) but at least they fixed my shit in ONE MONTH (would probably take me 1 hour to fix if they let me email them)

XiaoMi Phones: built like a tank but the software is buggy as all hell

Seagate HDD: had too many dead seagate drives

Kingston SSD: 300V controller swap thingy

Razer (except their mouse)

 

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

 

 

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Moonzy said:

another logitech mouse with stuttery issue hmm...

 

third case i've seen this week, 4 if you include me (though mine might be shotty wireless connection)

 

i remember seeing a thread that suggest tweaking system interrupt something something to solve this issue, though i cant remember the thread name.

Actually I had this problem with my last mouse too. One of the reason I changed my mouse was because I thought the problem is with the mouse. But now I don't think that was the issue. 

Link to post
Share on other sites
34 minutes ago, BBaron5jd said:

Actually I had this problem with my last mouse too. One of the reason I changed my mouse was because I thought the problem is with the mouse. But now I don't think that was the issue. 

I am currently using a Logitech G402 (wired USB) mouse with Win10 Pro 2004, no issues at all in Desktop or Games (Elite Dangerous, Elder Scrolls Online, Doom Ultimate), however once I had set my profiles and preferences in the Logitech Hub app and saved to the mouse I uninstalled the Hub app. Maybe if you are using the Logitech software that is causing the issue, just a wild guess.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×