Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TheMiniMiney

Every Steam game is throwing error

Recommended Posts

Posted · Original PosterOP

I did a fresh installation on my laptop , installed the drivers required and installed steam . Then i added my internal HDD back to my laptop and added the steam library to steam. Now almost every game is throwing errors. I made sure the drive had read/write permissions. 
Cuphead is starting and plays the menu music , but no visuals. ( for what ever reason forcing it to DirectX12 is working , but i want it to start normally like before)
Spyro reignited trilogy started at first , but now throws "The UE4-Falcon Game has crashed and will close
            LolLevelFatalError
            [File:D:\Bamboo\buildbot-package\Engine\Source\Runtime\D3D12RHI\Private\D3D12Util.cpp] [Line: 242]
            (Device-> "TPSOFunctionMap<TDesc>::GetCreatePipelineState()((Desc,IID_PPV_ARGS(&PSO)) failed
            at
            D:\Bamboo\buildbot-package\Engine\Source\Runtime\D3D12RHI\Private\Windows\WindowsD3D12PipelineState.cpp:601 with error E_INVALIDARG" error
CS 1.6 also starts with a blank screen. Before it gave an error loading library error.

WMR Portal gives outdated driver issue , whereas i have the latest drivers and i had used wmr headset on this before.

 

I can't understand whats wrong here. I installed the latest Intel drivers and Nvidia drivers (ver. 451.67) from Geforce Experience.

Link to post
Share on other sites

have you verified the files? might be worth a try


CPU: Intel 6700k 4.6GHz_____Motherboard: Gigabyte z170x gaming 3_____Cooler: Corsair H105_____RAM: Corsair LPX 4X4GB(16)_____GPU: MSI GTX 1070 Aero SC

PSU: EVGA 650w SUPERNOVA_____CASE: NZXT S340 blue_____Keyboard: Razer BlackWidow Chroma_____Mouse: Razer deathadder Chroma_____Headphones: Bose QC25

Microphone: Blue Yeti Black_____Monitor (1) Acer Predator XB1 144hz G-Sync  (2) Benq 144hz G-Sync

Razer blade 14

Also an XBOX one s.

 

 

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Acid Panda said:

have you verified the files? might be worth a try

yes , have done it multiple times now , including multiple restarts

 

Link to post
Share on other sites

has the drive name or location changed when you added the drive back in it might be trying to locate files that could have been in a C drive when your originally installed them but is now in a different drive?


CPU: Intel 6700k 4.6GHz_____Motherboard: Gigabyte z170x gaming 3_____Cooler: Corsair H105_____RAM: Corsair LPX 4X4GB(16)_____GPU: MSI GTX 1070 Aero SC

PSU: EVGA 650w SUPERNOVA_____CASE: NZXT S340 blue_____Keyboard: Razer BlackWidow Chroma_____Mouse: Razer deathadder Chroma_____Headphones: Bose QC25

Microphone: Blue Yeti Black_____Monitor (1) Acer Predator XB1 144hz G-Sync  (2) Benq 144hz G-Sync

Razer blade 14

Also an XBOX one s.

 

 

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Acid Panda said:

has the drive name or location changed when you added the drive back in it might be trying to locate files that could have been in a C drive when your originally installed them but is now in a different drive?

no , nothing of that sort 

Link to post
Share on other sites

ok get a new free steam game that has a small install size and see if that will launch.  trying to find out its a system error or a steam error


CPU: Intel 6700k 4.6GHz_____Motherboard: Gigabyte z170x gaming 3_____Cooler: Corsair H105_____RAM: Corsair LPX 4X4GB(16)_____GPU: MSI GTX 1070 Aero SC

PSU: EVGA 650w SUPERNOVA_____CASE: NZXT S340 blue_____Keyboard: Razer BlackWidow Chroma_____Mouse: Razer deathadder Chroma_____Headphones: Bose QC25

Microphone: Blue Yeti Black_____Monitor (1) Acer Predator XB1 144hz G-Sync  (2) Benq 144hz G-Sync

Razer blade 14

Also an XBOX one s.

 

 

Link to post
Share on other sites
Posted · Original PosterOP
17 minutes ago, Acid Panda said:

ok get a new free steam game that has a small install size and see if that will launch.  trying to find out its a system error or a steam error

so I downloaded DirectX runtime installer which included 9/10/11 and somehow that fixed it . I will test out some more games and update whether the problems persists or not. But thanks alot for your time.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×