Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
adikumar

Silicon Power 1TB NVMe (SP001TBP34A80M28) Write Speed Issue

Recommended Posts

Posted · Original PosterOP

I ran some benchmarks and I am getting very low write Seq. Q32T1 speed from few weeks in crystal disk mark. Originally Seq. Q32T1 write speed was always above 3000mbps when I bought it last year which is the advertised speed by company.

 

I am not sure what could be the issue. Maybe the SSD is fried ? Does anyone know?

 

Original Benchmark from last year:

old.png

 

Recent Bechmark :

New.png

 

------------------------------------------------------------------------------------------------------------------------------------------------------

 

I could send the SSD for RMA but problem is I don't want to reinstall everything. I have 2 external HDD lying around. So I can clone full disk image of my SSD into a USB HDD then when I get it back I can restore image on it. Can anyone let me know good software to do that.

 

Also I think first I need to create image of SSD onto an external HDD and then when I get it back I will have to install Windows on another spare HDD so I can restore that image back to the replaced SSD. It's very long and tedious process. Let me know if there is any easier method. I am not sure if its possible to restore the cloned image without installing any OS.

Link to post
Share on other sites

It's 73% full. SSDs and harddisks get slower the more they fill up. Have you accounted for that as well? This mostly affects writes.

Reads are still well within tolerances.


PC Specs - AMD Ryzen 5 3600X MSI B450M Mortar Max 16GB Crucial Ballistix DDR4-3600 @ CL15 - RX5700XT 660p 1TBGB & 256GB 600p Fractal Define Mini C CM V550 - Pop!_OS 20.04

Link to post
Share on other sites

Tried the "optimizing"?

 

1ssd.thumb.png.c2e08101342b6663e1ff00fb830f413a.png

 

Of course as said before - the fuller the drive the slower it gets.


... but I'm no expert

Link to post
Share on other sites

There's different types of NAND. The most common is TLC because it gives a reasonable balance between performance and storage space. With TLC, each cell stores 3 bits, but each successive bit is harder to write to, and thus takes longer. The drive will start off writing one bit per cell (the fastest) and then multiple bits once each cell starts to fill up. At 73% capacity, every write is to the third bit in the cell, thus the slower performance.

Link to post
Share on other sites

The fullness and the read write cycles isn't helping it.


NO RTX 30 SERIES TALK OR RYZEN 4000 OR INTEL 11TH GEN TALK.

Quote me or @Not Wills for a reply!

Contact info on my profile!

All my builds below!

 

Current builds:

Main system: AMD ryzen 5 3600 (No OC (Thermal reasons)) | Stock AMD cooler | Gigabyte B450m gaming | Zotac GTX 970 dual fan (OC, Core base: 1366, Core boost: 1440, Memory: 4206) (+200 core +700 memory) | Corsair 2x8GB 2666Mhz DDR4 | Kingston A400 240gb x2.

Laptop: Toshiba a110-274 | Intel core solo T1350 | Intel 945GM Express | 2x512mb 533Mhz DDR2 sodim | Seagate Momentus .3 7200rpm | Intel pro Wi-fi.

 

Coming soon:

Server build: x2 Xeon E5 2450 | HP Proliant DL360e Gen 8 | Quadro K620 | 4x500GB 7200rpm hdd | Kingston a400 240gb | 32gb ddr3 ECC. (On hold)

Small form factor gaming PC: AMD ryzen 5 3600 (It's here!) | Zotac GTX 970 dual fan (on-hand) | Asus B450I (coming soon-ish)  | 2x Kingston a400 240gb (on-hand).

 

Selling soon:

Mb | combo: AMD ryzen 3 1200 (OCed to 3.625Ghz) (1.21V) | Stock AMD cooler | Gigabyte B450m gaming | 

Dell prebuilt: Intel i3 8100 | Dell Z370 | Dell cooler 80mmm | Dell GTX 1050 | Crucial 1x8gb 2400Mhz DDR4 | Toshiba A300 1tb. (Sold)

Link to post
Share on other sites
Posted · Original PosterOP

image.png.1c1b8129266fb5a8551708506a3576ce.png

 

I just ran trim command in powershell but still same result

Optimize-Volume -DriveLetter YourDriveLetter -ReTrim -Verbose

Drive is around 65% full, so this slow speed is normal behavior and nothing can be done to fix it? and no point getting it replaced?

Link to post
Share on other sites

Yes. It's still not "slow" 1000MBps is a decent transfer speed, but yes, as the drive fills up, the slower it will be. That's true of all SSDs, so an RMA isn't going to help you. Though, a larger drive would. If it bothers you that much, upgrade to a 500GB or 1TB drive, and then you'll have plenty of headroom to maintain peak speeds.

 

Edit: I was looking at the other drive. You're already at a TB with this one, so maybe look into a 2TB drive. Still, it's not a huge issue to stick with what you have. You're still running faster than peak SATA, and in a lot of applications, like gaming, you won't notice a difference between SATA and NVMe anyways.

Link to post
Share on other sites
Posted · Original PosterOP

someone suggested I can fix it by running a manual garbage collection. I have no idea what that is.

Link to post
Share on other sites
Just now, adikumar said:

someone suggested I can fix it by running a manual garbage collection. I have no idea what that is.

I don't either. They might be referring to TRIM, but you've already done that, and the issue here is capacity. TRIM is akin to defragmenting a HDD, so it can help with speed, but it's not going to get around the physics here.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×