Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Hymenopus_Coronatus

RX580 Gaming X BSOD?

Recommended Posts

Posted · Original PosterOP

Hello!

 

I was testing out some games today, and I had the metric overlay on in the Radeon Software. The second I toggled it off, the system blue screened.

 

Should I be worried? This GPU is secondhand and is an interim solution till RTX3000/Big Navi. The only reason I'm worried is the possibility of it being something else.

 

Does this seem like a GPU issue, or is it more likely something else?


Current System: Ryzen 7 3700X, 32GB DDR4 @ 3000MHz, MAG B550 Tomahawk, 1TB WD SN550 NVME, be quiet! Straight Power 11 850W, MSI RX580 Gaming X (placeholder until next-gen GPUs), NZXT H510

Link to post
Share on other sites

Probably a driver issue. Have you ever had this happen before?


Desktop: Intel Core i9-9900K | be quiet! Dark Rock Pro 4 | ASUS Strix Z390-F |G.Skill Trident Z Neo (2x16GB, 3200MHz CL14) | EVGA GeForce RTX 2070 SUPER XC Ultra | Corsair RM650x | Fractal Design Define R6

Laptop: 2018 Apple MacBook Pro 13" (i5-8259U | 8GB LPDDR3 | 512GB NVMe)

Peripherals: Ducky Shine 7 (Cherry MX Brown) | Logitech MX Master 3 & Razer Basilisk X HyperSpeed | Beyerdynamic Custom One Pro Plus | Audio-Technica AT2020USB+

Displays: Alienware AW2521HF & BenQ BL2420PT

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Mateyyy said:

Probably a driver issue. Have you ever had this happen before?

no but I haven't actually gamed much since building

 

However, I have had a issues with freezes or white screens for a few seconds every other time gaming


Current System: Ryzen 7 3700X, 32GB DDR4 @ 3000MHz, MAG B550 Tomahawk, 1TB WD SN550 NVME, be quiet! Straight Power 11 850W, MSI RX580 Gaming X (placeholder until next-gen GPUs), NZXT H510

Link to post
Share on other sites
1 minute ago, Hymenopus_Coronatus said:

no but I haven't actually games much in the passed.

 

However, I have had a issues with freezes or white screens for a few seconds every other time gaming

Hm, I'd try using DDU to remove the driver and then reinstall the latest directly from AMD's website.

Or maybe it could be a known issue with AMD's latest video driver? I'm not sure.


Desktop: Intel Core i9-9900K | be quiet! Dark Rock Pro 4 | ASUS Strix Z390-F |G.Skill Trident Z Neo (2x16GB, 3200MHz CL14) | EVGA GeForce RTX 2070 SUPER XC Ultra | Corsair RM650x | Fractal Design Define R6

Laptop: 2018 Apple MacBook Pro 13" (i5-8259U | 8GB LPDDR3 | 512GB NVMe)

Peripherals: Ducky Shine 7 (Cherry MX Brown) | Logitech MX Master 3 & Razer Basilisk X HyperSpeed | Beyerdynamic Custom One Pro Plus | Audio-Technica AT2020USB+

Displays: Alienware AW2521HF & BenQ BL2420PT

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Mateyyy said:

Hm, I'd try using DDU to remove the driver and then reinstall the latest directly from AMD's website.

Or maybe it could be a known issue with AMD's latest video driver? I'm not sure.

Okay I'll try that, thank you! 

 

I'll let you know the results!


Current System: Ryzen 7 3700X, 32GB DDR4 @ 3000MHz, MAG B550 Tomahawk, 1TB WD SN550 NVME, be quiet! Straight Power 11 850W, MSI RX580 Gaming X (placeholder until next-gen GPUs), NZXT H510

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×