Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
PeytonG

Computer won't start, PSU clicks

34 minutes ago, Moonzy said:

even with the CPU power plugged in? try reseating the CPU (twist and tilt the cooler gently before pulling up to avoid pulling the cpu out of the socket along with it)

So, what I did was find a new connector and it worked. Guess it was that the manufacturer connector was broke?

Recommended Posts

Posted · Original PosterOP

Hey guys. I put together a new build, and when I went to boot it on the first time... The PSU just clicked and nothing else happened. So I did some testing and got a new PSU from a computer I have which does work, and it clicked as well, which in my mind rules out the PSU maybe, but then I noticed whenever I unplug the 8 pin CPU connector from the MB, it worked just fine. I'll leave the build details below, but does anyone have any ideas as to why the computer won't start with the 8 pin connector in, and when I say won't start, I mean nothing happens, the fans don't start, or anything. Just the click. I did notice that some of the RGB lights on the MB that are always on remain on, but those are like that before starting the PC. My MB does have some LED indicators for errors, but they don't appear to be doing anything. 

 

CPU: AMD Ryzen 5 3600

MB: ASUS ROG B550

MEMORY : corsair vengeance pro RGB 32gb (8x4)

PSU: EVGA SuperNOVA G3 750 W 80+

GPU: Quadro P4000 (yes I know quadros in a build like this are weird, it's a weird situation)

 

I should note I removed non essential things like the GPU and all but one ram chip while I figure out the problem 

Link to post
Share on other sites
12 minutes ago, PeytonG said:

whenever I unplug the 8 pin CPU connector from the MB, it worked just fine.

Make sure you are using the EPS power cable and not the PCIe power cable for CPU power, and make sure it is plugged into the correct port on the power supply.

Link to post
Share on other sites
24 minutes ago, PeytonG said:

I removed non essential things

including any USB in the back and front panel IO i assume?

 

25 minutes ago, PeytonG said:

I noticed whenever I unplug the 8 pin CPU connector from the MB, it worked just fine.

huh... im not sure if your PC should even boot without CPU 8-pin plugged in, can we get a photo?


Things I need help with:

Spoiler

 

 

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

 

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

 

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

 

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

 

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

 

Personal Blacklisted Companies:

Spoiler

Acer monitors, Gigabyte, Seagate HDD, Kingston SSD, Razer (except their mouse), XiaoMi Phones

 

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

Link to post
Share on other sites
Posted · Original PosterOP
11 minutes ago, Moonzy said:

including any USB in the back and front panel IO i assume?

 

huh... im not sure if your PC should even boot without CPU 8-pin plugged in, can we get a photo?

Yes, I'll get a photo up soon

Link to post
Share on other sites
Posted · Original PosterOP
23 minutes ago, Moonzy said:

including any USB in the back and front panel IO i assume?

 

huh... im not sure if your PC should even boot without CPU 8-pin plugged in, can we get a photo?

So here's a photo of the PC with and without the connector to the CPU plugged in, you can see it's running when the CPU connector is not plugged in, but isnt when it is plugged in

IMG_20200803_144204.jpg

IMG_20200803_144227.jpg

Link to post
Share on other sites
Posted · Original PosterOP
7 minutes ago, OrionFOTL said:

What is the first PSU and which 8pin cable are you using?

 

37 minutes ago, The_russian said:

Make sure you are using the EPS power cable and not the PCIe power cable for CPU power, and make sure it is plugged into the correct port on the power supply.

I have it plugged into CPU1 and the cable says CPU on it, I'm wondering if maybe the cable needs to be replaced because I saw somewhere that sometimes the manufacturer can screw up the cable 

Link to post
Share on other sites
1 minute ago, PeytonG said:

So here's a photo of the PC with and without the connector to the CPU plugged in, you can see it's running when the CPU connector is not plugged in, but isnt when it is plugged in

can you make sure that's the right cable for the CPU? and that it's plugged in the right port on the PSU?

cant quite see it from the photos, it's blurry

 

and by turn on, does it enter the bios or the lights are on?


Things I need help with:

Spoiler

 

 

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

 

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

 

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

 

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

 

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

 

Personal Blacklisted Companies:

Spoiler

Acer monitors, Gigabyte, Seagate HDD, Kingston SSD, Razer (except their mouse), XiaoMi Phones

 

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Moonzy said:

can you make sure that's the right cable for the CPU? and that it's plugged in the right port on the PSU?

cant quite see it from the photos, it's blurry

 

and by turn on, does it enter the bios or the lights are on?

It says CPU on the cable, and it's plugged into CPU1 on the PSU. I will check if it posts without the CPU connector in. Sorry for photo quality 

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, Moonzy said:

can you make sure that's the right cable for the CPU? and that it's plugged in the right port on the PSU?

cant quite see it from the photos, it's blurry

 

and by turn on, does it enter the bios or the lights are on?

So, it does not appear to be posting when I plug it into a monitor, but the fans do turn on only when I press the power button and if the CPU connector is unplugged, as you can see in the picture above. If the CPU connector is plugged in, it does not even turn the fans on, the PSU clicks and nothing happens

IMG_20200803_145315.jpg

IMG_20200803_145300.jpg

IMG_20200803_145451.jpg

IMG_20200803_145457.jpg

Link to post
Share on other sites
4 minutes ago, PeytonG said:

when I plug it into a monitor

your CPU doesnt have iGPU

are you trying to POST from your quadro? make sure your monitor is plugged into the quadro


Things I need help with:

Spoiler

 

 

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

 

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

 

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

 

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

 

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

 

Personal Blacklisted Companies:

Spoiler

Acer monitors, Gigabyte, Seagate HDD, Kingston SSD, Razer (except their mouse), XiaoMi Phones

 

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Moonzy said:

your CPU doesnt have iGPU

are you trying to POST from your quadro? make sure your monitor is plugged into the quadro

Oh, let me check again with the Quadro in that case 

Link to post
Share on other sites
Just now, PeytonG said:

Oh, let me check again with the Quadro in that case 

with your CPU power plugged in


Things I need help with:

Spoiler

 

 

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

 

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

 

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

 

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

 

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

 

Personal Blacklisted Companies:

Spoiler

Acer monitors, Gigabyte, Seagate HDD, Kingston SSD, Razer (except their mouse), XiaoMi Phones

 

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

Link to post
Share on other sites
Posted · Original PosterOP
9 minutes ago, Moonzy said:

your CPU doesnt have iGPU

are you trying to POST from your quadro? make sure your monitor is plugged into the quadro

Have that a go, and unfortunately still did not post

IMG_20200803_151011.jpg

Link to post
Share on other sites
1 minute ago, PeytonG said:

Have that a go, and unfortunately still did not post

even with the CPU power plugged in? try reseating the CPU (twist and tilt the cooler gently before pulling up to avoid pulling the cpu out of the socket along with it)


Things I need help with:

Spoiler

 

 

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

 

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

 

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

 

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

 

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

 

Personal Blacklisted Companies:

Spoiler

Acer monitors, Gigabyte, Seagate HDD, Kingston SSD, Razer (except their mouse), XiaoMi Phones

 

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

Link to post
Share on other sites
Posted · Original PosterOP
9 minutes ago, Moonzy said:

even with the CPU power plugged in? try reseating the CPU (twist and tilt the cooler gently before pulling up to avoid pulling the cpu out of the socket along with it)

Alright I'll give that a go, 

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer
34 minutes ago, Moonzy said:

even with the CPU power plugged in? try reseating the CPU (twist and tilt the cooler gently before pulling up to avoid pulling the cpu out of the socket along with it)

So, what I did was find a new connector and it worked. Guess it was that the manufacturer connector was broke?

Link to post
Share on other sites
1 minute ago, PeytonG said:

So, what I did was find a new connector and it worked. Guess it was that the manufacturer connector was broke?

email them about it

this could've killed your PC if the cable was connected wrongly


Things I need help with:

Spoiler

 

 

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

 

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

 

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

 

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

 

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

 

Personal Blacklisted Companies:

Spoiler

Acer monitors, Gigabyte, Seagate HDD, Kingston SSD, Razer (except their mouse), XiaoMi Phones

 

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

Link to post
Share on other sites
7 hours ago, PeytonG said:

PSU: EVGA SuperNOVA G3 750 W 80+

The picture you posted shows a flat ribbon CPU cable. The EVGA G3 does not come with flat ribbon cables it has sleeved. 

Kg39PkWXnGNKFp6KHzdexM-412-80.jpg.ccdf50cc91460d8314855e58584254b3.jpg

 

You're using the cable from a different power supply??


CPU: Intel i7 6700k  | Motherboard: Gigabyte Z170x Gaming 5 | RAM: 2x8GB 3000MHz G.Skill Ripjaws 5 | GPU: Gigabyte Aorus GTX 1080ti | PSU: Corsair RM750x (2018) | Case: BeQuiet SilentBase 800 | Cooler: Corsair H100i AIO | SSD: Samsung 970 Evo 500GB + Samsung 840 500GB | HDD: Seagate Ironwolf 8TB + 2x Seagate Ironwolf 6TB | Monitor: Acer Predator XB271HU + Samsung BX2450

Link to post
Share on other sites
Posted · Original PosterOP
On 8/3/2020 at 9:34 PM, Spotty said:

The picture you posted shows a flat ribbon CPU cable. The EVGA G3 does not come with flat ribbon cables it has sleeved. 

Kg39PkWXnGNKFp6KHzdexM-412-80.jpg.ccdf50cc91460d8314855e58584254b3.jpg

 

You're using the cable from a different power supply??

I think you may be right. I've ordered a new one, so we'll see if that fixes it. I've put a cable from a dif PSU in it and it worked for now. I'll let you know when the new one arrives if that was the prob

Link to post
Share on other sites
4 hours ago, PeytonG said:

I've put a cable from a dif PSU in it and it worked for now.

You should not mix cables from different power supplies. There's no standard to the pinout for modular cables from the PSU. Even PSUs from the same brand can use different cables. Which would be why with the flat ribbon cable from a different PSU you were trying to use with the EVGA G3 PSU didn't work.


CPU: Intel i7 6700k  | Motherboard: Gigabyte Z170x Gaming 5 | RAM: 2x8GB 3000MHz G.Skill Ripjaws 5 | GPU: Gigabyte Aorus GTX 1080ti | PSU: Corsair RM750x (2018) | Case: BeQuiet SilentBase 800 | Cooler: Corsair H100i AIO | SSD: Samsung 970 Evo 500GB + Samsung 840 500GB | HDD: Seagate Ironwolf 8TB + 2x Seagate Ironwolf 6TB | Monitor: Acer Predator XB271HU + Samsung BX2450

Link to post
Share on other sites

To expand on what @Spotty explained, your computer wasn't starting because the PSU was engaging its SCP (short-circuit protection) to protect your equipment from short-circuit damage caused by the wrong cable.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×