Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
johnnyleano69

CIsco 2921 router

Recommended Posts

Posted · Original PosterOP

Hi, I'm trying to set up some labs on my router and switch. I have been watching several videos on how to configure the ports on the router. I get to setting up DHCP and then when i do a "do ping 8.8.8.8" i get 0/5 succession rate. 

I ran debug mode but i also see that it says un-route able so i must be missing something. Please help 

Link to post
Share on other sites

Hi, 

 

Are there any routes when you type show ip route? 

 

What is your setup like? May I also know the DHCP command you used? 

Link to post
Share on other sites
Posted · Original PosterOP

Well let me be honest i am kind of new to the whole cisco world. 

So i cleared the cleared the configurations that were on it 

I think connected the ethernet cable from my modem to Interface g0/0

I then did 

router> enable

entered my password

router# config t

router#(config) int g0/0 

router#(config if)no shutdown 

router#(config if)ip address dhcp

router#(config if) exit

router#(config ) do ping 8.8.8.8 

thats when i got the error message 

 

Link to post
Share on other sites
57 minutes ago, johnnyleano69 said:

i will get a screenshot to better show my issues

 

No problem. Everything looks right. Will you be able to post the results of the below commands? 
 

router> enable 

Type password

router# show ip interface brief

router# show ip route

 

First command will show if you got an IP on G0/0 interface. Second will show the routing table. 

Link to post
Share on other sites
Posted · Original PosterOP

image.png.f22d488d1aa53692712db8b44da1e4f9.pngimage.png.2db8c937b762bfd12df591a5664d153e.png

 

 

 

So after a few more tries i finally got back around to the do ping .8.8.8.8 and it was successful with the connection 

but i reached another impass once i was trying to configure dhcp 

These screen shots were also taken with the ISP connection running through it because i needed to hop back on my computer to find more help 

 

Link to post
Share on other sites
14 minutes ago, johnnyleano69 said:

image.png.f22d488d1aa53692712db8b44da1e4f9.pngimage.png.2db8c937b762bfd12df591a5664d153e.png

 

 

 

So after a few more tries i finally got back around to the do ping .8.8.8.8 and it was successful with the connection 

but i reached another impass once i was trying to configure dhcp 

These screen shots were also taken with the ISP connection running through it because i needed to hop back on my computer to find more help 

 

Interesting. 
 

So I see that G0/0 is configured as DHCP client but hasn’t received an IP from the upstream modem. 
 

And for the DHCP server pool, have you configured default router and DNS? 
 

After enable and pool selection, use commands

 

ip dhcp pool Base

default-router 192.168.2.1

dns-server 8.8.8.8

 

Default router sets the default router for DHCP clients. 
 

You can remove unwanted pools using “no ip dhcp pool base” command. 

Link to post
Share on other sites
2 hours ago, johnnyleano69 said:

im gonna keep worklng at it since i just woke up 

 

Sure, let me know if you have any update. 

Link to post
Share on other sites
Posted · Original PosterOP

geez i think i am two steps back now. So i started it up and then i realized that it didn't save. 

So i reconfiged the g0/0 interface 

so i did 

router> enable

Router#config t
Router(config)#int g0/0
Router(config-if)#no shutdown
Router(config-if)#ip address dhcp
Router(config-if)#do ping 8.8.8.8
% Unrecognized host or address, or protocol not running.

Router(config-if)#exit
Router(config)#do ping 8.8.8.8
% Unrecognized host or address, or protocol not running.
 

router

Link to post
Share on other sites
4 hours ago, johnnyleano69 said:

geez i think i am two steps back now. So i started it up and then i realized that it didn't save. 

So i reconfiged the g0/0 interface 

so i did 

router> enable

Router#config t
Router(config)#int g0/0
Router(config-if)#no shutdown
Router(config-if)#ip address dhcp
Router(config-if)#do ping 8.8.8.8
% Unrecognized host or address, or protocol not running.

Router(config-if)#exit
Router(config)#do ping 8.8.8.8
% Unrecognized host or address, or protocol not running.
 

router

Oops. That isn’t good. Do remember to use command “copy run start” if you are planning to restart the system. 
 

In regards to the error, It is usually displayed when default gateway isn’t assigned yet. 
 

In terms of the DHCP client, I would suggest if you could set a static IP rather than using DHCP. Would make it easier for us. Would that be possible? 
 

int g0/0

ip address 192.168.1.2 255.255.255.0 (<- IP assigned from modem)

no shutdown

exit


Can you try after that?

Link to post
Share on other sites
Posted · Original PosterOP
50 minutes ago, HawkJ said:

Oops. That isn’t good. Do remember to use command “copy run start” if you are planning to restart the system. 
 

In regards to the error, It is usually displayed when default gateway isn’t assigned yet. 
 

In terms of the DHCP client, I would suggest if you could set a static IP rather than using DHCP. Would make it easier for us. Would that be possible? 
 

int g0/0

ip address 192.168.1.2 255.255.255.0 (<- IP assigned from modem)

no shutdown

exit


Can you try after that?

Router>enable
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int g0/0
Router(config-if)#no shutdown
Router(config-if)#i
*Jul 17 07:13:04.603: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to dow
Router(config-if)#
*Jul 17 07:13:09.187: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up
*Jul 17 07:13:10.187: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#exit
Router(config)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router(config)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router(config)#
 

 

 

 

This is where i am at now 

 

Link to post
Share on other sites
Posted · Original PosterOP
17 minutes ago, johnnyleano69 said:

Router>enable
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int g0/0
Router(config-if)#no shutdown
Router(config-if)#i
*Jul 17 07:13:04.603: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to dow
Router(config-if)#
*Jul 17 07:13:09.187: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up
*Jul 17 07:13:10.187: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#exit
Router(config)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router(config)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router(config)#
 

 

 

 

This is where i am at now 

 

Router(config)#Success rate is 0 percent (0/5)
                 ^
% Invalid input detected at '^' marker.

Router(config)#Router(config)#
                     ^
% Invalid input detected at '^' marker.

Router(config)#
*Jul 17 07:18:00.187: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state                                             to down
*Jul 17 07:18:01.187: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to down
Router(config)#
Router(config)#
Router(config)#
Router(config)#exit
Router#
*Jul 17 07:30:15.983: %SYS-5-CONFIG_I: Configured from console by console
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int g0/0
Router(config-if)#no shutdown
Router(config-if)#ip address dhcp
Router(config-if)#exit
Router(config)#exit
Router#
*Jul 17 07:31:16.251: %SYS-5-CONFIG_I: Configured from console by console
Router#do ping 8.8.8.8
          ^
% Invalid input detected at '^' marker.

Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router(config)#
*Jul 17 07:32:07.187: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up
*Jul 17 07:32:08.187: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state                                             to up
Router(config)#do
*Jul 17 07:32:18.251: %DHCP-6-ADDRESS_ASSIGN: Interface GigabitEthernet0/0 assigned DHCP address 192.168                                            .1.116, mask 255.255.255.0, hostname
do ping 8.8.8.8
                 ^
% Invalid input detected at '^' marker.

Router(config)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms
Router(config)#
 

 

 

 

 

 

So i decided to check if connecting the router directly to my isp router would work and see what would happen 

 so it goes 

ISP Modem > ISP Router > Cisco 2921 Router > ( Then planning to set up a Cisco 2950 Switch with it as well ) 

 

 

I was wondering why this work instead of the original configuration i had which was 

ISP Modem > Cisco 2921 Router > (2950 Switch ) 

i feel like i cheated i process though.

It is for labs but maybe i was doing it wrong ?

 

Link to post
Share on other sites
Posted · Original PosterOP

Self-Installation of Spectrum Internet, WiFi & Voice | Spectrum ...This is what the set up basically looks like except i was running the ethernet from the back of the modem directly to the cisco router 

Link to post
Share on other sites
1 hour ago, johnnyleano69 said:

Self-Installation of Spectrum Internet, WiFi & Voice | Spectrum ...This is what the set up basically looks like except i was running the ethernet from the back of the modem directly to the cisco router 

Oh okay. And do you know if DHCP is ok for the Cisco router if you connect it directly to the modem? Or do they use like PPPoE? If you don’t know, we can extract some information from your current router and see if it’s DHCP or PPPoE or Static IP or if they are using something else for it. 

Link to post
Share on other sites

The reason why Cisco router is not working with the modem is probably because your ISP is expecting a different setting to DHCP from the Cisco router to connect to the internet

Link to post
Share on other sites
On 7/16/2020 at 4:04 AM, johnnyleano69 said:

Hi, I'm trying to set up some labs on my router and switch. I have been watching several videos on how to configure the ports on the router. I get to setting up DHCP and then when i do a "do ping 8.8.8.8" i get 0/5 succession rate. 

I ran debug mode but i also see that it says un-route able so i must be missing something. Please help 

If your Cisco router is behind your modem/Router

 

so like 

 

ip route 0.0.0.0 0.0.0.0 192.168.0.0 (IP address of your modem/router)

8 hours ago, johnnyleano69 said:


Router(config-if)#ip address dhcp

 

router

Can you type in

 

IP address dhcp set route


CPU: i7 4790K |CPU Cooler: CM Hyper 212 Evo | Motherboard: Z97-A | RAM: 4x4GB Kingston Memory 1600mhz | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 120GB Kingston V300 SSD | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer 302USB Xenyx 5 Input Mixer | Neewer® NW-700 Microphone | Behringer PS400 Micropower Phantom Power Supply

 

Networking gear:  Lenovo ThinkCenter M82 ESXi 6.7 | Dell PowerEdge R210 II MDT/PDQ | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5505 VPN  | Cisco Catalyst 3750 Gigabit Switch

 

 

Link to post
Share on other sites
Posted · Original PosterOP

Well i think the ISP router already is configured to DHCP 

and yes i would like to find out more and what do i need to do to give u more information 

 

Link to post
Share on other sites
Posted · Original PosterOP
17 hours ago, HawkJ said:

The reason why Cisco router is not working with the modem is probably because your ISP is expecting a different setting to DHCP from the Cisco router to connect to the internet

Well i think the ISP router already is configured to DHCP 

and yes i would like to find out more and what do i need to do to give u more information 

Link to post
Share on other sites
Posted · Original PosterOP
16 hours ago, Sir Asvald said:

If your Cisco router is behind your modem/Router

 

so like 

 

ip route 0.0.0.0 0.0.0.0 192.168.0.0 (IP address of your modem/router)

Can you type in

 

IP address dhcp set route

i will do that right now 

 

Link to post
Share on other sites
4 hours ago, johnnyleano69 said:

i will do that right now 

 

Any luck?

 


CPU: i7 4790K |CPU Cooler: CM Hyper 212 Evo | Motherboard: Z97-A | RAM: 4x4GB Kingston Memory 1600mhz | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 120GB Kingston V300 SSD | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer 302USB Xenyx 5 Input Mixer | Neewer® NW-700 Microphone | Behringer PS400 Micropower Phantom Power Supply

 

Networking gear:  Lenovo ThinkCenter M82 ESXi 6.7 | Dell PowerEdge R210 II MDT/PDQ | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5505 VPN  | Cisco Catalyst 3750 Gigabit Switch

 

 

Link to post
Share on other sites
5 hours ago, johnnyleano69 said:

Well i think the ISP router already is configured to DHCP 

and yes i would like to find out more and what do i need to do to give u more information 

The best way would be to connect the ISPs WiFi router to your laptop and try accessing the routers webpage using the browser. The default gateway on your laptop should be the IP of the ISPs WiFi router. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×