Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Ritsukashy

New AMD High CPU Temps and Gpu weirdness

Recommended Posts

Posted · Original PosterOP

I just upgraded my pc to a AMD 3950x with new motherboard and ram since i was Intel before. The whole build went fine everything posted and installed normally but i noticed my fans on my AIO were going pretty high when i was just setting my pc up and web browsing. I checked task manager to see if my pc was doing something but no cpu at 2-4% usage. So i opened up my Cam software to see that my temps were at 55-60 at idle sometimes even reaches 70 and my fans were going loud because of it. I decided to the install the cpu cooler and everything and temps are the same. The liquid in the cooler never goes above 35 and goes into mid 20 often but the cpu never does under 50. i decided to run a game to see how wot it would get and it went to high 70 and was going into 80. I'm using a nzxt x52 and it was working fine before and i don't think its the issue. My second issue is that when ruining games to test the cpu i noticed my gpu always under reported the utilization some games just said it was at 1% while most were at 20%. i dint have the issue before either. Anyone have a clue whats going on? is the 3950x really that hot normally? Any help would be appreciated. I have reinstalled gpu drivers after a ddu to see if that would fix the gpu problem but it didn't do anything

 

P.S i did use ryzen master to see the cpu temps but it still says 50 so its on average lower than the opther temps ive seen but still doesnt go lower and my room is air conditioned to 23C 74F

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×