Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Habibikr

HELP! Reboot and Select Proper Boot Device ERROR

Recommended Posts

Posted · Original PosterOP

Thank you in advance. 

I have just finished building my PC (specs below), and get into ASUS BIOS. The BIOS recognises all the hardware, and everything works seamlessly. The problem appears when I click boot from Sandisk USB (ExFat) to boot up Windows 10 (downloaded onto the USB from a macbook). Instead of starting up Windows 10 for the first time, the message "reboot and select proper boot device or insert boot media in selected boot device and press a key_" appears. I have searched online for upwards of 7 hours, asked friends, double checked the hardware (which seems in perfect condition), played around with the CSM (and now put it back to default), but nothing seems to be working. Could the problem be that I cannot open the windows 10 download on my macbook and accept their agreements?

Please, I would love any suggestions or advice from anyone. 

 

Specs (all new): Ryzen 5 3600, Asus ROG Strix B450-F Gaming, GTX 1650 super, G-Skill 16GB 3200Mhz, 1TB SSD, 2TB Hard Drive, BeQuiet PurePower 600w, Cooler master Hyper 212 Black Edition CPU Cooler, 4 fans. 

 

This is the error which appears. 

image.png.f81e1d0a769754339211a1556564122b.png

 

Thank you for your time!

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, ChrisZH said:

Are you booting to install windows?

Yes, for Windows 10 English 64-Bit.

Link to post
Share on other sites
19 minutes ago, Habibikr said:

Yes, for Windows 10 English 64-Bit.

You download and make an iso image?

Link to post
Share on other sites
Posted · Original PosterOP
11 hours ago, ChrisZH said:

You download and make an iso image?

I can't make it an ISO image, I think its because im on mac. Do you think thats the problem?

Link to post
Share on other sites
11 hours ago, Habibikr said:

I can't make it an ISO image, I think its because im on mac. Do you think thats the problem?

That's what my guess would be, to install windows from USB it needs iso image I think 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×