Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
A1_Steak_Sauce

Monitor backlight turns on but no picture.

Recommended Posts

Posted · Original PosterOP

So I switched from the HDMI input to the Display Port input on my monitor and the monitor stopped displaying an image. My PC outputs to other displays, so I know that's not the problem, and neither is the video or power cables. When I turn on the monitor the back light shines through, however, the logo splash screen doesn't come up and I can't get the OSD to come up. Anybody have any ideas? Thanks!

Link to post
Share on other sites

It might be a bad cable, try using a different cable. That is what was wrong with my monitor when this happened.

Link to post
Share on other sites
Posted · Original PosterOP
2 hours ago, jsugarman2005 said:

It might be a bad cable, try using a different cable. That is what was wrong with my monitor when this happened.

I've tried the monitor with known-good video cables, both DisplayPort and HDMI, and it still displays nothing but a black screen.

Link to post
Share on other sites
11 hours ago, A1_Steak_Sauce said:

I've tried the monitor with known-good video cables, both DisplayPort and HDMI, and it still displays nothing but a black screen.

It could be the ports on the GPU or monitor

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×