Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Lukman

How to prevent keyboard press or mouse click from turning on my PC? (MSI Z97 GAMING 5)

Recommended Posts

Posted · Original PosterOP

I apologize in advance if this is the wrong sub to ask this question.

 

A few weeks ago I noticed that I couldn't wake up my PC from Sleep on Windows 10 by pressing keyboard or clicking a mouse button. If my memory serves, I don't have this problem back when I was using Windows 7 (on the same PC or even on my old laptop).

After doing a bunch of searching and trying almost everything that the internet has to offer for a possible fix, nothing worked, but I found a very simple solution to this problem, which is enabling the "Resume by USB Device" option on BIOS Settings (I'm using MSI Z97 Gaming 5 mobo) under "Settings\Advanced\Wake Up Event Setup". I could wake my PC up from Sleep using my keyboard/mouse now.

lHFFHxB.jpg

(sorry btw, couldn't find a FAT drive lying around, which apparently needed to save BIOS screenshot)

 

This, HOWEVER, apparently creates another issue for me. I rarely shut down my PC, I usually just use Hibernate or Sleep (I actually use Restart more than Shut down). But last night for some reason I wanted to shut down my PC before going to sleep, so I did. That's when I noticed that my keyboard was still on (the LED or whatever effect on my cheap gaming keyboard was on), my cheap little speaker that's powered up via USB 2.0 was also still on. They usually turn off immediately after I shut down my PC. I got curious, thinking maybe I misclicked on Sleep instead of Shut down, so I pressed a random key on my keyboard and it turned on (not wake up), doing POST, booting, and all that stuff. I then tried to shut it down again a couple times and same results.

I just did another test and apparently I can also wake my PC from hibernation using my keyboard/mouse. This isn't how it used to be.

 

So, the question is, is there a way so I can still wake up my PC from Sleep using keyboard/mouse, but at the same time prevent them from booting up my PC from a hibernation/shut down state?

Obviously if I disable the "Resume by USB Device" option, I can prevent turning on my PC by keyboard/mouse, but then I couldn't wake it up from sleep using keyboard/mouse, which is what I currently need because I stay at home a lot. But sometimes when I do go out, I usually shut down/hibernate my PC and I don't want something or somebody accidentally pushing a button and turning it on.

 

Any help or response is appreciated.

 

UPDATE:

So far, I've tried:

  • Disabling "Turn on fast startup" in Power Options. Didn't work.
  • Disabling Fast Boot in BIOS (I don't even know what it does, or what it's for). Didn't work.
  • Enabling the "EuP 2013" power management option in BIOS. 50% works. It prevents my PC from booting up while keeping the ability to wake it up from Sleep via keyboard/mouse, BUT my keyboard and speaker (and probably other peripherals that are still plugged in via USB) are still on, which is annoying because I can't turn off the damn light effect on this keyboard.

65UeYzl.jpg

Link to post
Share on other sites

I have an ASRock Z87 board.

 

I have a Corsair K70 keyboard, and Windows has been alternating between turning the keyboard off and not waking up and being unable to get into the BIOS since turning legacy USB support off. The mouse... also doesn't work in the bios.

 

I'm like "... you know what, I could reset the nvram and fix it"

 

If you want too prevent the mouse and keyboard from waking the PC, it has to be turned off in the BIOS, this is a BIOS feature as it ties into the power management, and the OS doesn't really have control over power management.  In laptops there's usually a separate microcontroller that actually does this.

 

However if Windows is turning usb stuff off and not turning it back on, this falls under Windows power management in regards to USB.

 

Control Panel\Hardware and Sound\Power Options\Edit Plan Settings

click advanced

USB selective suspend. I leave it disabled. Mouse works fine and wakes up, Keyboard however sometimes does not.

 

Honestly I think it's just a problem with USB gaming keyboards that have the n-key-rollover feature. The Corsair has an actual switch on it to have BIOS mode, but it doesn't work for me to get into the BIOS, which I suspect is just the same problem windows has.

 

If the problem is the same with the mouse, then start looking at USB problems.

Link to post
Share on other sites

My guess is, that Windows is configured to go into energy saving mode (S4) when you shutdown. So it doesn't really shutdown but it's also not the same as sleep. The setting should be somehwere here: Start > Settings > System > Power & sleep > Additional power settings > Choose what the power button does (I have german OS so I can't tell you the exact option names).

https://docs.microsoft.com/en-us/windows/win32/power/system-power-states

Link to post
Share on other sites
Posted · Original PosterOP
5 hours ago, Kisai said:

If you want too prevent the mouse and keyboard from waking the PC, it has to be turned off in the BIOS, this is a BIOS feature as it ties into the power management, and the OS doesn't really have control over power management.  In laptops there's usually a separate microcontroller that actually does this.

 

However if Windows is turning usb stuff off and not turning it back on, this falls under Windows power management in regards to USB.

 

Control Panel\Hardware and Sound\Power Options\Edit Plan Settings

click advanced

USB selective suspend. I leave it disabled. Mouse works fine and wakes up, Keyboard however sometimes does not.

 

Honestly I think it's just a problem with USB gaming keyboards that have the n-key-rollover feature. The Corsair has an actual switch on it to have BIOS mode, but it doesn't work for me to get into the BIOS, which I suspect is just the same problem windows has.

 

If the problem is the same with the mouse, then start looking at USB problems.

So, I decide to disable the "Resume by USB Device" BIOS option. I'm back to where I started, unable to wake the PC from Sleep using mouse/keyboard. One thing that's a bit strange is, when I put the computer to Sleep, the keyboard and mouse (Logitech G402) seem to turn off successfully (there are no light effects on both). When I try pressing a keyboard button, the keyboard seems to turn on because the NUM Lock LED indicator is suddenly on. However, the computer still won't wake up. On the other hand, when I try to click a mouse button, nothing's happening, no light's turned on, nada.

The only thing that would wake the PC is by pressing the Power Button on the case.

I've disabled the "USB selective suspend setting" and it didn't have any effect.

 

4 hours ago, Korben said:

My guess is, that Windows is configured to go into energy saving mode (S4) when you shutdown. So it doesn't really shutdown but it's also not the same as sleep. The setting should be somehwere here: Start > Settings > System > Power & sleep > Additional power settings > Choose what the power button does (I have german OS so I can't tell you the exact option names).

https://docs.microsoft.com/en-us/windows/win32/power/system-power-states

Apparently, it is said in the "Resume by USB Device" BIOS option that it will enable/disable system wake up from S3/S4/S5. So, according to the information in the link you provided, S5 is Soft Off/full shutdown, but enabling this BIOS option would pretty much override it, which is probably why the keyboard is kept ON.

JcA3Xr2.jpg

It seems that this is one of those "you can't have one without the other" situations. So, in order for me to be able to wake up the system from Sleep (S3) using mouse/keyboard, I have to accept that my system can be booted up (from S4/S5) using mouse/keyboard.

Sigh. :( I currently have it disabled. Back to Power Button for waking up.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×