Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
5GigaaHertz

my front mic jack doesnt work

Recommended Posts

Posted · Original PosterOP

I already double checked if my front i/o is properly plugged in. 

i also checked the drivers but the device manager says it is updated. 

the driver page of my motherboard is confusing because idk what to download

My motherboard is Asus H110m-k 

what can i do?

Link to post
Share on other sites

Uninstall the current driver and restart the computer, it should detect hardware on next startup and get the right driver. If not you might need to use 3rd party driver installer or maybe it's hardware to blame.

Link to post
Share on other sites

Go into sound-manager, into the properties of the mic and tick the box that says something like "Front-Panel Microphone". (My windows is in german, don't know it says exactly in english).


CPU: AMD Ryzen 7 3700X - Motherboard: MSI B450 Tomahawk Max - GPU: Asus GTX 1080 Ti - RAM: 16 GB Crucial Ballistix 3600MHz cl16 - PSU: Corsair RMx 650W - Storage: 500 GB Samsung Evo 850 2,5" + 2 TB Samsung Evo 860 M.2 - Cooling: Noctua NH-D15 (CPU) + Raijintek Morpheus II (GPU) - Case: CoolerMaster Mastercase H500 - Fans: Noctua 2x NF-A20 (Front), 1x NF-A14 (Top back), 1x NF-F12 (Back), 2x NF-A12x15 (GPU) - Soundcard: Asus Xonar Essence STX II - Fan Controller: Corsair Commander Pro - OS: Windows 10 Pro - Monitor: AOC AG352UCG6 Secondary Monitor: AOC 24G2 HDR-Gaming-TV: LG C9 OLED 55" - Mouse: Corsair Dark Core RGB Pro SE Wireless - Keyboard: Corsair K63 Wireless + Lapboard - Headphones: Beyerdynamic DT990 Edition 600 Ohm - Microphone: Antlion ModMic

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×