Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
itsjustind

GPU Issue?

Recommended Posts

Posted · Original PosterOP

So this afternoon I was running a game of CoD perfectly fine until my monitor decided to completely turn black, and a no signal decided to pop up.

 

I've since tried a brand new Display Port cable, HDMI cable, unplugged the monitor power cable, and used a different monitor.

At this point in time I'm frustrated and confused as to what the issue may be, the issue still persists with all of these methods listed above.

 

My GPU is a Gigabyte GeForce RTX 2070 Super Windforce OC 3X 8G GDDR6 1785MHz. 

 

After using the new monitor on my PC I'm adamant that it may be my GPU and not the monitor if the issue persisted with the new monitor.

Link to post
Share on other sites
4 minutes ago, itsjustind said:

So this afternoon I was running a game of CoD perfectly fine until my monitor decided to completely turn black, and a no signal decided to pop up.

 

I've since tried a brand new Display Port cable, HDMI cable, unplugged the monitor power cable, and used a different monitor.

At this point in time I'm frustrated and confused as to what the issue may be, the issue still persists with all of these methods listed above.

 

My GPU is a Gigabyte GeForce RTX 2070 Super Windforce OC 3X 8G GDDR6 1785MHz. 

 

After using the new monitor on my PC I'm adamant that it may be my GPU and not the monitor if the issue persisted with the new monitor.

DDU drivers and reinstall them.


@BlueScope819 so I can see your post

#MuricaParrotGang

My name is Legion 'Murica Parrot Gang, for we are many.

If a design is taking too long, the design is wrong, and therefore, the design must be modified to accelerate progress. -Elon

Mentioned in 8/5/2020 TechLinked

Link to post
Share on other sites
Posted · Original PosterOP
4 minutes ago, BlueScope819 said:

DDU drivers and reinstall them.

How can I reinstall them if I can't even get to my desktop? It's completely black from the startup?

Link to post
Share on other sites
Just now, itsjustind said:

How can I reinstall them if I can't even get to my desktop? It's completely black from the startup?

Can you boot into safe mode? That's the idea. DDU from safe mode than boot normally to reinstall.


@BlueScope819 so I can see your post

#MuricaParrotGang

My name is Legion 'Murica Parrot Gang, for we are many.

If a design is taking too long, the design is wrong, and therefore, the design must be modified to accelerate progress. -Elon

Mentioned in 8/5/2020 TechLinked

Link to post
Share on other sites

I’ve had this exact issue, it is most likely your psu. I had a crappy psu once and it did a similar thing before my psu completely stopped working. Buy a new psu.

Link to post
Share on other sites
Posted · Original PosterOP
11 hours ago, BlueScope819 said:

Can you boot into safe mode? That's the idea. DDU from safe mode than boot normally to reinstall.

Nope, my computer turns on, monitor has no response and remains black. Safe mode is not an option lol

Link to post
Share on other sites
52 minutes ago, itsjustind said:

Nope, my computer turns on, monitor has no response and remains black. Safe mode is not an option lol

Do you have a CPU with graphics on it? Try booting into safe mode and DDUing drivers from there with another graphics card.


@BlueScope819 so I can see your post

#MuricaParrotGang

My name is Legion 'Murica Parrot Gang, for we are many.

If a design is taking too long, the design is wrong, and therefore, the design must be modified to accelerate progress. -Elon

Mentioned in 8/5/2020 TechLinked

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, BlueScope819 said:

Do you have a CPU with graphics on it? Try booting into safe mode and DDUing drivers from there with another graphics card.

I’m assuming you meant on-board graphics? Like through my mobo/cpu, I’ve connected the DP Cable to my mobo and still no luck, screen remains black with a no signal 

Link to post
Share on other sites
4 minutes ago, itsjustind said:

I’m assuming you meant on-board graphics? Like through my mobo/cpu, I’ve connected the DP Cable to my mobo and still no luck, screen remains black with a no signal 

What CPU do you have


@BlueScope819 so I can see your post

#MuricaParrotGang

My name is Legion 'Murica Parrot Gang, for we are many.

If a design is taking too long, the design is wrong, and therefore, the design must be modified to accelerate progress. -Elon

Mentioned in 8/5/2020 TechLinked

Link to post
Share on other sites

Full spec list?


Desktop: Intel Core i9-9900K | be quiet! Dark Rock Pro 4 | ASUS Strix Z390-F |G.Skill Trident Z Neo (2x16GB, 3200MHz CL14) | EVGA GeForce RTX 2070 SUPER XC Ultra | Corsair RM650x | Fractal Design Define R6

Laptop: 2018 Apple MacBook Pro 13" (i5-8259U | 8GB LPDDR3 | 512GB NVMe)

Peripherals: Ducky Shine 7 (Cherry MX Brown) | Logitech MX Master 3 & Razer Basilisk X HyperSpeed | Beyerdynamic Custom One Pro Plus | Audio-Technica AT2020USB+

Displays: Alienware AW2521HF & BenQ BL2420PT

Link to post
Share on other sites
Posted · Original PosterOP

Asus prime x470 

AMD Ryzen 7 2700x
Corsair 2x8GB 

Gigabyte 2070Super windforce 3x 8G

Corsair h110i platinum

Corsair TXM 750W

AOC 24G2 Frameless IPS

 

 

 

Link to post
Share on other sites
15 minutes ago, itsjustind said:

Asus prime x470 

AMD Ryzen 7 2700x
Corsair 2x8GB 

Gigabyte 2070Super windforce 3x 8G

Corsair h110i platinum

Corsair TXM 750W

AOC 24G2 Frameless IPS

 

 

Ryzen CPU doesn't have an iGPU on-die (unlike Ryzen APUs).

You'll need a temporary GPU to confirm whether or not the GPU (RTX 2070S) is at fault.


Intel Z390 Rig ( *NEW* Primary )

Intel X99 Rig (Officially Decommissioned, Dead CPU returned to Intel)

  • i7-8086K @ 5.1 GHz (still tweaking) -- i7-6800K
  • Gigabyte Z390 Aorus Master -- ASUS X99 Deluxe
  • Sapphire NITRO+ RX 5700 XT Special Edition -- 2x Sapphire NITRO R9-Fury in Crossfire
  • 32GB G.Skill TridentZ DDR4-3000 CL14 (16GB TridentZ RGB + 16GB Red/Black TridentZ)
  • SanDisk 480 GB SSD + 1TB Samsung 860 EVO + 1TB Intel 660p NVMe
  • EVGA SuperNOVA 850W P2 + Red/White CableMod Cables
  • Phanteks Enthoo Luxe Tempered Glass Edition
  • Ekwb Custom loop
  • Logitech G502 Proteus Spectrum + Corsair K70 (Red LED, anodized black, Cheery MX Browns)

Intel Z97 Rig (Secondary)

  • Intel i5-4690K 4.8 GHz
  • ASUS ROG Maximus VII Hero Z97
  • Sapphire Vapor-X HD 7950 EVGA GTX 1070 SC Black Edition ACX 3.0
  • 20 GB (8GB X 2 + 4GB X 1) Corsair Vengeance DDR3 1600 MHz
  • Corsair A50 air cooler  NZXT X61
  • Crucial MX500 1TB SSD + SanDisk Ultra II 240GB SSD + WD Caviar Black 1TB HDD + Kingston V300 120GB SSD [non-gimped version]
  • Antec New TruePower 550W EVGA G2 650W + White CableMod cables
  • Cooler Master HAF 912 White NZXT S340 Elite w/ white LED stips

AMD 990FX Rig (Decommissioned)

  • FX-8350 @ 4.8 / 4.9 GHz (given up on the 5.0 / 5.1 GHz attempt)
  • ASUS ROG Crosshair V Formula 990FX
  • 12 GB (4 GB X 3) G.Skill RipJawsX DDR3 @ 1866 MHz
  • Sapphire Vapor-X HD 7970 + Sapphire Dual-X HD 7970 in Crossfire  Sapphire NITRO R9-Fury in Crossfire *NONE*
  • Thermaltake Frio w/ Cooler Master JetFlo's in push-pull
  • Samsung 850 EVO 500GB SSD + Kingston V300 120GB SSD + WD Caviar Black 1TB HDD
  • Corsair TX850 (ver.1)
  • Cooler Master HAF 932

 

<> Electrical Engineer , B.Eng <>

<> Electronics & Computer Engineering Technologist (Diploma + Advanced Diploma) <>

<> Electronics Engineering Technician for the Canadian Department of National Defence <>

Link to post
Share on other sites
Posted · Original PosterOP
6 hours ago, -rascal- said:

 

Ryzen CPU doesn't have an iGPU on-die (unlike Ryzen APUs).

You'll need a temporary GPU to confirm whether or not the GPU (RTX 2070S) is at fault.

Okay so I got a friend to lend me his old GPU, so if that doesn't work then it's probably the MOBO, and if it does then its my GPU. I'm only concerned with gigabytes rma and the lengthy wait time, versus buying a new MOBO and RMA'ing it. GPU's aren't the most cost friendly to purchase.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×