Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ANewLevel091

Could there still be something wrong?

Recommended Posts

Posted · Original PosterOP

     So I apologize if I put this in the wrong place, this is only the second time I have posted here. I just recently bough an Ailenware Aurora R9 and soon after the motherboard apparently died on me. After a hell of a time with Dell I finally got the thing back. My problem is something still doesn't seem quite right, originally the problem was when I would turn the computer on nothing would show up on screen, my color profile loaded and my keyboard and mouse lit up but soon after it would turn itself off and back on again and continue endlessly. Now it seems to be doing the same thing again but this time after the first on/off cycle it posts and loads into windows. I had read somewhere that this had happened to someone else and ended up going through several mobos before he found out that his front usb had a short in it. Im not really sure what to do but it scares the crap out of me. If anyone has any suggestions I would greatly appreciate them.

Link to post
Share on other sites
Posted · Original PosterOP

Seriously man I know. You have no idea how much it kills me that I didnt just build one I am perfectly capable of doing so but it was during the whole descent into the covid bullshit and needed something asap that I though would be good quality for my home studio as my old computer wasnt handling my mixes anymore and I had projects piling up. The only slight saving grace is that I ended up spending less going with the Ailenware since they were running a $175 off special and Honey threw on an extra $250 off but I guess you get what you paid for right?

Link to post
Share on other sites

Same thing with me. I got mine (prebuilt) during the mining craze so it was cheaper to buy a prebuilt than build my own. I got lucky and havent had any issues. But I do have a very weird psu that I need to replace soon.


I am far from an expert in this so please correct me if I’m wrong.

Quote or tag me so I can see your response

 

PSU Tier List

Motherboard Tier List

 

Link to post
Share on other sites
Posted · Original PosterOP

Well Im almost wondering if the psu in mine could possibly be the problem. Theres no way I could have gotten two faulty motherboards in a row. The computer is working but it makes my heart drop everytime I press the power button and it does its weird little dance. Im not quite sure how to test a psu but hopefully I can figure it out with a multimeter and a little more research. What exactly is yours doing?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×