Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Mark_856

B450M Gaming Plus board won't load BIOS and DRAM LED is on

Recommended Posts

Posted · Original PosterOP

Today I upgraded my pc adding 2 more sticks of ram. When I power it on, I hear the HDD start spinning, and the CPU and system fans start spinning as expected. But then the DRAM LED turns on and stays on and the board does not load to BIOS. Also the display gets no signal.

 

System specs:

CPU: Ryzen 3 2200G with stock cooler
Motherboard: MSI B450M Gaming Plus Max
RAM: G.Skill RipjawsV 8GB DDR4-2800MHz (F4-2800C15D-8GVRB)
GPU: None

 

What I've tried:
Booting with all 4 RAM sticks in the board. The BIOS didn't load and the DRAM LED stayed on.
Booting with the 2 old RAM stick in the board, the pc booted normally. 
Booting with the 2 new RAM stick in the board, the pc booted normally. 

 

Pls help me

Link to post
Share on other sites

Clear the cmos 

For all we know it could be not matching sticks 

Mixing and matching different sticks could cause problems and is not always guaranteed to work 


My favorite case is the mechify c and it is the best case and if you say otherwise you're lying 

 

@TofuHaroto so I can see your post 

 

 

I seek to max the letter count on every ... Single ... Site 

only the bravest are capable of such mission

 

Spoiler

Hi

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×