Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
gtr2244

Logitech G Hub Borked

Recommended Posts

Posted · Original PosterOP

 I opened it up and it didn't recognize my mouse. Usually I just plug in my G903 mouse. I tried disabling the software with task manager, reinstalling, updating. Once it starts updating it usually gets stuck at 100% or stuck on the loading emblem.

I'll try calling Logitech when they open if I can get through.

Link to post
Share on other sites

G HUB is a piece of shit.

 

I've had it randomly bork itself and reinstalling sometimes doesn't help. You've got to get lucky until it decides to want to reinstall.


The Workhorse

R7 3700X | RTX 2070 Super | 32GB DDR4-3200 | 512GB SX8200P + 2TB 7200RPM Barracuda Compute | Windows 10 Pro

 

The Portable Station

Core i7 7700H | GTX 1060 | 8GB DDR4-2400 | 128GB SSD + 1TB HGST | Windows 10

 

Samsung Galaxy Note8 SM-N950F

Exynos 8895 ARM Mali G71 MP20 | 6GB LPDDR4 | 64GB internal + 128GB microSD | 6.3" 1440p "Infinity Display" AMOLED | Android Pie 9.0 w/ OneUI

Link to post
Share on other sites
Posted · Original PosterOP

I've reinstalled it a few times, then it doesn't recognize I have a mouse. So I try to update and it doesn't complete, stays on 100% or an endless loading loop. So many videos on this, no real solution.

Link to post
Share on other sites
Posted · Original PosterOP

I talked to Logitech support. I had to go into app data delete the files and program data. Reinstall and it works now. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×