Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Ohsnaps

Nvidia and Linux help

Try this may or may not work in your scenario

 

1) create or open this conf file:

sudo nano /etc/modprobe.d/zz-nvidia-modeset.conf

 

2) add the following line:

options nvidia_drm modeset=1

3) update your initramfs

sudo update-initramfs -u

4) reboot

 

Side note: are you using proprietary driver from under the additional drivers under settings?

 

 

Recommended Posts

Posted · Original PosterOP

Alright im on Ubuntu budgie and i've been working on getting everything working correctly with my gpus and Linux. I am having screen tearing pretty commonly. This occurs with and without force composition pipeline and or force full composition pipeline. i've had this issue with gnome and budgie (idk if other wouldn't) and driver version is the most recent 440. I have a 1070ti and a 1050ti the issue occurs when regardless if only one is plugged in or both. I need both for work that I do. Do any of you use ubuntu and not have this issue? Do any of you use a different distro and not have this issue lmk. Any suggestions would be appreciated.

Link to post
Share on other sites
Posted · Best Answer

Try this may or may not work in your scenario

 

1) create or open this conf file:

sudo nano /etc/modprobe.d/zz-nvidia-modeset.conf

 

2) add the following line:

options nvidia_drm modeset=1

3) update your initramfs

sudo update-initramfs -u

4) reboot

 

Side note: are you using proprietary driver from under the additional drivers under settings?

 

 


[DESKTOPCPU: Intel Core i7 8700k GPU: GIGABYTE GTX 1060 6GB RAM: 64GB GSKILL DDR4 Mobo: Asus z390-A Prime

Storage:1x 512 M.2 Crucial SSD 2x 512GB OCZ ssds, 2x 3Tb Seagate PSU: Thermaltake 650W Monitors: 2x LG 24" 1080p LED

 

[SERVER/NAS] CPU: Intel Core i7 7700K GPU: AMD RADEON R9 270x 4GB RAM: 32 GB Corsair Vengeance Mobo: Asus z-170P D3

Storage:1x 1TB Western Digital SSD, 4x Ironwolf Pro 12Tb HDD,  PSU: Thermaltake 650W

 

[LAPTOP (MacBook Pro 16")] CPU: 2.4 GHz 8-Core Intel Core i9, RAM: 32 GB 2667 MHz DDR4, SSD: 2 TB

GPU: AMD Radeon Pro 5500M 8GB Display: 16-inch (3072 x 1920)

 

 

Link to post
Share on other sites
Posted · Original PosterOP
14 minutes ago, sp331yi said:

Suggestion -- a different distro not utilizing a recource-hogging DE -- maybe eXtern OS

I like heavier distros simply because of support. I do a lot of work on my pc I need something with a lot of support but I also don't personally enjoy using Windows.

 

13 minutes ago, bradmonster said:

Try this may or may not work in your scenario

 

1) create or open this conf file:

sudo nano /etc/modprobe.d/zz-nvidia-modeset.conf

 

2) add the following line:


options nvidia_drm modeset=1

3) update your initramfs


sudo update-initramfs -u

4) reboot

 

Side note: are you using proprietary driver from under the additional drivers under settings?

 

 

Honestly if its not fixed its miles better Thank you I think It's fixed.

Link to post
Share on other sites

Sounds good bud!


[DESKTOPCPU: Intel Core i7 8700k GPU: GIGABYTE GTX 1060 6GB RAM: 64GB GSKILL DDR4 Mobo: Asus z390-A Prime

Storage:1x 512 M.2 Crucial SSD 2x 512GB OCZ ssds, 2x 3Tb Seagate PSU: Thermaltake 650W Monitors: 2x LG 24" 1080p LED

 

[SERVER/NAS] CPU: Intel Core i7 7700K GPU: AMD RADEON R9 270x 4GB RAM: 32 GB Corsair Vengeance Mobo: Asus z-170P D3

Storage:1x 1TB Western Digital SSD, 4x Ironwolf Pro 12Tb HDD,  PSU: Thermaltake 650W

 

[LAPTOP (MacBook Pro 16")] CPU: 2.4 GHz 8-Core Intel Core i9, RAM: 32 GB 2667 MHz DDR4, SSD: 2 TB

GPU: AMD Radeon Pro 5500M 8GB Display: 16-inch (3072 x 1920)

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×