Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
jebetron

HELP Ryzen 7 2700x stuck at 3.2Ghz

First check your WIndows 10 power management settings.

The minimum CPU power needs to be set to 5% or lower and the maximum needs to be set to 100%.

 

What often happens with Ryzen 2000 chips in Windows 10, is that both CPU power options (min and max) are set to 100%.

This means that cores can't clock low enough for the other cores to turbo up.

 

It's in German, but you get the point:

image.png.a0f09dc8f31af76767eb959f277bb285.png

Recommended Posts

Posted · Original PosterOP

Hello again!

I got my new CPU just yesterday and installed it right away.

I bought a new CPU (r7 2700x), a new mobo (Tuf B-450 gaming plus) and new ram (Corsair venegance 3000mhz) and it was working fine the day i installed it (yesterday) and this morning, turboing up to 4,1Ghz and so on. But now it's stuck on 3.2Ghz. I didn't change any setting or anything. Why is it doing this?


SPECS

Ryzen 7 2700x (with stock cooler)

Tuf b450 plus gaming

Corsair venegance rgb pro 3000mhz (oc to 3600mhz)

AMD RX 480 RF

Cooler Master 650w PSU

and a hard drive and ssd.


Best regards, Jebe

Link to post
Share on other sites

Has your room temperature changed significantly (10-20 degrees Fahrenheit, or 5-10 degrees Celsius)? Time of day could affect temperatures, thus affecting heat dissipation (the greater the difference, the better heat transfers). 

Link to post
Share on other sites

I'd try resetting your bios by pulling out the cmos battery and then reapplying your XMP profile on the ram


8086k Winner BABY!!

My tech stuff

 

Main rig

Cpu: R5 1600AF 3.95ghz 1.32v (literally the worst bin I've ever seen)

Mobo: MSI b450 A-Pro MAX

Ram: 16gb Team Group T-Force Xtreem 3600 cl18 (3466 14-14-14-14-28) kinda tuned subs

Gpu: MSI 1080 ti Duke OC

PSU: Bitfenix Formula Gold 650w

SSD: 512gb Inland premium nvme

HDD: 2tb Seagate Barracuda Compute

 

Samsung Galaxy S9 | SD845 | Adreno 640

 

Link to post
Share on other sites

Could be a bios based issue, have your tried checking the core voltages  etc in the bios? and if your board on cool-n-quiet mode?


[DESKTOPCPU: Intel Core i7 8700k GPU: GIGABYTE GTX 1060 6GB RAM: 64GB GSKILL DDR4 Mobo: Asus z390-A Prime

Storage:1x 512 M.2 Crucial SSD 2x 512GB OCZ ssds, 2x 3Tb Seagate PSU: Thermaltake 650W Monitors: 2x LG 24" 1080p LED

 

[SERVER/NAS] CPU: Intel Core i7 7700K GPU: AMD RADEON R9 270x 4GB RAM: 32 GB Corsair Vengeance Mobo: Asus z-170P D3

Storage:1x 1TB Western Digital SSD, 4x Ironwolf Pro 12Tb HDD,  PSU: Thermaltake 650W

 

[LAPTOP (MacBook Pro 16")] CPU: 2.4 GHz 8-Core Intel Core i9, RAM: 32 GB 2667 MHz DDR4, SSD: 2 TB

GPU: AMD Radeon Pro 5500M 8GB Display: 16-inch (3072 x 1920)

 

 

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, TheDankKoosh said:

I'd try resetting your bios by pulling out the cmos battery and then reapplying your XMP profile on the ram

I've already tried that, nothing.

Link to post
Share on other sites
Posted · Best Answer

First check your WIndows 10 power management settings.

The minimum CPU power needs to be set to 5% or lower and the maximum needs to be set to 100%.

 

What often happens with Ryzen 2000 chips in Windows 10, is that both CPU power options (min and max) are set to 100%.

This means that cores can't clock low enough for the other cores to turbo up.

 

It's in German, but you get the point:

image.png.a0f09dc8f31af76767eb959f277bb285.png

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, bradmonster said:

Could be a bios based issue, have your tried checking the core voltages  etc in the bios? and if your board on cool-n-quiet mode?

Yes i have, and nothing helps.

Link to post
Share on other sites
Posted · Original PosterOP

1 minute ago, jebetron said:

Yes i have, and nothing helps.

I had the "ultimate" power plan that i tought i had already done that but no. Thank you, a quick run of cinebench and it turbos like it should. 

 

Sorry my bad

 

:D

Link to post
Share on other sites
2 minutes ago, jebetron said:

I had the "ultimate" power plan that i tought i had already done that but no. Thank you, a quick run of cinebench and it turbos like it should. 

 

Sorry my bad

 

:D

When I got my 2700 I went mad because no one knew of this issue. Took me days to figure it out 😭

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×