Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Joe Jackman

Ethernet refuses to connect, but works on Windows(just mine)

UPDATE
Fixed.....

Just needed to change from full to half duplex, even my ISP have no clue but my connection shows its true package speed when i run at Half duplex now as the port itself is damaged (kinda) i believe it cannot push that many lanes(for full duplex) but windows somehow is able to carry it regardless (i made some changes in the adapter settings to give me stable ping). HOW THE FK I DIDN'T THINK OF THIS BEFORE.

https://www.garron.me/en/linux/ubuntu-network-speed-duplex-lan.html as to how i did it (i am still a noob but this was fun)
image.png

Recommended Posts

Posted · Original PosterOP

image.thumb.png.dbb2055f86f464b52e2ccc1b577507a6.pngFew days ago one of my ports died, and the next day after i checked it up by my ISP (they usually don't ask to bring the router to them) and after a lot of tinkering somehow it worked (he was shocked as he basically gave up on it and 5 min later it started to work again) . Later when i log into Linux_ it does not connect. If i just change the port (on the router), it connects with no issue. Also i have 2 other computer that CANNOT connect to that port. 

Link to post
Share on other sites

Are the ports somehow different (on the S/W side of the router)?

 

If I understand your description correctly, it looks like a failing port (i.e. doesn't work, works after fiddling, doesn't work at home while other ports work ... etc; i.e. works - doesn't work - works - doesn't work ... 🙂 )

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, Wild Penquin said:

Are the ports somehow different (on the S/W side of the router)?

 

If I understand your description correctly, it looks like a failing port (i.e. doesn't work, works after fiddling, doesn't work at home while other ports work ... etc; i.e. works - doesn't work - works - doesn't work ... 🙂 )

they are physically the same and ya idk. let me rephrase- it only works on my PC (windows), other PCs have windows too but they dont work (cant detect ethernet cable) as well as my Linux(dual boot).

 

Link to post
Share on other sites
Posted · Original PosterOP
On 6/9/2020 at 10:58 PM, Wild Penquin said:

Are the ports somehow different (on the S/W side of the router)?

 

If I understand your description correctly, it looks like a failing port (i.e. doesn't work, works after fiddling, doesn't work at home while other ports work ... etc; i.e. works - doesn't work - works - doesn't work ... 🙂 )

can you rephase what you asked, i didnt get it i think

 

Link to post
Share on other sites

What I meant, are the port  separately configurable on the router, and if they are, have you changed any settings?

 

If not -> it is most certainly a H/W failure on the router.

Link to post
Share on other sites
Posted · Original PosterOP
14 minutes ago, Wild Penquin said:

What I meant, are the port  separately configurable on the router, and if they are, have you changed any settings?

 

If not -> it is most certainly a H/W failure on the router.

um they are not, its static IP and DNS is fixed and i checked port trigg/forwarding but nothing there. but how is it a hardware failure if i am replying this using that port.

 

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

UPDATE
Fixed.....

Just needed to change from full to half duplex, even my ISP have no clue but my connection shows its true package speed when i run at Half duplex now as the port itself is damaged (kinda) i believe it cannot push that many lanes(for full duplex) but windows somehow is able to carry it regardless (i made some changes in the adapter settings to give me stable ping). HOW THE FK I DIDN'T THINK OF THIS BEFORE.

https://www.garron.me/en/linux/ubuntu-network-speed-duplex-lan.html as to how i did it (i am still a noob but this was fun)
image.png

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×