Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
4MINE

Brand New Benq monitor keeps rebooting when switched to 144hz refresh rate

Recommended Posts

Posted · Original PosterOP

Hello guys , 

I bought a new monitor yesterday , the Benq zowie Xl2411p and i plugged it with the display port that comes with it to my msi 1050 ti . I booted  my computer everything was all right , then when i switched to 144hz and applied it , it started rebooting and twinkling . help pls :( 

Link to post
Share on other sites

likely a bad display port cable. The ones that come with the monitors are almost always junk. Get yourself a different display port or use the DVI to enable 144hz. 


PSU Tier List Thread

 

"White Ice"

Ryzen 7 3700x | Asus Crosshair VIII Hero (Wi-Fi) | EVGA RTX 2080ti | Flare X 14-14-14-34 3200mhz 32gb | Full Custom Water Cooling Loop | 1tb Samsung 970 Evo

2tb Crucial MX500 SSD | 2x 3tb Seagate Drive | Fractal Design Meshify S2 |  EVGA G2 750w PSU | 3x Corsair LL140 | 3x Corsair LL120

 

Dedicated Streaming Rig

 Ryzen 7 1800x | Asus B450-F Strix | 16gb Vengeance LPX 3000mhz | Corsair RM550x (2018) | EVGA GTX 1060 3gb | 250gb 860 Evo m.2 | Phanteks Enthoo Evolv 

 Elgato HD60 Pro | Elgato 4k60 Pro mk.2 | Avermedia 4k GC573 Capture Card

 

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Skiiwee29 said:

likely a bad display port cable. The ones that come with the monitors are almost always junk. Get yourself a different display port or use the DVI to enable 144hz. 

ohh i see , i'll get another cable and retry , thanks for your help.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×