Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Atemu

Is my RTX 2080 Ti failing?

Recommended Posts

Posted · Original PosterOP

Hey!

 

Recently my RTX 2080 Ti started to act weird, I started to have artifacts on Windows and while playing video games as you can see on the following screenshots https://imgur.com/a/mPLD8IG.

 

spacer.png

 

spacer.png

 

spacer.png

 

spacer.png

 

Is my GPU failing? Is it like the issue people had when the RTX launched? If that's the case I guess I should probably start the RMA process

 

Thanks!

Link to post
Share on other sites

Welcome to the forums! Is it an RTX 2080ti Founders Edition from Nvidia or is it an aftermarket card?


Main Desktop: CPU - I9-9900k @5ghz | Mobo - Gigabyte Z390 Aorus Master | GPU - Asus ROG STRIX 2080ti OC RAM - G.Skill Trident Z RGB 16GB 3200mhz | AIO - H100i Pro RGB | PSU - Evga 850 GQ | Case - Fractal Design Meshify C White | Storage - Samsung 970 Pro M.2 NVME SSD 512GB / Sabrent Rocket 1TB NVME SSD / Samsung 860 Evo Pro 500GB / Seagate 2TB Firecuda Hybrid Drive |

 

TV Streaming PC: Intel Nuc CPU - i7 8th Gen | RAM - 16GB DDR4 2666mhz | Storage - 256GB WD Black M.2 NVME SSD |

 

Phone: Samsung Galaxy S10+ - Ceramic White 512GB |

 

If you ask for a Mid Tower case recommend, I will 90% of the time recommend the Fractal Design Meshify C or S2.

Link to post
Share on other sites

Those types of artifacts are usually an indication of 1 or 2 things, A: you have an OC that is to high and needs to be dialed back, or B: the Memory is failing and needs to be RMA'd


PSU Tier List Thread

 

"White Ice"

Ryzen 7 3700x | Asus Crosshair VIII Hero (Wi-Fi) | EVGA RTX 2080ti | Flare X 14-14-14-34 3200mhz 32gb | Full Custom Water Cooling Loop | 1tb Samsung 970 Evo

2tb Crucial MX500 SSD | 2x 3tb Seagate Drive | Fractal Design Meshify S2 |  EVGA G2 750w PSU | 3x Corsair LL140 | 3x Corsair LL120

 

Dedicated Streaming Rig

 Ryzen 7 1800x | Asus B450-F Strix | 16gb Vengeance LPX 3000mhz | Corsair RM550x (2018) | EVGA GTX 1060 3gb | 250gb 860 Evo m.2 | Phanteks Enthoo Evolv 

 Elgato HD60 Pro | Elgato 4k60 Pro mk.2 | Avermedia 4k GC573 Capture Card

 

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Skiiwee29 said:

Those types of artifacts are usually an indication of 1 or 2 things, A: you have an OC that is to high and needs to be dialed back, or B: the Memory is failing and needs to be RMA'd

I think it is the later as I don't overclock my GPU. I'm going to start the RMA process then, thank you!

Link to post
Share on other sites
Posted (edited)

Just wondering. I don't see any of the artifacts that you are talking about. I'm relatively new to this kind of stuff so I've never seen it happen before.

 

EDIT: Nvm. I looked at the rest of the screenshots lol

Edited by PunchbagTurtle
Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, PunchbagTurtle said:

Just wondering. I don't see any of the artifacts that you are talking about. I'm relatively new to this kind of stuff so I've never seen it happen before

On the desktop:

spacer.png

 

In a game:

spacer.png

Link to post
Share on other sites
Posted · Original PosterOP

Could the GPU overheating produce such artifacts? 🤔

Link to post
Share on other sites
25 minutes ago, Atemu said:

Could the GPU overheating produce such artifacts? 🤔

That might be the cause. Check what temps you are getting in idle and under load when you getting the artifacts

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, PunchbagTurtle said:

That might be the cause. Check what temps you are getting in idle and under load when you getting the artifacts

Idle I get about 35C degrees and at load around 72C degrees as you can see on the game screenshot.

 

Image 2020-06-03 22.28.22.jpg

 

When I think about it, I don't think its the cause. Ah, well, no other choice than RMA it.

Link to post
Share on other sites
Posted (edited)
3 minutes ago, Atemu said:

Idle I get about 35C degrees and at load around 72C degrees as you can see on the game screenshot.

 

Image 2020-06-03 22.28.22.jpg

According to this (https://www.tomshardware.com/reviews/nvidia-geforce-rtx-2080-ti-founders-edition,5805-11.html) benchmark that seems to be an average temp, so go on with your RMA. Good luck!

 

If you want to be safe and not click that link just look up "average temp for rtx 2080 TI under load" :)

Edited by PunchbagTurtle
Link to post
Share on other sites
23 minutes ago, Atemu said:

Idle I get about 35C degrees and at load around 72C degrees as you can see on the game screenshot.

 

Image 2020-06-03 22.28.22.jpg

 

When I think about it, I don't think its the cause. Ah, well, no other choice than RMA it.

Yeah, that's perfectly normal temps-wise.

 

Best of luck with the RMA.


The Workhorse

R7 3700X | RTX 2070 Super | 32GB DDR4-3200 | 512GB SX8200P + 2TB 7200RPM Barracuda Compute | Windows 10 Pro

 

The Portable Station

Core i7 4700MQ | GT 750M | 16GB DDR3-1600 | 250GB 850 Evo | Windows 10

 

Samsung Galaxy Note8 SM-N950F

Exynos 8895 ARM Mali G71 MP20 | 6GB LPDDR4 | 64GB internal + 128GB microSD | 6.3" 1440p "Infinity Display" AMOLED | Android Pie 9.0 w/ OneUI

Link to post
Share on other sites
1 hour ago, Atemu said:

.

there's a very high chance that it's failing, last thing u can try while u wait is to lower the memory clock (even lower than stock) and see if it goes away for now, still should RMA it.


9900k 1.39v 5.2 83C 185w 1.24v 4.9 60C 135w 1.05v 4.5 90w 50C (doing some testing for hot days) all-2avx cinebench/blender temps. avx voltages in prime. ll D15 ll Z390 taichi ult 1.60 bios fixed LLC voltage gaps ll gskill 2x8gb cl16 ddr4000 bdie 1.42v ll EVGA 2080 ti XC (duo fan skinny) 1995//7600 power limited 79C max, stock voltage (really bad ocer) ll 2x samsung 860 evo 500gb raid 0 ll 500gb nvme 970 evo ll Corsair graphite 780T ll EVGA G2 1300w ll Windows 10 Pro ll NEC PA272w (movie, work mon) 2k60 14bit lut ll Predator X27 4k144 hdr (rgb98)

Link to post
Share on other sites
11 hours ago, Atemu said:

I think it is the later as I don't overclock my GPU. I'm going to start the RMA process then, thank you!

That or their factory OC is unstable which also justifies a RMA since it cannot reach the speeds they promised on its spec sheet... 😒


1000-1200$ builds (July 2020)
Spoiler

AMD Ryzen 5 3600 build: https://pcpartpicker.com/list/wgnHyk

AMD Ryzen 5 3600X build: https://pcpartpicker.com/list/n6GkMc

Intel Core i5-10400/10400F build: https://pcpartpicker.com/list/MJWDWb

Intel Core i5-10600K/10600KF build: https://pcpartpicker.com/list/3wdqFG

Vishera-X8-9370 (workstation PC)

Spoiler

Case: Cooler Master HAF XB Evo Black / Case Fan(s) Front: Noctua NF-A14 ULN 140mm Premium Fans / Case Fan(s) Rear: Corsair Air Series AF120 Quiet Edition (red) / Case Fan(s) Side: Noctua NF-A6x25 FLX 60mm Premium Fan / Case Fan VRM: SUNON MagLev KDE1209PTV3 92mm / Controller: Sony Dualshock 4 Wireless (DS4Windows) / Cooler: Cooler Master Hyper 212 Evo / CPU: AMD FX-8370 (Base: @4.4GHz | Turbo: @4.7GHz) Black Edition Eight-Core (Global Foundries 32nm) / Display: ASUS 24" LED VN247H (67Hz OC) 1920x1080p / GPU: Gigabyte Radeon RX Vega 56 Gaming OC @1501MHz (Samsung 14nm FinFET) / Keyboard: Logitech Desktop K120 (Nordic) / Motherboard: MSI 970 GAMING, Socket-AM3+ / Mouse: Razer Abyssus 2014 / PCI-E: ASRock USB 3.1/A+C (PCI Express x4) / PSU: EVGA SuperNOVA G2, 850W PSU / RAM 1, 2, 3 & 4: Corsair Vengeance DDR3-1866MHz CL8-10-10-28-37-2T (4x4GB) 16.38GB / Operating System 1: Windows 10 Home / Sound: Zombee Z300 / Storage 1: Samsung 850 EVO 500GB SSD (x2) / Storage 2: Seagate® Barracuda 2TB HDD / Storage 3: Seagate® Desktop 2TB SSHD / Wi-fi: TP-Link TL-WN951N 11n Wireless Adapter / https://pcpartpicker.com/list/ZW4Jtg

Zen-II-X6-3600 (gaming PC)

Spoiler

Case: Medion Micro-ATX Case / Case Fan Front: SUNON MagLev PF70251VX-Q000-S99 70mm / Case Fan Rear: Fanner Tech(Shen Zhen)Co.,LTD. 80mm (Purple) / Controller: Sony Dualshock 4 Wireless (DS4Windows) / Cooler: AMD Near-silent 125w Thermal Solution / CPU: AMD Ryzen 5 3600 (Base: @3.6GHz | Turbo: @4.2GHz) Black Edition Hexa-Core (T.S.M.C. 7nm) / Display: HP 19" Flat Panel L1940 (75Hz) 1280x1024 / GPU: MSI GeForce GTX 970 4GD5 OC "Afterburner" @1450MHz (T.S.M.C. 28nm) / Keyboard: HP KB-0316 PS/2 (Nordic) / Motherboard: ASRock B450M Pro4, Socket-AM4 / Mouse: Razer Abyssus 2014 / PCI-E: ASRock USB 3.1/A+C (PCI Express x4) / PSU: EVGA SuperNOVA G2, 550W PSU / RAM 1, 2, 3 & 4: G.Skill Sniper X DDR4-3200MHz CL16-18-18-38-75-1T (2x8GB) 16.38GB / Operating System 1: Windows 10 Home / Sound 1: Zombee Z500 / Sound 2: Logitech Stereo Speakers S-150 / Storage 1: Samsung 850 EVO 500GB SSD (x2) / Storage 2: Western Digital My Passport 2.5" 2TB HDD / Storage 3: Western Digital Elements Desktop 2TB HDD / Wi-fi & Bluetooth: ASUS PCE-AC55BT Wireless Adapter / pcpartpicker link F3yNV7

Godavari-X4-880 (old config 3)

Spoiler

Case: Medion Micro-ATX Case / Case Fan Front: SUNON MagLev PF70251VX-Q000-S99 70mm / Case Fan Rear: Fanner Tech(Shen Zhen)Co.,LTD. 80mm (Purple) / Controller: Sony Dualshock 4 Wireless (DS4Windows) / Cooler: AMD Near-silent 125w Thermal Solution / CPU: AMD Athlon X4 880K Black Edition Elite Quad-Core (T.S.M.C. 28nm) / Display: HP 19" Flat Panel L1940 (75Hz) 1280x1024 / GPU: MSI GeForce GTX 970 4GD5 OC "Afterburner" @1450MHz (T.S.M.C. 28nm) / Keyboard: HP KB-0316 PS/2 (Nordic) / Motherboard: MSI A78M-E45 V2, Socket-FM2+ / Mouse: Razer Abyssus 2014 / PCI-E: ASRock USB 3.1/A+C (PCI Express x4) / PSU: EVGA SuperNOVA G2, 550W PSU / RAM 1, 2, 3 & 4: SK hynix DDR3-1866MHz CL9-10-11-27-40 (4x4GB) 16.38GB / Operating System 1: Ubuntu Gnome 16.04 LTS (Xenial Xerus) / Operating System 2: Windows 10 Home / Sound 1: Zombee Z500 / Sound 2: Logitech Stereo Speakers S-150 / Storage 1: Samsung 850 EVO 500GB SSD (x2) / Storage 2: Western Digital My Passport 2.5" 2TB HDD / Storage 3: Western Digital Elements Desktop 2TB HDD / Wi-fi: TP-Link TL-WN851N 11n Wireless Adapter / https://pcpartpicker.com/list/LBjbw6

Vishera-X8-8370 (old config 2)
Spoiler

Case: Cooler Master HAF XB Evo Black / Case Fan(s) Front: Noctua NF-A14 ULN 140mm Premium Fans / Case Fan(s) Rear: Corsair Air Series AF120 Quiet Edition (red) / Case Fan(s) Side: Noctua NF-A6x25 FLX 60mm Premium Fan / Case Fan VRM: SUNON MagLev KDE1209PTV3 92mm / Controller: Sony Dualshock 4 Wireless (DS4Windows) / Cooler: Cooler Master Hyper 212 Evo / CPU: AMD FX-8370 Black Edition Eight-Core (Global Foundries 32nm) / Display: ASUS 24" LED VN247H (67Hz OC) 1920x1080p / GPU: MSI GeForce GTX 970 4GD5 OC "Afterburner" @1450MHz (T.S.M.C. 28nm) / Keyboard: Logitech Desktop K120 (Nordic) / Motherboard: MSI 970 GAMING, Socket-AM3+ / Mouse: Razer Abyssus 2014 / PCI-E: ASRock USB 3.1/A+C (PCI Express x4) / PSU: EVGA SuperNOVA G2, 850W PSU / RAM 1, 2, 3 & 4: SK hynix DDR3-1866MHz CL9-10-11-27-44 (4x4GB) 16.38GB / Operating System 1: Ubuntu Kylin 14.04 LTS (Xenial Xerus) / Operating System 2: Windows 10 Home / Sound: Zombee Z300 / Storage 1: Samsung 850 EVO 500GB SSD (x2) / Storage 2: Seagate® Barracuda 2TB HDD / Storage 3: Seagate® Desktop 2TB SSHD / Wi-fi: TP-Link TL-WN951N 11n Wireless Adapter / https://pcpartpicker.com/list/ZW4Jtg

Kaveri-X4-860K (old config 1)

Spoiler

Case: Medion Micro-ATX Case / Case Fan Front: SUNON MagLev PF70251VX-Q000-S99 70mm / Case Fan Rear: Fanner Tech(Shen Zhen)Co.,LTD. 80mm (Purple) / Controller: Sony Dualshock 4 Wireless (DS4Windows) / Cooler: AMD FX-8370 125w Thermal Solution / CPU: AMD Athlon X4 860K Black Edition Elite Quad-Core (T.S.M.C. 28nm) / Display: HP 19" Flat Panel L1940 (75Hz) 1280x1024 / GPU: EVGA GeForce GTX 960 SuperSC 2GB (T.S.M.C. 28nm) / Keyboard: HP KB-0316 PS/2 (Nordic) / Motherboard: MSI A78M-E45 V2, Socket-FM2+ / Mouse: Razer Abyssus 2014 / PCI-E: ASRock USB 3.1/A+C (PCI Express x4) / PSU: EVGA SuperNOVA G2, 550W PSU / RAM 1, 2, 3 & 4: Corsair Vengeance DDR3-2133MHz CL9-11-11-31-42 (4x4GB) 16.38GB / Operating System 1: Ubuntu Kylin 14.04 LTS (Xenial Xerus) / Operating System 2: Windows 10 Home / Sound 1: Zombee Z500 / Sound 2: Logitech Stereo Speakers S-150 / Storage 1: Samsung 850 EVO 500GB SSD (x2) / Storage 2: Seagate® Desktop 2TB SSHD / Storage 3: Western Digital Elements Desktop 2TB HDD / Wi-fi: TP-Link TL-WN851N 11n Wireless Adapter

Complete portable device SoC history:

Spoiler
Apple A4 - Apple iPod touch (4th generation)
Apple A5 - Apple iPod touch (5th generation)
Apple A9 - Apple iPhone 6s Plus
MSM8926 - Microsoft Lumia 640 LTE
MSM8974AA - Blackberry Passport
MT2601 - TicWatch E
MT6580 - TECNO Spark 2 (1GB RAM)
MT6592M - my|phone my32 (orange)
MT6592M - my|phone my32 (yellow)
MT6735 - HMD Nokia 3 Dual SIM
MT6737 - Cherry Mobile Flare S6
MT6739 - my|phone myX8 (blue)
MT6739 - my|phone myX8 (gold)
MT6750 - Huawei honor 6C Pro / V9 Play
MT6765 - TECNO Pouvoir 3 Plus
MT6797D - my|phone Brown Tab 1
SDM710 - Oppo Realme 3 Pro

 

Link to post
Share on other sites
Posted · Original PosterOP

Thank you for your help! I'm going to send the card back to ASUS and keep you posted.

Link to post
Share on other sites
2 hours ago, Atemu said:

Thank you for your help! I'm going to send the card back to ASUS and keep you posted.

Just remember that most RMA centers are closed, and while they are accepting RMAs they aren't getting on them right away and as of right now it may be up to a month until you get a replacement card. I helped a guy RMA his 2080ti founders edition that he had bought day one about two months ago and he still hasn't gotten the replacement he just went out and bought a new one after the first month and asked Nvidia for a refund because he had bought it through them, I don't know if he ever got the card back or a refund.


Main Desktop: CPU - I9-9900k @5ghz | Mobo - Gigabyte Z390 Aorus Master | GPU - Asus ROG STRIX 2080ti OC RAM - G.Skill Trident Z RGB 16GB 3200mhz | AIO - H100i Pro RGB | PSU - Evga 850 GQ | Case - Fractal Design Meshify C White | Storage - Samsung 970 Pro M.2 NVME SSD 512GB / Sabrent Rocket 1TB NVME SSD / Samsung 860 Evo Pro 500GB / Seagate 2TB Firecuda Hybrid Drive |

 

TV Streaming PC: Intel Nuc CPU - i7 8th Gen | RAM - 16GB DDR4 2666mhz | Storage - 256GB WD Black M.2 NVME SSD |

 

Phone: Samsung Galaxy S10+ - Ceramic White 512GB |

 

If you ask for a Mid Tower case recommend, I will 90% of the time recommend the Fractal Design Meshify C or S2.

Link to post
Share on other sites
Posted · Original PosterOP

Just to keep you posted, this is what it looks like now ☹️

 

Image 2020-06-05 09.34.42.jpg

 

Image 2020-06-05 09.36.46.jpg

Link to post
Share on other sites
Posted · Original PosterOP
16 minutes ago, PunchbagTurtle said:

Yikes. That sucks. You have an alternate graphics card to use or another pc/laptop? :(

Fortunately my CPU, an i7 8700K, has an iGPU and my motherboard has a DisplayPort and HDMI ports.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×