Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
iostr33m

PSU Cap Discharge / Motherboard + Graphics LEDs Blinking

Recommended Posts

Posted · Original PosterOP

Hi,

I've recently upgraded my PC, installing a new Super Flower SF-850F14HG PSU as well as a Gigabyte RTX 2070 Super Gaming OC Graphics Card. I have a MSI x470 Gaming Plus mainboard / Ryzen 2700X.

Issue is this: with the new PSU installed and when computer is shut down, two LEDs - one above each of the 8/6-pin power ports on the graphics card blink continuously (abnormal power supply?) and the mainboard also has some LEDs lit (near ATX connector and memory modules). It's now been switched off at the wall power outlet for nearly 3 hours and the LEDs are still lit / flashing; power lead still attached.
 

When the machine is powered up, the graphic card LEDs switch off.


It looks like capacitors are not discharging, is this PSU faulty?

Link to post
Share on other sites

If the power cable is disconnected from the power supply then it's not possible for something to stay on, unless some other device you have connected to the PC is feeding back power into it.

If the power cable is connected then standby power is present and it's common for mobos to leave LEDs on or stuff by default.


F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX2080S, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K

 

GPD Win 2

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×