Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Brutal Doom Can't Perform Execution/Fatalities, Need Help

Recommended Posts

Posted · Original PosterOP

So while waiting for my PSU to get RMA'ed, i am only left with this old 2007 Acer laptop that runs windows XP.


Lets get to the point, since i can't play modern games on it, i've tried the original Doom with Mods.


I tried Brutal Doom V21 with ZDoom and ZDL and i can't perform the infamous fatality moves.


What i've tried:


1. Re-installing the games along with ZDoom and ZDL

2. Getting the Berserk Pack and "Give Berserk" Command via Console

3. Pressing R to alternate execution = Doesn't work at all


So when i got the berserk pack and punch the enemies, it just send them flying to the wall.


Does anyone ever had the same problem?

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, 6x6 said:

Is this you shorturl.at/ahxzD

I am asking genuine question, are you even familiar with the game and the modding community?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now