Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
MorgonS9

Monitor defaults to Intel Integrated Graphics Processor

Recommended Posts

Posted · Original PosterOP

I am trying to fix an over-scan issue on the monitor connected to my laptop, but the Display drop-down was not showing up on the NVIDIA Control Panel.
After further inspection, my monitor is being ran by the Intel Integrated GPU, not my GTX 1050 Dedicated Mobile GPU.
Since the Intel Control Panel sucks, I want to change the default chipset to my GTX 1050
I tried the Device Manager trick by disabling the Intel Chipset, but, all it did was disable my HDMI Port, turn down my main laptop display resolution, and default to the Microsoft Basic Display Adapter.

Anything I am doing wrong? 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×