Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Premilix

Display turns black

Recommended Posts

Posted · Original PosterOP

Hey! Today I was playing games on my new computer and randomly my PC display turned black. I pressed alt f4 because I thought it was maybe the game that crashed. Then I looked at what to do on internet and somewhere saw to press the Windows button + ctrl + shift + b and after I pressed those it came back. The game was closed which means my system was still responsive so I have no idea what happened. Could anyone help me explain this? Btw if you're wondering my GPU is a Gigabyte aorus rx 5700 xt. 

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, Screen said:

It might be that your display driver needs an update.
Install the latest drivers for your gpu and try again.

I checked, my drivers are up to date using Radeon software. 

Link to post
Share on other sites
3 minutes ago, Premilix said:

I checked, my drivers are up to date using Radeon software. 

Try going back to a previous stable version of the driver and check if you run into the same issue.
You can also look up and check if the Game you are running have previously shown these behavior among st other users and if there are possible solutions for the same.

Link to post
Share on other sites
Posted · Original PosterOP
56 minutes ago, Screen said:

Try going back to a previous stable version of the driver and check if you run into the same issue.
You can also look up and check if the Game you are running have previously shown these behavior among st other users and if there are possible solutions for the same.

The game I was playing was Minecraft and not too long ago, it blackscreened again but this time I had my headphones on so I knew the computer was definitely responsive because the sounds were still playing. The current driver version 20.4.2 is already the recommended one so I guess I have to wait for a new version. However, I still have no idea why it happened only now as I've been using this PC for almost 2 weeks no problem. I don't know, I tried removing the watermark of Activate Windows today and I changed a few things in regedit but after the first blackscreen changed them back, however, still haven't restarted the computer. I will try to do that a bit later and see if the problem continues. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×