Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
GONE SEXUAAAAAAAAAAAL

Low fps in CS GO with good pc which make no sense

Recommended Posts

Posted · Original PosterOP

Hi! About a month ago i upgraded to rx 5700 from gtx 970. I installed CS GO and im getting.. 30-40 fps on dust 2 lowest. Mirage gets me 200+ some over 60 and some below 60. Which makes no sense. What i checked is that GPU is at 99% usage and cpu at 15%. CPU is Ryzen 1600x which is overclocked to 4ghz. I have 75hz monitor. What can i do? I tried parking cpu changing every settings i could,reinstalling and i did reinstall windows after upgrade. What can i do?

Link to post
Share on other sites

Have you installed graphics drivers from AMD? You can find the proper drivers at https://www.amd.com/en/support/graphics/amd-radeon-5700-series/amd-radeon-rx-5700-series/amd-radeon-rx-5700-xt.


Make sure to quote me or use @PorkishPig to notify me that you replied!

 

 

Desktop

CPU - Ryzen 9 3900X | Cooler - Noctua NH-U12S | Motherboard - Asus TUF X570-PLUS (WiFi) RAM - Corsair Vengeance LPX (2x8GB) DDR4-3200

GPU - MSI GTX 1070 Ti PSU - EVGA B3 650W Case - Meshify C Storage - 960 EVO 500GB, MX500 500GB

 

Media Server

CPU - Core i5-4570 | RAM - Samsung 16GB (4x4GB) DDR3-1600 | Case - OptiPlex 9020 SFF

Storage - 850 EVO 128GB (Boot), BX500 240GB (Software), WD Red 4TB (Storage) | OS - FreeNAS 11.3

Link to post
Share on other sites
16 minutes ago, GONE SEXUAAAAAAAAAAAL said:

All drivers are up to date.

Yes but did you DDU in safe mode before installing AMD drivers?


Workstation Rig:
CPU:  Intel Core i9 9900K @5.0ghz  |~| Cooling: beQuiet! Dark Rock 4 |~|  MOBO: Asus Z390M ROG Maximus XI GENE |~| RAM: 32gb 3333mhz CL15 G.Skill Trident Z RGB |~| GPU: nVidia TITAN V  |~| PSU: beQuiet! Dark Power Pro 11 80Plus Platinum  |~| Boot: Intel 660p 2TB NVMe |~| Storage: 2X4TB HDD 7200rpm Seagate Iron Wolf + 2X2TB SSD SanDisk Ultra |~| Case: Cooler Master Case Pro 3 |~| Display: Acer Predator X34 3440x1440p100hz |~| OS: Windows 10 Pro.
 
Personal Use Rig:
CPU: Intel Core i9 9900 @4.75ghz |~| Cooling: beQuiet! Shadow Rock Slim |~| MOBO: Gigabyte Z390M Gaming mATX|~| RAM: 16gb DDR4 3400mhzCL15 Viper Steel |~| GPU: nVidia Founders Edition RTX 2080 Ti |~| PSU: beQuiet! Straight Power 11 80Plus Gold  |~|  Boot:  Intel 660p 2TB NVMe |~| Storage: 2x2TB SanDisk SSD Ultra 3D |~| Case: Cooler Master Case Pro 3 |~| Display: Viotek GN34CB 3440x1440p100hz |~| OS: Windows 10 Pro.


HTPC / "Console of the house":

CPU: Intel Core i7 8700 @4.45ghz |~| Cooling: Cooler Master Hyper 212X |~| MOBO: Gigabyte Z370M D3H mATX|~| RAM: 16gb DDR4 3333mhzCL16 G.Skill Trident Z |~| GPU: nVidia Founders Edition GTX 1080 Ti |~| PSU: Corsair TX650M 80Plus Gold |~| Boot:  SSD WD Green M.2 2280 240GB |~| Storage: 1x3TB HDD 7200rpm Seagate Barracuda + SanDisk Ultra 3D 1TB |~| Case: Fractal Design Meshify C Mini |~| Display: Toshiba UL7A 4K/60hz |~| OS: Windows 10 Pro.
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×