Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
cetineru

Do I have a faulty GPU (XFX AMD Radeon RX 5600 XT THICC III Ultra)?

Recommended Posts

Posted · Original PosterOP

Hello everyone. I recently bought a new XFX AMD Radeon RX 5600 XT THICC III Ultra and replaced my old r9 380 today. At first, there was no issue, Windows booted properly, I have checked the AMD software and device manager, and everything seemed in order. So, I started to play Witcher 3 to test it, FPS was normal (80-100) but there was stutter. After 3-5 minutes of playtime, the computer crashed to black screen and wouldn't boot after restart (it powers up but all I see is black screen, no BIOS or anything).

I've tried to boot with my r9 380 to see if I mess something else but it runs just as fine before. I've tried factory reset with adrenaline software, installed the new GPU and booted again but the result was black screen. I have used DDU to completely remove the drivers in safe mode with my old r9 380 on, selected the option "clean and shutdown". After shutdown, I installed the 5600 xt and tried to boot, did not work again.

Am I doing something wrong, or do I have a faulty GPU?

Specs:

Motherboard: GIGABYTE B450M S2H

CPU: AMD Ryzen 5 3600

GPU: XFX AMD Radeon RX 5600 XT THICC III Ultra

Memory: GSKILL 8GB Ripjaws V Siyah 3200MHz CL16 DDR4

Case and integrated power supply (650 W): EVEREST RANGE-7 PEAK-650W USB 3.0 MidT ATX

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×