Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Get InSpectre. Turn off the Spectre and Meltdown mitigations. Try after a reboot. Let me know.

Recommended Posts

Posted · Original PosterOP

Hello guys and help, hahah.

 

Recently I bought one more PC from my friend, I like to have a lot PCs but this one is really pain for me, its mid range PC and I didnt swap anything in it so here are the specs:

 

Motherboard: Z87X-D3H

CPU: Intel Core i7 4770 3.40Ghz

RAM: Kingston HyperX Fury 1600mhz 2x4Gb

GPU: nVidia GTX 770 2Gb

PSU: Thermaltake Smart SE 730w

SSD: Kingston HyperX 120Gb

HDD: 1,5Tb WD Blue

 

Soo when I bought this PC I test run it on newly installed windows 10 and it run smoothly on boot, programs and games, i had over 100+ FPS stable on Valorant, LoL, CS GO etc.

Than I download new BIOS, last version of Bios for this motherboard is F9 so I updated it and there starts new jurny of problems, like slow boot, slow load of apps after loging in, lower FPS.

 

I tried to install APP Center software form Gigabyte to enable fast boot, easytune etc, but  it couldnt start the app on this F9, this software ran on previus Bios version soo until i updated it. Than I discovered on some forums that apps from gigabyte App Center were stoped from being used.

 

When I getup in the morning every time i boot  this pc it takes forewer to boot it... than I decide i need help from you guys.

 

Soo, where am I doing it wrong do I need to setup bios in correct order (for that i need help), anyone have any clue?

Link to post
Share on other sites
Posted · Best Answer

Get InSpectre. Turn off the Spectre and Meltdown mitigations. Try after a reboot. Let me know.

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, 191x7 said:

Get InSpectre. Turn off the Spectre and Meltdown mitigations. Try after a reboot. Let me know.

After InSpectre edit, so far so good in Valorant is back 100+ FPS on HIGH settings it  drops to 75 that is normal its stable, as on LoL and CS GO...

 

Any more tips for tweaks in BIOS or OS to have best performance?

Link to post
Share on other sites

Latest chipset drivers, latest GPU drivers, updated directx with dxwebsetup, ...

Link to post
Share on other sites
Posted · Original PosterOP
4 hours ago, 191x7 said:

Latest chipset drivers, latest GPU drivers, updated directx with dxwebsetup, ...

Thanks man you really save my day keep it up. :)

Link to post
Share on other sites
4 hours ago, iNFECTEM said:

Thanks man you really save my day keep it up. :)

You can also try using IOBit Driver Booster (free).

And SSDFresh to optimize the SSD.

Link to post
Share on other sites
Posted · Original PosterOP

So here is the case the only thing i need to check is when i reboot pc it goes normal on bootup. But when i shut down and turn my pc again  it takes like 3mins for to boot and load apps on desktop like they are blank and slowly icons are refreshing... In bios i enabled ultra fast boot, windows is by default set on fast boot and still no effect...

 

What should i do any clue

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×