Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Mr.ComputerBuilder

B450 tomahawk board wont power after i install ryzen 5 2600x

Recommended Posts

Posted · Original PosterOP

So i got my Ryzen 5 2600x and was excited to get my computer up and running but was disappointed to see that my motherboard will not power. I took out my cpu and left my ram and gpu in and it powered on with no problem and the cpu light flashed red (no cpu installed) i tried updating the bios and its not my ram and gpu for sure but board will power with them installed. I have the ryzen 5 2600x and B450 Tomahawk (Non max). Pls help. NOTE: If its my cpu i may still be able to get it exchanged. 

Link to post
Share on other sites
Posted (edited)

deleted

Edited by GamingSeargent
How to delete comment?

CPU: Intel Core i3-4310 @ 3.40 GHz

GPU: Intel HD Graphics 4400

Ram: 1x4GB 800MHz DDR3 

 

Link to post
Share on other sites
Posted · Original PosterOP
41 minutes ago, FriedEngineer said:

How did you test your RAM and GPU?

Lent my ram and gpu to someone i trust and they said it worked and i still have same problem if i take them out and leave cpu with ram (No power) and with no ram . Also used different ram and still have the same problem. 😑 Also want to lend cpu so they can test but idk about that, dont want them to bend pins. 

Link to post
Share on other sites

If you suspect the Cpu is bad, and it sounds like the board is working properly, return the Cpu.

 

edit:

But try to clear the cmos one good time first.


 

Lid-less PGA 2700x / ROG B450-I Gaming / Corsair 3000mhz SK Hynix / RTX 2060 / EVGA 750w

Lid-less 8700K / Maximus X Hero / G.Skill 4266mhz B-Die / RTX 2060 / Antec 1000w CP series

Ryzen Athlon 220ge with Vega Graphics / Asus Prime B450M-A / Corsair LED 3000mhz / 550w Antec Office PC.

DFI LanParty UT / Opteron 148 / DDR Corsair XMS Expert / X1800 XT 256MB Bios modded

Asus CrossHair Formula IV / Phenom II x4 B97 / Dominator GT 2000mhz. / EVGA GTX 770

Link to post
Share on other sites
11 minutes ago, Mr.ComputerBuilder said:

Lent my ram and gpu to someone i trust and they said it worked and i still have same problem if i take them out and leave cpu with ram (No power) and with no ram . Also used different ram and still have the same problem. 😑

Thats good enough for me.

 

if you have a friend who your cool lending stuff to, couldn’t you just go to their place with your CPU and try it with them? They can touch all their stuff (removing whatever CPU they have and such) and you just install your CPU to make sure you don’t bend the pins.

Link to post
Share on other sites
Posted · Original PosterOP
10 hours ago, ShrimpBrime said:

If you suspect the Cpu is bad, and it sounds like the board is working properly, return the Cpu.

 

edit:

But try to clear the cmos one good time first.

I'm not quite sure it's the cpu because I bought it recently at microcenter, but it could be possible to get a dead cpu and I'll try to clear the cmos a good time.

Link to post
Share on other sites
Posted · Original PosterOP
10 hours ago, FriedEngineer said:

Thats good enough for me.

 

if you have a friend who your cool lending stuff to, couldn’t you just go to their place with your CPU and try it with them? They can touch all their stuff (removing whatever CPU they have and such) and you just install your CPU to make sure you don’t bend the pins.

Yes, but the world is in a pandemic, my friends parents probably wouldn't let me enter for their safety so I'll have to work out something with him.

Link to post
Share on other sites
20 minutes ago, Mr.ComputerBuilder said:

I'm not quite sure it's the cpu because I bought it recently at microcenter, but it could be possible to get a dead cpu and I'll try to clear the cmos a good time.

Diagnostics aren't always quick and easy. 

 

See if they will exchange it, or perhaps they will diag the PC for you at low cost or free. 


 

Lid-less PGA 2700x / ROG B450-I Gaming / Corsair 3000mhz SK Hynix / RTX 2060 / EVGA 750w

Lid-less 8700K / Maximus X Hero / G.Skill 4266mhz B-Die / RTX 2060 / Antec 1000w CP series

Ryzen Athlon 220ge with Vega Graphics / Asus Prime B450M-A / Corsair LED 3000mhz / 550w Antec Office PC.

DFI LanParty UT / Opteron 148 / DDR Corsair XMS Expert / X1800 XT 256MB Bios modded

Asus CrossHair Formula IV / Phenom II x4 B97 / Dominator GT 2000mhz. / EVGA GTX 770

Link to post
Share on other sites
40 minutes ago, Mr.ComputerBuilder said:

Yes, but the world is in a pandemic, my friends parents probably wouldn't let me enter for their safety so I'll have to work out something with him.

Yeah, I wasn't really considering the pandemic, sorry (where I'm at has barely been affected and I was working on a MS degree online before and after so I barely left the house anyways)

 

43 minutes ago, Mr.ComputerBuilder said:

I bought it recently at microcenter

I agree with @ShrimpBrime, I would absolutely go back to microcenter. They have pretty good on-site diagnostics and should be able to get it sorted pretty quickly. I have gotten DOA CPUs it's just pretty uncommon.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×