Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
_Kaurus

Connect to 2nd router in network

Recommended Posts

Posted · Original PosterOP

So I can connect to my second router's UI while i'm directly connected to the router or connected through Wifi, but for whatever reason, I cannot connect to it from my desktop through my router. 

 

I have a modem, then an edgerouterX.  

Port 0 = modem

port 1 = My desk top

port 2 = my power line adapter

port 3 = my other router - Dlink - DIR-880L

 

You'd think it's be as easy as putting the IP which was assigned to the port 2 or port 3 device into your web browser, but that doesn't seem to be the case.  Lucky me, power line adaptor has a scan tool that can get you into the interface from my desktop without issues, but my port 3 router cannot, and it really bugs me.. buggggssss meeee.

 

I've attached an image of my Edge RouterX, which shows four things connected, though seems strange that two are on Eth0, one is on lo (what's lo, i don't know), and switch0.  

 

Would someone mind filling my knowledge gap on this one, why I cannot connect to my port 3 routers UI?

2020-04-27 19_34_25-EdgeOS - ubnt.png

Link to post
Share on other sites

Does the second router have nat enabled? You should probably be using it only as a access point.

 

Can you make a network diagram?

 

Can you show the port configuration on the edge router? I think you want all your devices on one subnet 

Link to post
Share on other sites

lo stands for loopback, so in short: itself.

 

For the main topic.

The picture is not all devices connected to the router. It's the routers routing table (Where to send what). Based on your picture, it says that standard gateway is at interface eth0 and that the network 172.103.252.0/26 is at eth0. And a loopback entry, and then the switch0 entry wich states that 192.168.1.0/24 network is connected to interface switch0.

 

And considering you have 4 ports in use, and of the 4 routes there is only 2 that indicates a network means that you are missing one line.

So, since everything connected to the edge router needs a network (since it's a router not a switch) this means that there are only routes for two devices. Considering that your PC has internet, the route for the Dlink is missing.

 

What you need to do is to create one LAN for the Dlink, and one LAN between your computer and the router and the LAN between the modem and the edge. And set the routing table for it on the Edge Router for it to work.

 

So:

PC network: 192.168.1.0/24

DLink network: 192.168.0.0/24

Modem network: 172.103.252.0/26

 

And when it's right, your screenshot should show 5 lines instead of 4, one for each device + loopback and standard gateway.

 

 

EDIT: Brainfart! Is the Switch0 interface a virtual switch? Then double check that the physical interface for Port 3 is included in the switch0. If not, double check that DHCP is disabled on the Dlink and plug the ethernet cable into a LAN port and not the WAN port, because then the for the DLINK will be behind a NAT firewall.

Damn, i overcomplicated that way to much...

 

 

Link to post
Share on other sites

The two eth0 entries are for different things.  One is a next hop route to your ISP, and one contains the WAN subnet that interfaces with your ISP.

 

If you're using the WAN interface of your second router then that's why you can't directly access it (also you're rolling double NAT behind router #2).  The best solution is to assign it a static LAN address in the 192.168.1.0/24 space, disable DHCP specifically on router #2 and then connect to the LAN port instead on router #2.


PC : 3600 · Crosshair VI WiFi · 2x16GB RGB 3200 · 1080Ti SC2 · 1TB WD SN750 · EVGA 1600G2 · Define C 

Link to post
Share on other sites
Posted · Original PosterOP
On 4/27/2020 at 7:40 PM, Electronics Wizardy said:

Does the second router have nat enabled? You should probably be using it only as a access point.

 

Can you make a network diagram?

 

Can you show the port configuration on the edge router? I think you want all your devices on one subnet 

I had it setup as an access point when I had two wifi's in the house, though switching between access points was not working good since neither signal would ever get weak enough to warranty an auto switch, so I decided to leave DHCP enabled and let the humans pick what network connection they wanted.

Link to post
Share on other sites
Posted · Original PosterOP
On 4/28/2020 at 1:14 PM, Fr3dr1k said:

EDIT: Brainfart! Is the Switch0 interface a virtual switch? Then double check that the physical interface for Port 3 is included in the switch0. If not, double check that DHCP is disabled on the Dlink and plug the ethernet cable into a LAN port and not the WAN port, because then the for the DLINK will be behind a NAT firewall.

Damn, i overcomplicated that way to much...

 

 

I don't know what Switch0 interface is :( That's port three and it goes up to the other up stairs wifi router "internet" port.

 

So, move the plug from Wan to Eth1 or something and turn off DHCP. Will the upstairs router still get internet then?

Link to post
Share on other sites
25 minutes ago, _Kaurus said:

I had it setup as an access point when I had two wifi's in the house, though switching between access points was not working good since neither signal would ever get weak enough to warranty an auto switch, so I decided to leave DHCP enabled and let the humans pick what network connection they wanted.

Access point mode should turn off NAT/DHCP for that wireless device. Ideally, to allow for easier hand-off with moving clients, you should use the same SSID on both APs but on different wireless channels, then lower the power output of each AP’s radio so that their coverage just barely overlaps with the other. The client will then decide to switch to the stronger signal.

 

By leaving DHCP enabled on the APs, I’m assuming you’re running them as wireless routers. This will cause double-NAT with the upstream router resulting in LAN IP assignment conflicts.

 

25 minutes ago, _Kaurus said:

I don't know what Switch0 interface is :( That's port three and it goes up to the other up stairs wifi router "internet" port.

 

So, move the plug from Wan to Eth1 or something and turn off DHCP. Will the upstairs router still get internet then?

When you were setting up the ER-X, did you read the instructions on a simple setup for a single WAN connection? The wizard should have taken you through this if you used it.

 

eth0 is assigned to your WAN. switch0 should essentially place all other physical ports on your LAN (here, on the 192.1868.1.0/24 subnet) that are able to communicate with each other and the WAN.

 

Did you follow the recommendations by @beersykins?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×