Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Majoneze

Problems with 5700xt

Recommended Posts

Posted · Original PosterOP

So i have the 5700xt gigabyte aorus GPU, and i Will say, its A nightamre, im getting 150 fps in csgo, fortnite is horible to,the fps are horible on all games, the crashes are horible, i cant play a csgo competitive without restarting my pc atleast 2 times, bluescreens aswell, i would really appreciate if someone could help me, i have a pirated win 10 btw, my coniguration is:5700xt aorus gigabyte, 2700xt, 16gb 3200, 1tb HDD, 240 ssd, and a seasonic S 12 620w, case nzxt 510, And a 165hz monitor 

Link to post
Share on other sites

Did you DDU your old drivers before installing it?

Link to post
Share on other sites

Start first with Drivers its AMD, known problem. Try clean uninstalation on Drivers with Guru DDR, then instal new ones try with Freesync enable disable, chack the temps try to see whats the Windwos Error problem while you run, test different modes.


CPU Ryzen 5 3600X OC 4.6                  Mobo Asus Tuf Gaming Pro B450                 DDR4 16GB 3600Mhz Corsair Dominator

Gigabyte 1070 Ti              Arctic Liquid Freezer 2 240             Cooler MasterMB511 Case With 6 TT White Ring Fans

Link to post
Share on other sites

I wouldn't expect a 5700XT to work properly unless the OS was up to date and a fresh install of the latest GPU driver was done.

 

My advice would be a fresh LEGIT install of Windows which you can get for FREE from Microsoft using the Media Creation Tool which is available here, https://www.microsoft.com/en-gb/software-download/windows10

 

Then the latest GPU drivers from AMD.

Link to post
Share on other sites
Posted · Original PosterOP
12 minutes ago, 5x5 said:

Did you DDU your old drivers before installing it?

Its A New pc so i didnt need to do it 

Link to post
Share on other sites
1 minute ago, Majoneze said:

Its A New pc so i didnt need to do it 

Then get a legit windows copy

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, glenalz81 said:

the OS was up to date

Its A New pc and i did do a fresh install of win, just didnt buy the key

Link to post
Share on other sites
Posted · Original PosterOP
Just now, 5x5 said:

Then get a legit windows copy

You really think thats the cause of the issue? 

Link to post
Share on other sites

Also make sure Enchanced sync is off (its the main culprit of blackscreens)


Let's agree to disagree

Link to post
Share on other sites
14 minutes ago, Majoneze said:

just didnt buy the key

Not pirated then 😂

 

OK, then i'd suggest running DDU and having a fresh install of the GPU drivers. Latest recommended driver is 20.2.2

14 minutes ago, MrTiC said:

Also make sure Enchanced sync is off (its the main culprit of blackscreens)

Also this.

 

Did you manually install the drivers or let windows do it?

Link to post
Share on other sites
Posted · Original PosterOP
23 minutes ago, glenalz81 said:

you manually install the drivers or let windows do it?

I went to the website and manually installed them

Link to post
Share on other sites
2 hours ago, Majoneze said:

seasonic S 12

Seasonic S12II? S12III? I thought those PSU is not good for latest hardware because of the group regulated bla bla. 

 

https://linustechtips.com/main/topic/858096-lets-not-go-with-group-regulated-units-like-the-m12ii-thanks/


| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to post
Share on other sites

I have the same GPU and get over 300 FPS on CSGO...


SLAMD-XT  Ryzen 2600X 4.125ghz 1.26v~Gigabyte B450 Aorus ELITE~16GB Corsair Vengeance 3000mhz C15~Arcting Cooling Freezer 34 Esports Duo~Gigabyte Aorus RX 5700-XT~CIT chassis~120GB PNY SSD~WD BLUE 3D NAND 1TB SSD M.2~Phobya 120mm G.Silent's~SuperFlower Leadex III GOLD~Razer Basilisk~RedDragon Kumura

Link to post
Share on other sites
Posted · Original PosterOP
4 minutes ago, xAcid9 said:

Seasonic S12II? S12III? I thought those PSU is not good for latest hardware because of the group regulated bla bla. 

O ty for the info so the problems could be PSU releated? 

Link to post
Share on other sites
Posted · Original PosterOP
Just now, GreyestGoat said:

have the same GPU and get over 300 FPS on CSGO...

Thats what im saying its performs like a 1050ti even worse sometimes

Link to post
Share on other sites
Just now, Majoneze said:

Thats what im saying its performs like a 1050ti even worse sometimes

Then clearly it is something you are doing that is wrong.

 

A pirated OS may be why.


SLAMD-XT  Ryzen 2600X 4.125ghz 1.26v~Gigabyte B450 Aorus ELITE~16GB Corsair Vengeance 3000mhz C15~Arcting Cooling Freezer 34 Esports Duo~Gigabyte Aorus RX 5700-XT~CIT chassis~120GB PNY SSD~WD BLUE 3D NAND 1TB SSD M.2~Phobya 120mm G.Silent's~SuperFlower Leadex III GOLD~Razer Basilisk~RedDragon Kumura

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×