Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ftahir192

Any RTX 2070 Super's which don't have fan issues?

Recommended Posts

Posted · Original PosterOP

I'm returning my Gigabyte Windforce OC 3X 2070 Super because of an annoying fan revving issue (see 

It seems like this is an issue for quite a lot of GPUs that use 0db fan mode. Has anybody got any experience with any 2070/2070 Supers/2080/2080 Supers where the fan just works? Where it doesn't rev up and down if your GPU is hovering over the limit, and there's no other known issues with fans? I'm contemplating either the MSI Gaming Trio X or the Asus RoG Strix but have heard that even the latter has issues with one fan failing to stop spinning after going below the temperature threshold.

 

Another issue with the gigabyte card was setting a custom fan curve didn't allow me to set a fan speed below 40% - the fan would just rev up and down again, assuming because this is too low a speed for the fans. Has anybody managed to run one of the RTX cards at a lower fan speed, say 10-20%?

 

Would appreciate some others share their experience to help me make an informed decision on my purchase.

 

Link to post
Share on other sites

are you OCing your GPU at all or just stock settings?

 

i currently have an EVGA RTX 2070 super FTW3 ultra+ and no fans on at all. but i am also running at stock everything with out touching a thing on the program other than to turn the RGB on and off. 

 

i would suggest that you try uninstalling and reinstalling the drivers to see if that is the issue or update them to the newest ones.

Link to post
Share on other sites

That is very odd and i am sorry you are having issues with your 2070S.

 

My Aorus has not done this though it is an AMD one.


SLAMD-XT  Ryzen 2600X 4.125ghz 1.26v~Gigabyte B450 Aorus ELITE~16GB Corsair Vengeance 3000mhz C15~Arcting Cooling Freezer 34 Esports Duo~Gigabyte Aorus RX 5700-XT~CIT chassis~120GB PNY SSD~WD BLUE 3D NAND 1TB SSD M.2~Phobya 120mm G.Silent's~SuperFlower Leadex III GOLD~Razer Basilisk~RedDragon Kumura

Link to post
Share on other sites

Sucks that happened, i have the same card but non super and it doesn't do that at all

Link to post
Share on other sites
Posted · Original PosterOP
30 minutes ago, tdkid said:

are you OCing your GPU at all or just stock settings?

 

i currently have an EVGA RTX 2070 super FTW3 ultra+ and no fans on at all. but i am also running at stock everything with out touching a thing on the program other than to turn the RGB on and off. 

 

i would suggest that you try uninstalling and reinstalling the drivers to see if that is the issue or update them to the newest ones.

Have tried that. This is a widely known and reported issue I guess and it can so easily be fixed with a bios update. Some of Gigabytes cards have had bios updates to address this but not mine and when asking Gigabyte support, it looks like there was no scope for this.

 

26 minutes ago, GreyestGoat said:

That is very odd and i am sorry you are having issues with your 2070S.

 

My Aorus has not done this though it is an AMD one.

Aorus doesn't suffer from the issue because AFAIK they had bios updates really early on to address this.

 

21 minutes ago, Escapenz said:

Sucks that happened, i have the same card but non super and it doesn't do that at all

Likewose above, the non super version also had a bios update to improve the fan issues, so I assume your card has this bios flashed.

 

It sucks that the Super variant of the windforce cards don't have new bioses. The card isn't exactly new now... Bios updates for the non super was released in Feb 2019.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×