Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
LinkStride

I need help for my Asus TUF Gaming FX505GT

Recommended Posts

Posted · Original PosterOP

My laptop has been having problems for the past 5 days. First it started with the sound output. Apparently I tried doing an update on the Realtek speaker driver, the update got denied. Sadly while doing the update it somewhat uninstalled the original driver so the laptop couldn't detect ant sound outputs nor microphone. I eventually recovered the previous update and installed it, the sound was back. However after the update, the pc messaged that Microsoft store stopped working. I opened it and it was working so I was like wtf. Few minutes later windows gave me the error screen .-.

 

The computer restarted and after I typed the Bios password, the Asus logo popped up, then the screen just stayed on but black. It's been like that ever since. Now I took off the Bios administrative password and Factory Reset  the computer (I went through a lot trust me) and now apparently the bios password is back and it's not the one I used to have. Alt + r doesn't work, tried taking off the CMOS battery (still didn't work) and now I'm here because I gave up. So if anyone knows how to fix this situation, PLEASE I'm stressed and tired.

PS: The picture shows when I press Alt + r

15869957615368950294197994165496.jpg

Link to post
Share on other sites
17 hours ago, LinkStride said:

Not there 

That's super strange that factory reset put a password on your bios, and it's not the same as the one you previously set. Google it extensively, reach out to Asus support for help.  warranty that shyt if you can.  good luck.

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×